summaryrefslogtreecommitdiffstats
path: root/meta/packages/unfs-server/unfs-server-2.2beta47/010-realpath.patch
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2010-08-12 21:02:58 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-20 16:20:09 +0100
commitb5b3825ce6df45b16e1f3e15001da213bc8b0a55 (patch)
treeb2577de0765074d6e2bdbbdf1862220b52e8d7c1 /meta/packages/unfs-server/unfs-server-2.2beta47/010-realpath.patch
parent735210556dc709b3c2367389fa6ea9c0109412b1 (diff)
downloadpoky-b5b3825ce6df45b16e1f3e15001da213bc8b0a55.tar.gz
unfs-server: new userspace nfs recipe
This is a simple userspace NFS server, derived from one which was previously used in openSUSE 10.x. Wind River contributed many of the patches. This package is not intended for target installations, only -native and -nativesdk use. Enabling nativesdk for readline, sqlite3, and pseudo was required, as well as a few new autoconf siteconfig entries. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/packages/unfs-server/unfs-server-2.2beta47/010-realpath.patch')
-rw-r--r--meta/packages/unfs-server/unfs-server-2.2beta47/010-realpath.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/unfs-server/unfs-server-2.2beta47/010-realpath.patch b/meta/packages/unfs-server/unfs-server-2.2beta47/010-realpath.patch
new file mode 100644
index 0000000000..c3b5d58151
--- /dev/null
+++ b/meta/packages/unfs-server/unfs-server-2.2beta47/010-realpath.patch
@@ -0,0 +1,30 @@
1# Patch origin: nfs-server source RPM from openSUSE 10.3
2
3--- nfs-server/configure.in
4+++ nfs-server/configure.in
5@@ -81,7 +81,7 @@
6 AC_CHECK_LIB(rpc, main)
7 AC_CHECK_LIB(crypt, main)
8 AC_CHECK_LIB(nys, main)
9-AC_HAVE_FUNCS(getcwd seteuid setreuid getdtablesize setgroups lchown setsid setfsuid setfsgid innetgr quotactl authdes_getucred)
10+AC_HAVE_FUNCS(getcwd seteuid setreuid getdtablesize setgroups lchown setsid setfsuid setfsgid innetgr quotactl authdes_getucred realpath)
11 AC_AUTHDES_GETUCRED
12 AC_BROKEN_SETFSUID
13 AC_MOUNTLIST
14--- nfs-server/realpath.c
15+++ nfs-server/realpath.c
16@@ -53,6 +53,8 @@
17
18 #define MAX_READLINKS 32
19
20+#ifndef HAVE_REALPATH
21+
22 #ifdef __STDC__
23 char *realpath(const char *path, char resolved_path [])
24 #else
25@@ -173,3 +175,5 @@
26 strcpy (resolved_path, got_path);
27 return resolved_path;
28 }
29+
30+#endif /* HAVE_REALPATH */