diff options
author | Ross Burton <ross@openedhand.com> | 2007-11-05 17:36:00 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2007-11-05 17:36:00 +0000 |
commit | 7676c2b38e649b294bc1332839b3c3a26489dd34 (patch) | |
tree | 6de7024701603e068251830108c09954ef36db4b /meta/packages/ubootchart | |
parent | 2188cf09e11398447a6e59ee8a2819877f90b45c (diff) | |
download | poky-7676c2b38e649b294bc1332839b3c3a26489dd34.tar.gz |
Move ubootchart to meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3072 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/ubootchart')
-rw-r--r-- | meta/packages/ubootchart/files/pass-args.patch | 21 | ||||
-rw-r--r-- | meta/packages/ubootchart/files/sysvinit.patch | 12 | ||||
-rw-r--r-- | meta/packages/ubootchart/files/ubootchart-stop | 3 | ||||
-rw-r--r-- | meta/packages/ubootchart/files/ubootchart.desktop | 6 | ||||
-rw-r--r-- | meta/packages/ubootchart/ubootchart_svn.bb | 38 |
5 files changed, 80 insertions, 0 deletions
diff --git a/meta/packages/ubootchart/files/pass-args.patch b/meta/packages/ubootchart/files/pass-args.patch new file mode 100644 index 0000000000..9ad4282f21 --- /dev/null +++ b/meta/packages/ubootchart/files/pass-args.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | Index: ubootchartd | ||
2 | =================================================================== | ||
3 | --- ubootchartd (revision 9) | ||
4 | +++ ubootchartd (working copy) | ||
5 | @@ -7,9 +7,11 @@ | ||
6 | # can read. | ||
7 | . /etc/ubootchart/ubootchart.conf | ||
8 | |||
9 | -#################################################### | ||
10 | -# Now start capturing the stats: | ||
11 | -#################################################### | ||
12 | -/sbin/ubootchartd_bin & | ||
13 | -exec $init_prog | ||
14 | +if [ $$ -eq 1 ]; then | ||
15 | + #################################################### | ||
16 | + # Now start capturing the stats: | ||
17 | + #################################################### | ||
18 | + /sbin/ubootchartd_bin & | ||
19 | +fi | ||
20 | |||
21 | +exec $init_prog "$@" | ||
diff --git a/meta/packages/ubootchart/files/sysvinit.patch b/meta/packages/ubootchart/files/sysvinit.patch new file mode 100644 index 0000000000..de9fb0b17d --- /dev/null +++ b/meta/packages/ubootchart/files/sysvinit.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Index: ubootchart.conf | ||
2 | =================================================================== | ||
3 | --- ubootchart.conf (revision 9) | ||
4 | +++ ubootchart.conf (working copy) | ||
5 | @@ -1,6 +1,6 @@ | ||
6 | |||
7 | # If you want to chain on and run somthing other than /sbin/init... | ||
8 | -export init_prog=/sbin/init | ||
9 | +export init_prog=/sbin/init.sysvinit | ||
10 | |||
11 | # On startup ubootchart will mount a tmpfs filesystem at this | ||
12 | # location and chdir here. This is only used for the logging of | ||
diff --git a/meta/packages/ubootchart/files/ubootchart-stop b/meta/packages/ubootchart/files/ubootchart-stop new file mode 100644 index 0000000000..3444069c9a --- /dev/null +++ b/meta/packages/ubootchart/files/ubootchart-stop | |||
@@ -0,0 +1,3 @@ | |||
1 | #! /bin/sh | ||
2 | |||
3 | kill -USR1 $(pidof ubootchartd_bin) | ||
diff --git a/meta/packages/ubootchart/files/ubootchart.desktop b/meta/packages/ubootchart/files/ubootchart.desktop new file mode 100644 index 0000000000..5552b3bc6f --- /dev/null +++ b/meta/packages/ubootchart/files/ubootchart.desktop | |||
@@ -0,0 +1,6 @@ | |||
1 | [Desktop Entry] | ||
2 | Encoding=UTF-8 | ||
3 | Exec=/sbin/ubootchart-stop | ||
4 | Name=Stop Bootchart | ||
5 | Type=Application | ||
6 | Categories=Programming; | ||
diff --git a/meta/packages/ubootchart/ubootchart_svn.bb b/meta/packages/ubootchart/ubootchart_svn.bb new file mode 100644 index 0000000000..7ab485c58c --- /dev/null +++ b/meta/packages/ubootchart/ubootchart_svn.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "A boot profiling tool" | ||
2 | HOMEPAGE = "http://code.google.com/p/ubootchart/" | ||
3 | LICENSE = "GPLv3" | ||
4 | PV = "0.0+r${SRCREV}" | ||
5 | PR = "r2" | ||
6 | |||
7 | RRECOMMENDS = "acct" | ||
8 | |||
9 | SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \ | ||
10 | file://sysvinit.patch;patch=1;pnum=0 \ | ||
11 | file://pass-args.patch;patch=1;pnum=0 \ | ||
12 | file://ubootchart-stop \ | ||
13 | file://ubootchart.desktop" | ||
14 | |||
15 | S = "${WORKDIR}/trunk" | ||
16 | |||
17 | inherit update-alternatives | ||
18 | |||
19 | ALTERNATIVE_NAME = "init" | ||
20 | ALTERNATIVE_LINK = "${base_sbindir}/init" | ||
21 | ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd" | ||
22 | ALTERNATIVE_PRIORITY = "20" | ||
23 | |||
24 | do_compile() { | ||
25 | ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin | ||
26 | } | ||
27 | |||
28 | do_install() { | ||
29 | install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications | ||
30 | install -m 0755 ${S}/ubootchartd_bin ${D}/sbin | ||
31 | install -m 0755 ${S}/ubootchartd ${D}/sbin | ||
32 | install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart | ||
33 | install -m 0755 ${S}/start.sh ${D}/etc/ubootchart | ||
34 | install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart | ||
35 | |||
36 | install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin | ||
37 | install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications | ||
38 | } | ||