summaryrefslogtreecommitdiffstats
path: root/meta/packages/ubootchart/ubootchart_svn.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-05 17:36:00 +0000
committerRoss Burton <ross@openedhand.com>2007-11-05 17:36:00 +0000
commit7676c2b38e649b294bc1332839b3c3a26489dd34 (patch)
tree6de7024701603e068251830108c09954ef36db4b /meta/packages/ubootchart/ubootchart_svn.bb
parent2188cf09e11398447a6e59ee8a2819877f90b45c (diff)
downloadpoky-7676c2b38e649b294bc1332839b3c3a26489dd34.tar.gz
Move ubootchart to meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3072 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/ubootchart/ubootchart_svn.bb')
-rw-r--r--meta/packages/ubootchart/ubootchart_svn.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/ubootchart/ubootchart_svn.bb b/meta/packages/ubootchart/ubootchart_svn.bb
new file mode 100644
index 0000000000..7ab485c58c
--- /dev/null
+++ b/meta/packages/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "A boot profiling tool"
2HOMEPAGE = "http://code.google.com/p/ubootchart/"
3LICENSE = "GPLv3"
4PV = "0.0+r${SRCREV}"
5PR = "r2"
6
7RRECOMMENDS = "acct"
8
9SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
10 file://sysvinit.patch;patch=1;pnum=0 \
11 file://pass-args.patch;patch=1;pnum=0 \
12 file://ubootchart-stop \
13 file://ubootchart.desktop"
14
15S = "${WORKDIR}/trunk"
16
17inherit update-alternatives
18
19ALTERNATIVE_NAME = "init"
20ALTERNATIVE_LINK = "${base_sbindir}/init"
21ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd"
22ALTERNATIVE_PRIORITY = "20"
23
24do_compile() {
25 ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
26}
27
28do_install() {
29 install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
30 install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
31 install -m 0755 ${S}/ubootchartd ${D}/sbin
32 install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
33 install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
34 install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
35
36 install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
37 install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
38}