diff options
author | Richard Purdie <richard@openedhand.com> | 2008-10-10 11:56:19 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-10-10 11:56:19 +0000 |
commit | 457ae5ada547f8f03a5963f40e4f403dd0244a2b (patch) | |
tree | cb8a51afe2c96f9c11b7f04f128895e6e3b05d55 /meta/packages/uboot | |
parent | fe795de8f54b4270bc3fcf7b87c06ccf6d837665 (diff) | |
download | poky-457ae5ada547f8f03a5963f40e4f403dd0244a2b.tar.gz |
Add overo
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5477 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/uboot')
-rw-r--r-- | meta/packages/uboot/u-boot-omap3-git/beagleboard/name.patch | 14 | ||||
-rw-r--r-- | meta/packages/uboot/u-boot-omap3_git.bb | 19 | ||||
-rw-r--r-- | meta/packages/uboot/u-boot.inc | 40 |
3 files changed, 73 insertions, 0 deletions
diff --git a/meta/packages/uboot/u-boot-omap3-git/beagleboard/name.patch b/meta/packages/uboot/u-boot-omap3-git/beagleboard/name.patch new file mode 100644 index 0000000000..ac03e47774 --- /dev/null +++ b/meta/packages/uboot/u-boot-omap3-git/beagleboard/name.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | --- git/Makefile.orig 2008-07-25 16:21:22.000000000 -0700 | ||
2 | +++ git/Makefile 2008-07-27 06:49:08.000000000 -0700 | ||
3 | @@ -2582,8 +2582,8 @@ SMN42_config : unconfig | ||
4 | ######################################################################### | ||
5 | ## ARM CORTEX Systems | ||
6 | ######################################################################### | ||
7 | -omap3530beagle_config : unconfig | ||
8 | - @$(MKCONFIG) $(@:_config=) arm omap3 omap3530beagle | ||
9 | +beagleboard_config : unconfig | ||
10 | + @$(MKCONFIG) omap3530beagle arm omap3 omap3530beagle | ||
11 | |||
12 | overo_config : unconfig | ||
13 | @$(MKCONFIG) $(@:_config=) arm omap3 overo | ||
14 | |||
diff --git a/meta/packages/uboot/u-boot-omap3_git.bb b/meta/packages/uboot/u-boot-omap3_git.bb new file mode 100644 index 0000000000..50c85c7ba6 --- /dev/null +++ b/meta/packages/uboot/u-boot-omap3_git.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | require u-boot.inc | ||
2 | |||
3 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-omap3-git/${MACHINE}" | ||
4 | |||
5 | SRCREV = "dcae48d0df9dd0367172677f8154eb2683de0865" | ||
6 | |||
7 | PV = "2008.10-rc2+${PR}+git${SRCREV}" | ||
8 | PR="r2" | ||
9 | |||
10 | SRC_URI = "git://www.sakoman.net/git/u-boot-omap3.git;branch=common;protocol=git \ | ||
11 | " | ||
12 | |||
13 | UBOOT_MACHINE_beagleboard = "omap3_beagle_config" | ||
14 | UBOOT_MACHINE_omap3evm = "omap3_evm_config" | ||
15 | UBOOT_MACHINE_overo = "omap3_overo_config" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/meta/packages/uboot/u-boot.inc b/meta/packages/uboot/u-boot.inc new file mode 100644 index 0000000000..93d6037339 --- /dev/null +++ b/meta/packages/uboot/u-boot.inc | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "U-boot bootloader" | ||
2 | HOMEPAGE = "http://u-boot.sf.net" | ||
3 | SECTION = "bootloaders" | ||
4 | PRIORITY = "optional" | ||
5 | LICENSE = "GPL" | ||
6 | PROVIDES = "virtual/bootloader" | ||
7 | |||
8 | PARALLEL_MAKE="" | ||
9 | |||
10 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" | ||
11 | |||
12 | UBOOT_MACHINE ?= "${MACHINE}_config" | ||
13 | UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin" | ||
14 | UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin" | ||
15 | |||
16 | do_compile () { | ||
17 | unset LDFLAGS | ||
18 | unset CFLAGS | ||
19 | unset CPPFLAGS | ||
20 | oe_runmake ${UBOOT_MACHINE} | ||
21 | oe_runmake all | ||
22 | } | ||
23 | |||
24 | do_deploy () { | ||
25 | install -d ${DEPLOY_DIR_IMAGE} | ||
26 | install ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE} | ||
27 | package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE} | ||
28 | |||
29 | cd ${DEPLOY_DIR_IMAGE} | ||
30 | rm -f ${UBOOT_SYMLINK} | ||
31 | ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK} | ||
32 | package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${UBOOT_SYMLINK} | ||
33 | } | ||
34 | do_deploy[dirs] = "${S}" | ||
35 | addtask deploy before do_build after do_compile | ||
36 | |||
37 | do_stage() { | ||
38 | install -d ${STAGING_BINDIR_NATIVE} | ||
39 | install -m 755 tools/mkimage ${STAGING_BINDIR_NATIVE}/ | ||
40 | } | ||