summaryrefslogtreecommitdiffstats
path: root/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-25 15:47:54 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-25 15:47:54 +0000
commit85e3e7265be8389f65c52f4585ad9b4667c96dc2 (patch)
treeb10bfe0154668dbf0a322f7a379bab1f549da6db /meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
parentc6422207156a33edaf2d8dd72a37ef2d7ce7e966 (diff)
downloadpoky-85e3e7265be8389f65c52f4585ad9b4667c96dc2.tar.gz
u-boot-mkimage-native: use 1.3.2 version instead of Openmoko patched version
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4114 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb')
-rw-r--r--meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
new file mode 100644
index 0000000000..38dd700d08
--- /dev/null
+++ b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPL"
3SECTION = "bootloader"
4
5SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
6 file://fix-arm920t-eabi.patch;patch=1"
7
8S = "${WORKDIR}/u-boot-${PV}"
9
10inherit native
11
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
13
14do_compile () {
15 oe_runmake smdk2410_config
16 oe_runmake tools
17}
18
19do_stage () {
20 install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
21 ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
22}