summaryrefslogtreecommitdiffstats
path: root/meta/packages/tslib
diff options
context:
space:
mode:
authorChris Larson <kergoth@openedhand.com>2006-08-16 22:03:00 +0000
committerChris Larson <kergoth@openedhand.com>2006-08-16 22:03:00 +0000
commitcefc924b29dd6e7d0b06b292f70e60c6178ff405 (patch)
tree28dfbfa75e48aa56e8a57ce64aafd8ae1edf60a9 /meta/packages/tslib
parentca10363baac7de9581ec90ab47957f973e1dbdc4 (diff)
downloadpoky-cefc924b29dd6e7d0b06b292f70e60c6178ff405.tar.gz
Add tslib 1.0 release candidate one.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@608 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/tslib')
-rw-r--r--meta/packages/tslib/tslib_1.0-rc1.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/meta/packages/tslib/tslib_1.0-rc1.bb b/meta/packages/tslib/tslib_1.0-rc1.bb
new file mode 100644
index 0000000000..4b23177d94
--- /dev/null
+++ b/meta/packages/tslib/tslib_1.0-rc1.bb
@@ -0,0 +1,80 @@
1SECTION = "base"
2DESCRIPTION = "tslib is a touchscreen access library."
3PR = "r0"
4SRCDATE_tslib = "now"
5
6SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
7PACKAGE_ARCH_tslib-conf = "${MACHINE_ARCH}"
8PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"
9
10SRC_URI = "svn://svn.berlios.de/svnroot/repos/tslib/tags/tslib;module=${PV};proto=http \
11 file://ts.conf file://ts-2.6.conf \
12 file://ts.conf-h3600-2.4 file://ts.conf-simpad-2.4 \
13 file://ts.conf-corgi-2.4 file://ts.conf-collie-2.4 \
14 file://tslib.sh"
15SRC_URI_append_mnci += " file://devfs.patch;patch=1"
16SRC_URI_append_mnci += " file://event1.patch;patch=1"
17S = "${WORKDIR}/1.0-rc1"
18LICENSE = "LGPL"
19CONFFILES_${PN} = "${sysconfdir}/ts.conf"
20
21inherit autotools pkgconfig
22
23PACKAGES = "tslib-conf libts libts-dev tslib-tests tslib-calibrate"
24EXTRA_OECONF = "--enable-shared"
25EXTRA_OECONF_mnci = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
26EXTRA_OECONF_beagle = "--enable-shared --enable-h3600 --disable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
27
28do_stage () {
29autotools_stage_all
30}
31
32do_install_prepend () {
33 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
34}
35
36do_install_append() {
37 install -d ${D}${sysconfdir}/profile.d/
38 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
39 case ${MACHINE} in
40 h3600 | h3900 | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel)
41 install -d ${D}${datadir}/tslib
42 for f in ts-2.6.conf ts.conf-h3600-2.4; do
43 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
44 done
45 rm -f ${D}${sysconfdir}/ts.conf
46 ;;
47 c7x0 | spitz | akita | tosa )
48 install -d ${D}${datadir}/tslib
49 for f in ts-2.6.conf ts.conf-corgi-2.4; do
50 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
51 done
52 rm -f ${D}${sysconfdir}/ts.conf
53 ;;
54 collie | poodle )
55 install -d ${D}${datadir}/tslib
56 for f in ts-2.6.conf ts.conf-collie-2.4; do
57 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
58 done
59 rm -f ${D}${sysconfdir}/ts.conf
60 ;;
61
62 simpad )
63 install -d ${D}${datadir}/tslib
64 for f in ts-2.6.conf ts.conf-simpad-2.4; do
65 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
66 done
67 rm -f ${D}${sysconfdir}/ts.conf
68 ;;
69 *)
70 ;;
71 esac
72}
73
74RDEPENDS_libts = "tslib-conf"
75
76FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
77FILES_libts = "${libdir}/*.so.* ${libdir}/ts/*.so*"
78FILES_libts-dev = "${FILES_tslib-dev}"
79FILES_tslib-calibrate += "${bindir}/ts_calibrate"
80FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"