diff options
author | Chris Larson <kergoth@openedhand.com> | 2006-08-17 10:00:44 +0000 |
---|---|---|
committer | Chris Larson <kergoth@openedhand.com> | 2006-08-17 10:00:44 +0000 |
commit | d58cfb05fa0b8d6bf93f435713995b46616330cc (patch) | |
tree | 83c809a31cf0ecf0bdee839117c7cac7f5f2ec82 /meta/packages/tslib/tslib_1.0.bb | |
parent | cefc924b29dd6e7d0b06b292f70e60c6178ff405 (diff) | |
download | poky-d58cfb05fa0b8d6bf93f435713995b46616330cc.tar.gz |
Switch from tslib 1.0-rc1 to tslib 1.0.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@609 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/tslib/tslib_1.0.bb')
-rw-r--r-- | meta/packages/tslib/tslib_1.0.bb | 80 |
1 files changed, 80 insertions, 0 deletions
diff --git a/meta/packages/tslib/tslib_1.0.bb b/meta/packages/tslib/tslib_1.0.bb new file mode 100644 index 0000000000..e44d077a92 --- /dev/null +++ b/meta/packages/tslib/tslib_1.0.bb | |||
@@ -0,0 +1,80 @@ | |||
1 | SECTION = "base" | ||
2 | DESCRIPTION = "tslib is a touchscreen access library." | ||
3 | PR = "r0" | ||
4 | SRCDATE_tslib = "now" | ||
5 | |||
6 | SRC_URI_OVERRIDES_PACKAGE_ARCH = "0" | ||
7 | PACKAGE_ARCH_tslib-conf = "${MACHINE_ARCH}" | ||
8 | PACKAGE_ARCH_mnci = "${MACHINE_ARCH}" | ||
9 | |||
10 | SRC_URI = "svn://svn.berlios.de/svnroot/repos/tslib/tags/tslib;module=${PV};proto=http \ | ||
11 | file://ts.conf file://ts-2.6.conf \ | ||
12 | file://ts.conf-h3600-2.4 file://ts.conf-simpad-2.4 \ | ||
13 | file://ts.conf-corgi-2.4 file://ts.conf-collie-2.4 \ | ||
14 | file://tslib.sh" | ||
15 | SRC_URI_append_mnci += " file://devfs.patch;patch=1" | ||
16 | SRC_URI_append_mnci += " file://event1.patch;patch=1" | ||
17 | S = "${WORKDIR}/${PV}" | ||
18 | LICENSE = "LGPL" | ||
19 | CONFFILES_${PN} = "${sysconfdir}/ts.conf" | ||
20 | |||
21 | inherit autotools pkgconfig | ||
22 | |||
23 | PACKAGES = "tslib-conf libts libts-dev tslib-tests tslib-calibrate" | ||
24 | EXTRA_OECONF = "--enable-shared" | ||
25 | EXTRA_OECONF_mnci = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 " | ||
26 | EXTRA_OECONF_beagle = "--enable-shared --enable-h3600 --disable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 " | ||
27 | |||
28 | do_stage () { | ||
29 | autotools_stage_all | ||
30 | } | ||
31 | |||
32 | do_install_prepend () { | ||
33 | install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf | ||
34 | } | ||
35 | |||
36 | do_install_append() { | ||
37 | install -d ${D}${sysconfdir}/profile.d/ | ||
38 | install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/ | ||
39 | case ${MACHINE} in | ||
40 | h3600 | h3900 | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel) | ||
41 | install -d ${D}${datadir}/tslib | ||
42 | for f in ts-2.6.conf ts.conf-h3600-2.4; do | ||
43 | install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/ | ||
44 | done | ||
45 | rm -f ${D}${sysconfdir}/ts.conf | ||
46 | ;; | ||
47 | c7x0 | spitz | akita | tosa ) | ||
48 | install -d ${D}${datadir}/tslib | ||
49 | for f in ts-2.6.conf ts.conf-corgi-2.4; do | ||
50 | install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/ | ||
51 | done | ||
52 | rm -f ${D}${sysconfdir}/ts.conf | ||
53 | ;; | ||
54 | collie | poodle ) | ||
55 | install -d ${D}${datadir}/tslib | ||
56 | for f in ts-2.6.conf ts.conf-collie-2.4; do | ||
57 | install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/ | ||
58 | done | ||
59 | rm -f ${D}${sysconfdir}/ts.conf | ||
60 | ;; | ||
61 | |||
62 | simpad ) | ||
63 | install -d ${D}${datadir}/tslib | ||
64 | for f in ts-2.6.conf ts.conf-simpad-2.4; do | ||
65 | install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/ | ||
66 | done | ||
67 | rm -f ${D}${sysconfdir}/ts.conf | ||
68 | ;; | ||
69 | *) | ||
70 | ;; | ||
71 | esac | ||
72 | } | ||
73 | |||
74 | RDEPENDS_libts = "tslib-conf" | ||
75 | |||
76 | FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib" | ||
77 | FILES_libts = "${libdir}/*.so.* ${libdir}/ts/*.so*" | ||
78 | FILES_libts-dev = "${FILES_tslib-dev}" | ||
79 | FILES_tslib-calibrate += "${bindir}/ts_calibrate" | ||
80 | FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test" | ||