diff options
author | Rob Bradford <rob@linux.intel.com> | 2008-10-29 18:21:50 +0000 |
---|---|---|
committer | Rob Bradford <rob@linux.intel.com> | 2008-10-29 18:22:42 +0000 |
commit | 8cafc7c2cb2a5a3aa52ea04ba524fb1f07d6f17a (patch) | |
tree | b7f5ff89b264bb388c00bcb00ca316ed5a9fc185 /meta/packages/sysvinit | |
parent | 6c298cebbd728b93e94be0087b3a3fdc12d02d65 (diff) | |
download | poky-8cafc7c2cb2a5a3aa52ea04ba524fb1f07d6f17a.tar.gz |
sysvinit: Manage /sbin/poweroff with update-alternatives
Diffstat (limited to 'meta/packages/sysvinit')
-rw-r--r-- | meta/packages/sysvinit/sysvinit_2.86.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/packages/sysvinit/sysvinit_2.86.bb b/meta/packages/sysvinit/sysvinit_2.86.bb index 407ffd3369..5807af3442 100644 --- a/meta/packages/sysvinit/sysvinit_2.86.bb +++ b/meta/packages/sysvinit/sysvinit_2.86.bb | |||
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init." | |||
2 | SECTION = "base" | 2 | SECTION = "base" |
3 | LICENSE = "GPL" | 3 | LICENSE = "GPL" |
4 | HOMEPAGE = "http://freshmeat.net/projects/sysvinit/" | 4 | HOMEPAGE = "http://freshmeat.net/projects/sysvinit/" |
5 | PR = "r31" | 5 | PR = "r32" |
6 | 6 | ||
7 | # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf. | 7 | # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf. |
8 | # Set PACKAGE_ARCH appropriately. | 8 | # Set PACKAGE_ARCH appropriately. |
@@ -97,6 +97,7 @@ EOF | |||
97 | mv ${D}${base_sbindir}/halt ${D}${base_sbindir}/halt.${PN} | 97 | mv ${D}${base_sbindir}/halt ${D}${base_sbindir}/halt.${PN} |
98 | mv ${D}${base_sbindir}/reboot ${D}${base_sbindir}/reboot.${PN} | 98 | mv ${D}${base_sbindir}/reboot ${D}${base_sbindir}/reboot.${PN} |
99 | mv ${D}${base_sbindir}/shutdown ${D}${base_sbindir}/shutdown.${PN} | 99 | mv ${D}${base_sbindir}/shutdown ${D}${base_sbindir}/shutdown.${PN} |
100 | mv ${D}${base_sbindir}/poweroff ${D}${base_sbindir}/poweroff.${PN} | ||
100 | mv ${D}${bindir}/last ${D}${bindir}/last.${PN} | 101 | mv ${D}${bindir}/last ${D}${bindir}/last.${PN} |
101 | mv ${D}${bindir}/mesg ${D}${bindir}/mesg.${PN} | 102 | mv ${D}${bindir}/mesg ${D}${bindir}/mesg.${PN} |
102 | mv ${D}${bindir}/wall ${D}${bindir}/wall.${PN} | 103 | mv ${D}${bindir}/wall ${D}${bindir}/wall.${PN} |
@@ -106,6 +107,7 @@ pkg_postinst_${PN} () { | |||
106 | update-alternatives --install ${base_sbindir}/halt halt halt.${PN} 200 | 107 | update-alternatives --install ${base_sbindir}/halt halt halt.${PN} 200 |
107 | update-alternatives --install ${base_sbindir}/reboot reboot reboot.${PN} 200 | 108 | update-alternatives --install ${base_sbindir}/reboot reboot reboot.${PN} 200 |
108 | update-alternatives --install ${base_sbindir}/shutdown shutdown shutdown.${PN} 200 | 109 | update-alternatives --install ${base_sbindir}/shutdown shutdown shutdown.${PN} 200 |
110 | update-alternatives --install ${base_sbindir}/poweroff poweroff poweroff.${PN} 200 | ||
109 | update-alternatives --install ${bindir}/last last last.${PN} 200 | 111 | update-alternatives --install ${bindir}/last last last.${PN} 200 |
110 | update-alternatives --install ${bindir}/mesg mesg mesg.${PN} 200 | 112 | update-alternatives --install ${bindir}/mesg mesg mesg.${PN} 200 |
111 | update-alternatives --install ${bindir}/wall wall wall.${PN} 200 | 113 | update-alternatives --install ${bindir}/wall wall wall.${PN} 200 |
@@ -115,6 +117,7 @@ pkg_prerm_${PN} () { | |||
115 | update-alternatives --remove halt halt.${PN} | 117 | update-alternatives --remove halt halt.${PN} |
116 | update-alternatives --remove reboot reboot.${PN} | 118 | update-alternatives --remove reboot reboot.${PN} |
117 | update-alternatives --remove shutdown shutdown.${PN} | 119 | update-alternatives --remove shutdown shutdown.${PN} |
120 | update-alternatives --remove poweroff poweroff.${PN} | ||
118 | update-alternatives --remove last last.${PN} | 121 | update-alternatives --remove last last.${PN} |
119 | update-alternatives --remove mesg mesg.${PN} | 122 | update-alternatives --remove mesg mesg.${PN} |
120 | update-alternatives --remove wall wall.${PN} | 123 | update-alternatives --remove wall wall.${PN} |