diff options
author | Richard Purdie <richard@openedhand.com> | 2007-03-28 15:46:02 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2007-03-28 15:46:02 +0000 |
commit | 2693f8dd3e3b5187881cb4e3ef5ede502e6972fb (patch) | |
tree | 5e3862578a9c9418bf5636afabac4bc8d8cced6e /meta/packages/sysvinit | |
parent | 4641d219d2a3d8c0134fc8596a9965794dd8fbb6 (diff) | |
download | poky-2693f8dd3e3b5187881cb4e3ef5ede502e6972fb.tar.gz |
sysvinit: Various progress bar fixes, especially reboot/halt handling
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1406 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/sysvinit')
-rwxr-xr-x | meta/packages/sysvinit/sysvinit/rc | 36 | ||||
-rw-r--r-- | meta/packages/sysvinit/sysvinit_2.86.bb | 2 |
2 files changed, 19 insertions, 19 deletions
diff --git a/meta/packages/sysvinit/sysvinit/rc b/meta/packages/sysvinit/sysvinit/rc index 2abc818eea..30b69ad516 100755 --- a/meta/packages/sysvinit/sysvinit/rc +++ b/meta/packages/sysvinit/sysvinit/rc | |||
@@ -20,12 +20,12 @@ export VERBOSE | |||
20 | 20 | ||
21 | startup_progress() { | 21 | startup_progress() { |
22 | step=$(($step + $step_change)) | 22 | step=$(($step + $step_change)) |
23 | denominator=$(($num_steps + $first_step)) | 23 | if [ "$num_steps" != "0" ]; then |
24 | if [ "$denominator" != "0" ]; then | 24 | progress=$((($step * $progress_size / $num_steps) + $first_step)) |
25 | progress=$(($step * $progress_size / $denominator)) | ||
26 | else | 25 | else |
27 | progress=$progress_size | 26 | progress=$progress_size |
28 | fi | 27 | fi |
28 | #echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size" | ||
29 | if type psplash-write >/dev/null 2>&1; then | 29 | if type psplash-write >/dev/null 2>&1; then |
30 | TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true | 30 | TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true |
31 | fi | 31 | fi |
@@ -91,10 +91,10 @@ startup() { | |||
91 | 91 | ||
92 | case "$runlevel" in | 92 | case "$runlevel" in |
93 | 0|6) | 93 | 0|6) |
94 | # Count down from 0 to -100 and use the entire bar | 94 | # Count down from -100 to 0 and use the entire bar |
95 | first_step=0 | 95 | first_step=-100 |
96 | progress_size=100 | 96 | progress_size=100 |
97 | step_change=-1 | 97 | step_change=1 |
98 | ;; | 98 | ;; |
99 | S) | 99 | S) |
100 | # Begin where the initramfs left off and use 2/3 | 100 | # Begin where the initramfs left off and use 2/3 |
@@ -111,6 +111,17 @@ startup() { | |||
111 | ;; | 111 | ;; |
112 | esac | 112 | esac |
113 | 113 | ||
114 | num_steps=0 | ||
115 | for s in /etc/rc$runlevel.d/[SK]*; do | ||
116 | case "${s##/etc/rc$runlevel.d/S??}" in | ||
117 | gdm|xdm|kdm|reboot|halt) | ||
118 | break | ||
119 | ;; | ||
120 | esac | ||
121 | num_steps=$(($num_steps + 1)) | ||
122 | done | ||
123 | step=0 | ||
124 | |||
114 | # First, run the KILL scripts. | 125 | # First, run the KILL scripts. |
115 | if [ $previous != N ] | 126 | if [ $previous != N ] |
116 | then | 127 | then |
@@ -124,18 +135,6 @@ startup() { | |||
124 | done | 135 | done |
125 | fi | 136 | fi |
126 | 137 | ||
127 | num_steps=0 | ||
128 | for s in /etc/rc$runlevel.d/[SK]*; do | ||
129 | case "${s##/etc/rc$runlevel.d/S??}" in | ||
130 | gdm|xdm|kdm|reboot|halt) | ||
131 | break | ||
132 | ;; | ||
133 | esac | ||
134 | num_steps=$(($num_steps + 1)) | ||
135 | done | ||
136 | |||
137 | step=0 | ||
138 | |||
139 | # Now run the START scripts for this runlevel. | 138 | # Now run the START scripts for this runlevel. |
140 | for i in /etc/rc$runlevel.d/S* | 139 | for i in /etc/rc$runlevel.d/S* |
141 | do | 140 | do |
@@ -168,6 +167,7 @@ startup() { | |||
168 | done | 167 | done |
169 | fi | 168 | fi |
170 | 169 | ||
170 | #Uncomment to cause psplash to exit manually, otherwise it exits when it sees a VC switch | ||
171 | #if [ "x$runlevel" != "xS" ]; then | 171 | #if [ "x$runlevel" != "xS" ]; then |
172 | # if type psplash-write >/dev/null 2>&1; then | 172 | # if type psplash-write >/dev/null 2>&1; then |
173 | # TMPDIR=/mnt/.psplash psplash-write "QUIT" || true | 173 | # TMPDIR=/mnt/.psplash psplash-write "QUIT" || true |
diff --git a/meta/packages/sysvinit/sysvinit_2.86.bb b/meta/packages/sysvinit/sysvinit_2.86.bb index 97b611fe97..885199e542 100644 --- a/meta/packages/sysvinit/sysvinit_2.86.bb +++ b/meta/packages/sysvinit/sysvinit_2.86.bb | |||
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init." | |||
2 | SECTION = "base" | 2 | SECTION = "base" |
3 | LICENSE = "GPL" | 3 | LICENSE = "GPL" |
4 | HOMEPAGE = "http://freshmeat.net/projects/sysvinit/" | 4 | HOMEPAGE = "http://freshmeat.net/projects/sysvinit/" |
5 | PR = "r27" | 5 | PR = "r28" |
6 | 6 | ||
7 | # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf. | 7 | # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf. |
8 | # Set PACKAGE_ARCH appropriately. | 8 | # Set PACKAGE_ARCH appropriately. |