diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-03-25 14:08:12 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-03-25 14:08:12 +0000 |
commit | 91f093a2b26d4574cd5ce68171a2e872ac000047 (patch) | |
tree | 7e7a9a398c220cb71e29559216d2b302058c0612 /meta/packages/syslinux | |
parent | 7ccc04673294c966cb9d212e401b1d90bde0f59f (diff) | |
download | poky-91f093a2b26d4574cd5ce68171a2e872ac000047.tar.gz |
syslinux: Convert to BBCLASSEXTEND, clean up recipe and staging function
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/syslinux')
-rw-r--r-- | meta/packages/syslinux/syslinux-installer-native_3.36.bb | 27 | ||||
-rw-r--r-- | meta/packages/syslinux/syslinux_3.36.bb | 29 |
2 files changed, 13 insertions, 43 deletions
diff --git a/meta/packages/syslinux/syslinux-installer-native_3.36.bb b/meta/packages/syslinux/syslinux-installer-native_3.36.bb deleted file mode 100644 index c304a2d293..0000000000 --- a/meta/packages/syslinux/syslinux-installer-native_3.36.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved | ||
2 | # Released under the MIT license (see packages/COPYING) | ||
3 | |||
4 | DESCRIPTION = "A multi-purpose linux bootloader" | ||
5 | HOMEPAGE = "http://syslinux.zytor.com/" | ||
6 | LICENSE = "GPL" | ||
7 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 " | ||
8 | DEPENDS = "nasm-native" | ||
9 | |||
10 | S = "${WORKDIR}/syslinux-${PV}" | ||
11 | STAGE_TEMP = "${WORKDIR}/stage_temp" | ||
12 | |||
13 | inherit native | ||
14 | |||
15 | do_compile() { | ||
16 | oe_runmake installer | ||
17 | } | ||
18 | |||
19 | NATIVE_INSTALL_WORKS = "1" | ||
20 | do_install() { | ||
21 | install -d ${STAGE_TEMP} | ||
22 | oe_runmake install INSTALLROOT="${STAGE_TEMP}" | ||
23 | |||
24 | install -d ${D}${bindir}/ | ||
25 | install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${D}${bindir}/ | ||
26 | install -m 755 ${STAGE_TEMP}/sbin/extlinux ${D}${bindir}/ | ||
27 | } | ||
diff --git a/meta/packages/syslinux/syslinux_3.36.bb b/meta/packages/syslinux/syslinux_3.36.bb index 8db2055dc9..5073ac358a 100644 --- a/meta/packages/syslinux/syslinux_3.36.bb +++ b/meta/packages/syslinux/syslinux_3.36.bb | |||
@@ -2,32 +2,29 @@ DESCRIPTION = "A multi-purpose linux bootloader" | |||
2 | HOMEPAGE = "http://syslinux.zytor.com/" | 2 | HOMEPAGE = "http://syslinux.zytor.com/" |
3 | LICENSE = "GPL" | 3 | LICENSE = "GPL" |
4 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2" | 4 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2" |
5 | PR = "r1" | 5 | PR = "r3" |
6 | 6 | ||
7 | # If you really want to run syslinux, you need mtools. We just want the | 7 | # If you really want to run syslinux, you need mtools. We just want the |
8 | # ldlinux.* stuff for now, so skip mtools-native | 8 | # ldlinux.* stuff for now, so skip mtools-native |
9 | DEPENDS = "nasm-native" | 9 | DEPENDS = "nasm-native" |
10 | 10 | ||
11 | S = "${WORKDIR}/syslinux-${PV}" | ||
12 | |||
13 | do_configure() { | 11 | do_configure() { |
14 | sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/' | 12 | sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/' |
15 | } | 13 | } |
16 | 14 | ||
17 | STAGE_TEMP = "${WORKDIR}/stage_temp" | ||
18 | |||
19 | COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)' | 15 | COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)' |
20 | 16 | ||
17 | do_compile_virtclass-native () { | ||
18 | oe_runmake installer | ||
19 | } | ||
20 | |||
21 | NATIVE_INSTALL_WORKS = "1" | ||
21 | do_install() { | 22 | do_install() { |
22 | install -d ${STAGE_TEMP} | 23 | oe_runmake install INSTALLROOT="${D}" |
23 | oe_runmake install INSTALLROOT="${STAGE_TEMP}" | 24 | |
24 | 25 | install -d ${D}${libdir}/syslinux/ | |
25 | # When building media, the syslinux binary isn't nearly as useful | 26 | install -m 644 ${S}/ldlinux.sys ${D}${libdir}/syslinux/ |
26 | # as the DOS data files, so we copy those into a special location | 27 | install -m 644 ${S}/ldlinux.bss ${D}${libdir}/syslinux/ |
27 | # for usage during a image build stage | ||
28 | |||
29 | install -d ${D}${datadir}/syslinux/ | ||
30 | install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${D}${datadir}/syslinux/isolinux.bin | ||
31 | install -m 644 ${S}/ldlinux.sys ${D}${datadir}/syslinux/ldlinux.sys | ||
32 | install -m 644 ${S}/ldlinux.bss ${D}${datadir}/syslinux/ldlinux.bss | ||
33 | } | 28 | } |
29 | |||
30 | BBCLASSEXTEND = "native" | ||