diff options
author | Andrzej Zaborowski <andrew@openedhand.com> | 2008-10-20 00:22:07 +0000 |
---|---|---|
committer | Andrzej Zaborowski <andrew@openedhand.com> | 2008-10-20 00:22:07 +0000 |
commit | 3f93ed6bce12da9ece86e3f965e4e667b22fb306 (patch) | |
tree | 3d059c6ebe00f5d19590c4e660696dfc7c0964bd /meta/packages/syslinux | |
parent | 4cb659823ba8f8631d623a870695c79ba352a6ad (diff) | |
download | poky-3f93ed6bce12da9ece86e3f965e4e667b22fb306.tar.gz |
syslinux-native: Try to make syslinux cross-compile friendly.
We only had one package for building both the bootloader and the installer,
i.e. target and host code. It used always the host compiler. Split the
package into syslinux and syslinux-installer-native, require both for a
cd bootable image.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5539 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/syslinux')
-rw-r--r-- | meta/packages/syslinux/syslinux-installer-native_3.36.bb | 26 | ||||
-rw-r--r-- | meta/packages/syslinux/syslinux-native_3.36.bb | 3 | ||||
-rw-r--r-- | meta/packages/syslinux/syslinux.inc | 29 | ||||
-rw-r--r-- | meta/packages/syslinux/syslinux3.inc | 21 | ||||
-rw-r--r-- | meta/packages/syslinux/syslinux_3.36.bb | 14 |
5 files changed, 40 insertions, 53 deletions
diff --git a/meta/packages/syslinux/syslinux-installer-native_3.36.bb b/meta/packages/syslinux/syslinux-installer-native_3.36.bb new file mode 100644 index 0000000000..ae5b73afac --- /dev/null +++ b/meta/packages/syslinux/syslinux-installer-native_3.36.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | # syslinux-native OE build file | ||
2 | # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved | ||
3 | # Released under the MIT license (see packages/COPYING) | ||
4 | |||
5 | DESCRIPTION="A multi-purpose linux bootloader" | ||
6 | HOMEPAGE="http://syslinux.zytor.com/" | ||
7 | LICENSE="GPL" | ||
8 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 " | ||
9 | |||
10 | S="${WORKDIR}/syslinux-${PV}" | ||
11 | STAGE_TEMP="${WORKDIR}/stage_temp" | ||
12 | |||
13 | inherit native | ||
14 | |||
15 | do_compile() { | ||
16 | oe_runmake installer | ||
17 | } | ||
18 | |||
19 | do_stage() { | ||
20 | install -d ${STAGE_TEMP} | ||
21 | oe_runmake install INSTALLROOT="${STAGE_TEMP}" | ||
22 | |||
23 | install -d ${STAGING_BINDIR} | ||
24 | install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR} | ||
25 | install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR} | ||
26 | } | ||
diff --git a/meta/packages/syslinux/syslinux-native_3.36.bb b/meta/packages/syslinux/syslinux-native_3.36.bb deleted file mode 100644 index d9019a4ab4..0000000000 --- a/meta/packages/syslinux/syslinux-native_3.36.bb +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 " | ||
2 | |||
3 | require syslinux3.inc | ||
diff --git a/meta/packages/syslinux/syslinux.inc b/meta/packages/syslinux/syslinux.inc deleted file mode 100644 index 41be168d12..0000000000 --- a/meta/packages/syslinux/syslinux.inc +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | # syslinux-native OE build file | ||
2 | # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved | ||
3 | # Released under the MIT license (see packages/COPYING) | ||
4 | |||
5 | DESCRIPTION="A multi-purpose linux bootloader" | ||
6 | HOMEPAGE="http://syslinux.zytor.com/" | ||
7 | LICENSE="GPL" | ||
8 | |||
9 | # If you really want to run syslinux, you need mtools. We just want the | ||
10 | # ldlinux.* stuff for now, so skip mtools-native | ||
11 | DEPENDS="nasm-native" | ||
12 | |||
13 | S="${WORKDIR}/syslinux-${PV}" | ||
14 | |||
15 | |||
16 | inherit native | ||
17 | |||
18 | do_stage() { | ||
19 | install -d ${STAGING_BINDIR} | ||
20 | install -m 755 ${S}/syslinux ${STAGING_BINDIR} | ||
21 | |||
22 | # When building media, the syslinux binary isn't nearly as useful | ||
23 | # as the DOS data files, so we copy those into a special location | ||
24 | # for usage during a image build stage | ||
25 | |||
26 | install -d ${STAGING_DATADIR}/syslinux | ||
27 | install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys | ||
28 | install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss | ||
29 | } | ||
diff --git a/meta/packages/syslinux/syslinux3.inc b/meta/packages/syslinux/syslinux3.inc deleted file mode 100644 index 95124d6160..0000000000 --- a/meta/packages/syslinux/syslinux3.inc +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | require syslinux.inc | ||
2 | |||
3 | STAGE_TEMP="${WORKDIR}/stage_temp" | ||
4 | |||
5 | do_stage() { | ||
6 | install -d ${STAGE_TEMP} | ||
7 | oe_runmake install INSTALLROOT="${STAGE_TEMP}" | ||
8 | |||
9 | install -d ${STAGING_BINDIR} | ||
10 | install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR} | ||
11 | install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR} | ||
12 | |||
13 | # When building media, the syslinux binary isn't nearly as useful | ||
14 | # as the DOS data files, so we copy those into a special location | ||
15 | # for usage during a image build stage | ||
16 | |||
17 | install -d ${STAGING_DATADIR}/syslinux | ||
18 | install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin | ||
19 | install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys | ||
20 | install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss | ||
21 | } | ||
diff --git a/meta/packages/syslinux/syslinux_3.36.bb b/meta/packages/syslinux/syslinux_3.36.bb new file mode 100644 index 0000000000..4458c1f234 --- /dev/null +++ b/meta/packages/syslinux/syslinux_3.36.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | DESCRIPTION="A multi-purpose linux bootloader" | ||
2 | HOMEPAGE="http://syslinux.zytor.com/" | ||
3 | LICENSE="GPL" | ||
4 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 " | ||
5 | |||
6 | # If you really want to run syslinux, you need mtools. We just want the | ||
7 | # ldlinux.* stuff for now, so skip mtools-native | ||
8 | DEPENDS="nasm-native" | ||
9 | |||
10 | S="${WORKDIR}/syslinux-${PV}" | ||
11 | |||
12 | do_configure() { | ||
13 | sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/' | ||
14 | } | ||