diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:11 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:57 +0100 |
commit | d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch) | |
tree | f36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/sudo | |
parent | caab7fc509bf27706ff3248689f6afd04225cfda (diff) | |
download | poky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz |
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/sudo')
-rw-r--r-- | meta/packages/sudo/files/autofoo.patch | 143 | ||||
-rw-r--r-- | meta/packages/sudo/files/noexec-link.patch | 17 | ||||
-rw-r--r-- | meta/packages/sudo/files/nostrip.patch | 23 | ||||
-rw-r--r-- | meta/packages/sudo/site/bit-32 | 2 | ||||
-rw-r--r-- | meta/packages/sudo/site/bit-64 | 2 | ||||
-rw-r--r-- | meta/packages/sudo/sudo.inc | 36 | ||||
-rw-r--r-- | meta/packages/sudo/sudo_1.7.2p7.bb | 7 |
7 files changed, 0 insertions, 230 deletions
diff --git a/meta/packages/sudo/files/autofoo.patch b/meta/packages/sudo/files/autofoo.patch deleted file mode 100644 index 4f24737610..0000000000 --- a/meta/packages/sudo/files/autofoo.patch +++ /dev/null | |||
@@ -1,143 +0,0 @@ | |||
1 | # fix underquotes, rebased to 1.7.2p7 | ||
2 | # | ||
3 | # by Kevin Tian <kevin.tian@intel.com>, 06/23/2010 | ||
4 | Index: sudo-1.7.2p7/aclocal.m4 | ||
5 | =================================================================== | ||
6 | --- sudo-1.7.2p7.orig/aclocal.m4 2010-06-23 13:33:57.000000000 +0800 | ||
7 | +++ sudo-1.7.2p7/aclocal.m4 2010-06-23 13:36:41.000000000 +0800 | ||
8 | @@ -10,7 +10,7 @@ | ||
9 | dnl | ||
10 | dnl check for sendmail | ||
11 | dnl | ||
12 | -AC_DEFUN(SUDO_PROG_SENDMAIL, [AC_MSG_CHECKING(for sendmail) | ||
13 | +AC_DEFUN([SUDO_PROG_SENDMAIL], [AC_MSG_CHECKING(for sendmail) | ||
14 | if test -f "/usr/sbin/sendmail"; then | ||
15 | AC_MSG_RESULT(/usr/sbin/sendmail) | ||
16 | SUDO_DEFINE(_PATH_SUDO_SENDMAIL, "/usr/sbin/sendmail") | ||
17 | @@ -37,7 +37,7 @@ | ||
18 | dnl | ||
19 | dnl check for vi | ||
20 | dnl | ||
21 | -AC_DEFUN(SUDO_PROG_VI, [AC_MSG_CHECKING(for vi) | ||
22 | +AC_DEFUN([SUDO_PROG_VI], [AC_MSG_CHECKING(for vi) | ||
23 | if test -f "/usr/bin/vi"; then | ||
24 | AC_MSG_RESULT(/usr/bin/vi) | ||
25 | SUDO_DEFINE(_PATH_VI, "/usr/bin/vi") | ||
26 | @@ -61,7 +61,7 @@ | ||
27 | dnl | ||
28 | dnl check for mv | ||
29 | dnl | ||
30 | -AC_DEFUN(SUDO_PROG_MV, [AC_MSG_CHECKING(for mv) | ||
31 | +AC_DEFUN([SUDO_PROG_MV], [AC_MSG_CHECKING(for mv) | ||
32 | if test -f "/usr/bin/mv"; then | ||
33 | AC_MSG_RESULT(/usr/bin/mv) | ||
34 | SUDO_DEFINE(_PATH_MV, "/usr/bin/mv") | ||
35 | @@ -82,7 +82,7 @@ | ||
36 | dnl | ||
37 | dnl check for bourne shell | ||
38 | dnl | ||
39 | -AC_DEFUN(SUDO_PROG_BSHELL, [AC_MSG_CHECKING(for bourne shell) | ||
40 | +AC_DEFUN([SUDO_PROG_BSHELL], [AC_MSG_CHECKING(for bourne shell) | ||
41 | if test -f "/bin/sh"; then | ||
42 | AC_MSG_RESULT(/bin/sh) | ||
43 | SUDO_DEFINE(_PATH_BSHELL, "/bin/sh") | ||
44 | @@ -115,7 +115,7 @@ | ||
45 | dnl | ||
46 | dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm | ||
47 | dnl | ||
48 | -AC_DEFUN(SUDO_LOGFILE, [AC_MSG_CHECKING(for log file location) | ||
49 | +AC_DEFUN([SUDO_LOGFILE], [AC_MSG_CHECKING(for log file location) | ||
50 | if test -n "$with_logpath"; then | ||
51 | AC_MSG_RESULT($with_logpath) | ||
52 | SUDO_DEFINE_UNQUOTED(_PATH_SUDO_LOGFILE, "$with_logpath") | ||
53 | @@ -136,7 +136,7 @@ | ||
54 | dnl | ||
55 | dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm | ||
56 | dnl | ||
57 | -AC_DEFUN(SUDO_TIMEDIR, [AC_MSG_CHECKING(for timestamp file location) | ||
58 | +AC_DEFUN([SUDO_TIMEDIR], [AC_MSG_CHECKING(for timestamp file location) | ||
59 | if test -n "$with_timedir"; then | ||
60 | AC_MSG_RESULT($with_timedir) | ||
61 | SUDO_DEFINE_UNQUOTED(_PATH_SUDO_TIMEDIR, "$with_timedir") | ||
62 | @@ -160,7 +160,7 @@ | ||
63 | dnl SUDO_CHECK_TYPE(TYPE, DEFAULT) | ||
64 | dnl XXX - should require the check for unistd.h... | ||
65 | dnl | ||
66 | -AC_DEFUN(SUDO_CHECK_TYPE, | ||
67 | +AC_DEFUN([SUDO_CHECK_TYPE], | ||
68 | [AC_REQUIRE([AC_HEADER_STDC])dnl | ||
69 | AC_MSG_CHECKING(for $1) | ||
70 | AC_CACHE_VAL(sudo_cv_type_$1, | ||
71 | @@ -181,31 +181,31 @@ | ||
72 | dnl | ||
73 | dnl Check for size_t declation | ||
74 | dnl | ||
75 | -AC_DEFUN(SUDO_TYPE_SIZE_T, | ||
76 | +AC_DEFUN([SUDO_TYPE_SIZE_T], | ||
77 | [SUDO_CHECK_TYPE(size_t, int)]) | ||
78 | |||
79 | dnl | ||
80 | dnl Check for ssize_t declation | ||
81 | dnl | ||
82 | -AC_DEFUN(SUDO_TYPE_SSIZE_T, | ||
83 | +AC_DEFUN([SUDO_TYPE_SSIZE_T], | ||
84 | [SUDO_CHECK_TYPE(ssize_t, int)]) | ||
85 | |||
86 | dnl | ||
87 | dnl Check for dev_t declation | ||
88 | dnl | ||
89 | -AC_DEFUN(SUDO_TYPE_DEV_T, | ||
90 | +AC_DEFUN([SUDO_TYPE_DEV_T], | ||
91 | [SUDO_CHECK_TYPE(dev_t, int)]) | ||
92 | |||
93 | dnl | ||
94 | dnl Check for ino_t declation | ||
95 | dnl | ||
96 | -AC_DEFUN(SUDO_TYPE_INO_T, | ||
97 | +AC_DEFUN([SUDO_TYPE_INO_T], | ||
98 | [SUDO_CHECK_TYPE(ino_t, unsigned int)]) | ||
99 | |||
100 | dnl | ||
101 | dnl check for working fnmatch(3) | ||
102 | dnl | ||
103 | -AC_DEFUN(SUDO_FUNC_FNMATCH, | ||
104 | +AC_DEFUN([SUDO_FUNC_FNMATCH], | ||
105 | [AC_MSG_CHECKING([for working fnmatch with FNM_CASEFOLD]) | ||
106 | AC_CACHE_VAL(sudo_cv_func_fnmatch, | ||
107 | [rm -f conftestdata; > conftestdata | ||
108 | @@ -271,7 +271,7 @@ | ||
109 | dnl | ||
110 | dnl check for sa_len field in struct sockaddr | ||
111 | dnl | ||
112 | -AC_DEFUN(SUDO_SOCK_SA_LEN, | ||
113 | +AC_DEFUN([SUDO_SOCK_SA_LEN], | ||
114 | [AC_MSG_CHECKING(for sa_len field in struct sockaddr) | ||
115 | AC_CACHE_VAL(sudo_cv_sock_sa_len, | ||
116 | [AC_TRY_RUN([#include <sys/types.h> | ||
117 | @@ -294,7 +294,7 @@ | ||
118 | dnl we can't really trust UID_MAX or MAXUID since they may exist | ||
119 | dnl only for backwards compatibility. | ||
120 | dnl | ||
121 | -AC_DEFUN(SUDO_UID_T_LEN, | ||
122 | +AC_DEFUN([SUDO_UID_T_LEN], | ||
123 | [AC_REQUIRE([AC_TYPE_UID_T]) | ||
124 | AC_MSG_CHECKING(max length of uid_t) | ||
125 | AC_CACHE_VAL(sudo_cv_uid_t_len, | ||
126 | @@ -327,7 +327,7 @@ | ||
127 | dnl | ||
128 | dnl Check for presence of long long and for sizeof(long long) == sizeof(long) | ||
129 | dnl | ||
130 | -AC_DEFUN(SUDO_TYPE_LONG_LONG, | ||
131 | +AC_DEFUN([SUDO_TYPE_LONG_LONG], | ||
132 | [AC_CHECK_TYPES(long long, [AC_DEFINE(HAVE_LONG_LONG, 1, [Define if your compiler supports the "long long" type.])] | ||
133 | [AC_MSG_CHECKING(for long and long long equivalence) | ||
134 | AC_CACHE_VAL(sudo_cv_type_long_is_quad, | ||
135 | @@ -347,7 +347,7 @@ | ||
136 | dnl | ||
137 | dnl append a libpath to an LDFLAGS style variable | ||
138 | dnl | ||
139 | -AC_DEFUN(SUDO_APPEND_LIBPATH, [ | ||
140 | +AC_DEFUN([SUDO_APPEND_LIBPATH], [ | ||
141 | if test X"$with_rpath" = X"yes"; then | ||
142 | case "$host" in | ||
143 | *-*-hpux*) $1="${$1} -L$2 -Wl,+b,$2" | ||
diff --git a/meta/packages/sudo/files/noexec-link.patch b/meta/packages/sudo/files/noexec-link.patch deleted file mode 100644 index e0d35d0e25..0000000000 --- a/meta/packages/sudo/files/noexec-link.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | # libtool requires library's name to start with 'lib', or else error is reported. with "-module" option | ||
2 | # that check is skipped | ||
3 | # | ||
4 | # comments added by Kevin Tian <kevin.tian@intel.com>, 06/23/2010 | ||
5 | Index: sudo-1.6.8p6/Makefile.in | ||
6 | =================================================================== | ||
7 | --- sudo-1.6.8p6.orig/Makefile.in 2005-01-21 19:09:26.963276656 -0500 | ||
8 | +++ sudo-1.6.8p6/Makefile.in 2005-01-21 19:16:11.918714072 -0500 | ||
9 | @@ -187,7 +187,7 @@ | ||
10 | $(CC) -o $@ $(TESTOBJS) $(LIBOBJS) $(LDFLAGS) $(LIBS) $(NET_LIBS) | ||
11 | |||
12 | sudo_noexec.la: sudo_noexec.lo | ||
13 | - $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ sudo_noexec.lo -avoid-version -rpath $(noexecdir) | ||
14 | + $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ sudo_noexec.lo -avoid-version -module -rpath $(noexecdir) | ||
15 | |||
16 | # Uncomment the following if you want "make distclean" to clean the parser | ||
17 | @DEV@PARSESRCS = sudo.tab.h sudo.tab.c lex.yy.c def_data.c def_data.h | ||
diff --git a/meta/packages/sudo/files/nostrip.patch b/meta/packages/sudo/files/nostrip.patch deleted file mode 100644 index 3c71b4fd86..0000000000 --- a/meta/packages/sudo/files/nostrip.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | # this could be pushed upstream to allowing conditional strip. Now it's not applied. | ||
2 | # we use sed in recipe for same purpose. Keep here as reminder for upstream | ||
3 | # | ||
4 | # comment added by Kevin Tian <kevin.tian@intel.com>, 07/01/2010 | ||
5 | # | ||
6 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
7 | # | ||
8 | |||
9 | Index: sudo-1.6.8p5/Makefile.in | ||
10 | =================================================================== | ||
11 | --- sudo-1.6.8p5.orig/Makefile.in 2005-01-21 18:19:05.762568976 -0500 | ||
12 | +++ sudo-1.6.8p5/Makefile.in 2005-01-21 18:19:34.701169640 -0500 | ||
13 | @@ -307,8 +307,8 @@ | ||
14 | $(DESTDIR)$(noexecdir) | ||
15 | |||
16 | install-binaries: $(PROGS) | ||
17 | - $(INSTALL) $(install_owncmd) -m 4555 -s sudo $(DESTDIR)$(sudodir)/sudo | ||
18 | - $(INSTALL) $(install_owncmd) -m 0555 -s visudo $(DESTDIR)$(visudodir)/visudo | ||
19 | + $(INSTALL) $(install_owncmd) -m 4555 sudo $(DESTDIR)$(sudodir)/sudo | ||
20 | + $(INSTALL) $(install_owncmd) -m 0555 visudo $(DESTDIR)$(visudodir)/visudo | ||
21 | rm -f $(DESTDIR)$(sudodir)/sudoedit | ||
22 | ln $(DESTDIR)$(sudodir)/sudo $(DESTDIR)$(sudodir)/sudoedit | ||
23 | |||
diff --git a/meta/packages/sudo/site/bit-32 b/meta/packages/sudo/site/bit-32 deleted file mode 100644 index 9b7ca5c81b..0000000000 --- a/meta/packages/sudo/site/bit-32 +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | # is sizeof(long long) == sizeof(long) | ||
2 | sudo_cv_type_long_is_quad=${sudo_cv_type_long_is_quad=no} | ||
diff --git a/meta/packages/sudo/site/bit-64 b/meta/packages/sudo/site/bit-64 deleted file mode 100644 index 05846ff0aa..0000000000 --- a/meta/packages/sudo/site/bit-64 +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | # is sizeof(long long) == sizeof(long) | ||
2 | sudo_cv_type_long_is_quad=${sudo_cv_type_long_is_quad=yes} | ||
diff --git a/meta/packages/sudo/sudo.inc b/meta/packages/sudo/sudo.inc deleted file mode 100644 index 2add94bef4..0000000000 --- a/meta/packages/sudo/sudo.inc +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | DESCRIPTION = "Sudo (superuser do) allows a system administrator to give certain users (or groups of users) the ability to run some (or all) commands as root while logging all commands and arguments." | ||
2 | HOMEPAGE = "http://www.courtesan.com/sudo/" | ||
3 | BUGTRACKER = "http://www.sudo.ws/bugs/" | ||
4 | PRIORITY = "optional" | ||
5 | SECTION = "admin" | ||
6 | LICENSE = "ISC & UCB & MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a7dfe8895011d65d0c2e24aaf5ad0843 \ | ||
8 | file://nonunix.h;startline=4;endline=28;md5=1e70feedac93a3fd7f5254e3fec52677 \ | ||
9 | file://vasgroups.c;startline=4;endline=28;md5=1e70feedac93a3fd7f5254e3fec52677 \ | ||
10 | file://fnmatch.c;startline=6;endline=31;md5=0779058eafd6e23b966585b45bfa54f3 \ | ||
11 | file://getcwd.c;startline=5;endline=27;md5=08d82914995224a0ca42116d7ca2a218 \ | ||
12 | file://glob.c;startline=6;endline=31;md5=299cb38ec8d56e89118ce57fb83b4f78 \ | ||
13 | file://snprintf.c;startline=6;endline=31;md5=dabd56a89a7a773850dc06ee4f1ecde2" | ||
14 | |||
15 | inherit autotools | ||
16 | |||
17 | EXTRA_OECONF = "--with-editor=/bin/vi --with-env-editor" | ||
18 | |||
19 | do_configure_prepend () { | ||
20 | # Prevent binaries from being stripped on the host | ||
21 | sed -i 's/\($(INSTALL).*\) -s \(.*[(sudo|visudo)]\)/\1 \2/g' Makefile.in | ||
22 | |||
23 | rm -f acsite.m4 | ||
24 | if [ ! -e acinclude.m4 ]; then | ||
25 | cat aclocal.m4 > acinclude.m4 | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | pkg_postinst() { | ||
30 | if [ "x$D" != "x" ]; then | ||
31 | exit 1 | ||
32 | fi | ||
33 | |||
34 | chmod 4111 /usr/bin/sudo | ||
35 | chmod 0440 /etc/sudoers | ||
36 | } | ||
diff --git a/meta/packages/sudo/sudo_1.7.2p7.bb b/meta/packages/sudo/sudo_1.7.2p7.bb deleted file mode 100644 index 3dd6cdf059..0000000000 --- a/meta/packages/sudo/sudo_1.7.2p7.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | PR = "r0" | ||
2 | |||
3 | SRC_URI = "http://ftp.sudo.ws/sudo/dist/sudo-1.7.2p7.tar.gz \ | ||
4 | file://noexec-link.patch" | ||
5 | |||
6 | require sudo.inc | ||
7 | EXTRA_OECONF += " --with-pam=no" | ||