summaryrefslogtreecommitdiffstats
path: root/meta/packages/sudo/files/nonrootinstall.patch
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-06-22 11:33:06 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-02 10:35:11 -0700
commit6b81c6dbb55d57a0f8d96ee5e3f5d1e6148850b1 (patch)
tree529a9eeec848c4c258c7282f394a1d1d02fca999 /meta/packages/sudo/files/nonrootinstall.patch
parent14df5714866dcb1b0b93fc9e30dffb4931127de9 (diff)
downloadpoky-6b81c6dbb55d57a0f8d96ee5e3f5d1e6148850b1.tar.gz
sudo: upgrade to 1.7.2p7
Old 1.6.8p12 is quite old, even w/o source available now (only cached in pokylinux). [Patches-Poky] KEEP _autofoo.patch_: deal with bunch of autotool warnings/errors, more about underquotes. In 1.7.2p7, those error conditions disappear. But the underquotes fix is still valid to remove a bunch of autoconf warnings REMOVE _autofoo1.patch_: copy of autofoo.patch. no one uses it. REMOVE. KEEP _noexec-link.patch_: use "-module" to avoid libtool complaining about not starting with "lib". Add comment to the patch file. DISABLE _nostrip.patch_: it's wrong to strip target binaries on build host. Borrow from OE to use 'sed' instead of patch, but keept it for remind to upstream REMOVE _nonrootinstall.patch_: handle mode/owner population at install. It's not requried at all since there's pkg_postinst to handle it at right stage Other misc stuff: - update metadata information - no need to use ${S} in 1.7.2p7 - fix idention - use sed to disable strip - changes from OE: * disable PAM as our pam doesn't include necessary config files and plugs * no need to special sudo_cv_uid_t_len tweak in the recipe. It's already there in poky site files for a long time * move sudo_cv_func_unsetenv_void to meta/site/common. Stdlib.h is common across architectures in our libc headers, which conforms to POSIX standard (borrow from openembedded 1.7.2p4) Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/sudo/files/nonrootinstall.patch')
-rw-r--r--meta/packages/sudo/files/nonrootinstall.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/packages/sudo/files/nonrootinstall.patch b/meta/packages/sudo/files/nonrootinstall.patch
deleted file mode 100644
index db174b373f..0000000000
--- a/meta/packages/sudo/files/nonrootinstall.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6Index: sudo-1.6.8p5/Makefile.in
7===================================================================
8--- sudo-1.6.8p5.orig/Makefile.in 2004-11-25 12:27:00.000000000 -0500
9+++ sudo-1.6.8p5/Makefile.in 2005-01-21 18:02:00.447440568 -0500
10@@ -81,10 +81,16 @@
11 mandirform = $(mandir)/$(mantype)$(mansectform)
12
13 # User and group ids the installed files should be "owned" by
14+ifeq ($(DESTDIR),)
15+install_owncmd = -o $(install_uid) -g $(install_gid)
16+endif
17 install_uid = 0
18 install_gid = 0
19
20 # User, group, and mode the sudoers file should be "owned" by (configure)
21+ifeq ($(DESTDIR),)
22+sudoers_owncmd = -o $(sudoers_uid) -g $(sudoers_gid)
23+endif
24 sudoers_uid = @SUDOERS_UID@
25 sudoers_gid = @SUDOERS_GID@
26 sudoers_mode = @SUDOERS_MODE@
27@@ -301,12 +307,11 @@
28 $(DESTDIR)$(noexecdir)
29
30 install-binaries: $(PROGS)
31- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 4111 -s sudo $(DESTDIR)$(sudodir)/sudo
32+ $(INSTALL) $(install_owncmd) -m 4555 -s sudo $(DESTDIR)$(sudodir)/sudo
33+ $(INSTALL) $(install_owncmd) -m 0555 -s visudo $(DESTDIR)$(visudodir)/visudo
34 rm -f $(DESTDIR)$(sudodir)/sudoedit
35 ln $(DESTDIR)$(sudodir)/sudo $(DESTDIR)$(sudodir)/sudoedit
36
37- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0111 -s visudo $(DESTDIR)$(visudodir)/visudo
38-
39 install-noexec: sudo_noexec.la
40 $(LIBTOOL) --mode=install $(INSTALL) sudo_noexec.la $(DESTDIR)$(noexecdir)
41
42@@ -319,11 +324,11 @@
43 $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
44
45 install-man:
46- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
47+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
48 @rm -f $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
49 ln $(DESTDIR)$(mandirsu)/sudo.$(mansectsu) $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
50- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
51- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
52+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
53+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
54 @MAN_POSTINSTALL@
55
56 check: