summaryrefslogtreecommitdiffstats
path: root/meta/packages/subversion
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/subversion
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/subversion')
-rw-r--r--meta/packages/subversion/subversion-1.5.5/disable-revision-install.patch22
-rw-r--r--meta/packages/subversion/subversion-1.5.5/libtool2.patch15
-rw-r--r--meta/packages/subversion/subversion-1.5.5/neon-detection.patch36
-rw-r--r--meta/packages/subversion/subversion_1.5.5.bb29
4 files changed, 0 insertions, 102 deletions
diff --git a/meta/packages/subversion/subversion-1.5.5/disable-revision-install.patch b/meta/packages/subversion/subversion-1.5.5/disable-revision-install.patch
deleted file mode 100644
index a1c60654cb..0000000000
--- a/meta/packages/subversion/subversion-1.5.5/disable-revision-install.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1--- subversion-1.2.0-r0/Makefile.in.old 2005-07-17 22:28:21.898728312 +0200
2+++ subversion-1.2.0-r0/Makefile.in 2005-07-17 22:30:05.361999504 +0200
3@@ -260,7 +260,7 @@
4 clean: external-clean local-clean
5 distclean: external-distclean local-distclean
6 extraclean: external-extraclean local-extraclean
7-install: external-install local-install revision-install
8+install: external-install local-install #revision-install
9
10 @INCLUDE_OUTPUTS@
11
12@@ -320,8 +320,8 @@
13 local-install: @INSTALL_RULES@
14
15 ### HACK!! Find a better way to do this
16-revision-install:
17- subversion/svnversion/svnversion $(top_srcdir) /repos/svn/trunk > $(DESTDIR)$(includedir)/subversion-1/svn-revision.txt
18+#revision-install:
19+# subversion/svnversion/svnversion $(top_srcdir) /repos/svn/trunk > $(DESTDIR)$(includedir)/subversion-1/svn-revision.txt
20
21 install-static: @INSTALL_STATIC_RULES@
22
diff --git a/meta/packages/subversion/subversion-1.5.5/libtool2.patch b/meta/packages/subversion/subversion-1.5.5/libtool2.patch
deleted file mode 100644
index 08343b09ec..0000000000
--- a/meta/packages/subversion/subversion-1.5.5/libtool2.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1Index: subversion-1.5.5/configure.ac
2===================================================================
3--- subversion-1.5.5.orig/configure.ac 2008-08-26 18:27:56.000000000 +0100
4+++ subversion-1.5.5/configure.ac 2009-01-07 18:00:47.000000000 +0000
5@@ -153,8 +153,8 @@
6 LIBTOOL="$sh_libtool"
7 SVN_LIBTOOL="$sh_libtool"
8 else
9- sh_libtool="$abs_builddir/libtool"
10- SVN_LIBTOOL="\$(SHELL) $sh_libtool"
11+ sh_libtool="$abs_builddir/$host_alias-libtool"
12+ SVN_LIBTOOL="\$(SHELL) \$(abs_builddir)/$host_alias-libtool"
13 dnl libtoolize requires that the following line not be indented
14 ifdef([LT_INIT], [LT_INIT], [AC_PROG_LIBTOOL])
15 fi
diff --git a/meta/packages/subversion/subversion-1.5.5/neon-detection.patch b/meta/packages/subversion/subversion-1.5.5/neon-detection.patch
deleted file mode 100644
index b567d5c050..0000000000
--- a/meta/packages/subversion/subversion-1.5.5/neon-detection.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1diff --git a/build/ac-macros/neon.m4 b/build/ac-macros/neon.m4
2index 9fcf859..8d964f3 100644
3--- a/build/ac-macros/neon.m4
4+++ b/build/ac-macros/neon.m4
5@@ -38,7 +38,7 @@ AC_DEFUN(SVN_LIB_NEON,
6 if test "$withval" = "yes" ; then
7 AC_MSG_ERROR([--with-neon requires an argument.])
8 else
9- neon_config="$withval/bin/neon-config"
10+ neon_config="env env PKG_CONFIG_PATH=${withval}:${PKG_CONFIG_PATH} pkg-config neon"
11 fi
12
13 SVN_NEON_CONFIG()
14@@ -117,10 +117,10 @@ dnl SVN_NEON_CONFIG()
15 dnl neon-config found, gather relevant information from it
16 AC_DEFUN(SVN_NEON_CONFIG,
17 [
18- if test -f "$neon_config"; then
19- if test "$neon_config" != ""; then
20+ if true; then
21+ if true; then
22 AC_MSG_CHECKING([neon library version])
23- NEON_VERSION=`$neon_config --version | sed -e 's/^neon //'`
24+ NEON_VERSION=`$neon_config --modversion | sed -e 's/^neon //'`
25 AC_MSG_RESULT([$NEON_VERSION])
26
27 if test -n "`echo \"$NEON_VERSION\" | grep '^0\.25\.'`" ; then
28@@ -133,7 +133,7 @@ AC_DEFUN(SVN_NEON_CONFIG,
29 test "$svn_allowed_neon" = "any"; then
30 svn_allowed_neon_on_system="yes"
31 SVN_NEON_INCLUDES=[`$neon_config --cflags | sed -e 's/-D[^ ]*//g'`]
32- NEON_LIBS=`$neon_config --la-file`
33+ NEON_LIBS=`$neon_config --libs`
34 CFLAGS=["$CFLAGS `$neon_config --cflags | sed -e 's/-I[^ ]*//g'`"]
35 svn_lib_neon="yes"
36 break
diff --git a/meta/packages/subversion/subversion_1.5.5.bb b/meta/packages/subversion/subversion_1.5.5.bb
deleted file mode 100644
index 8adac8a6fa..0000000000
--- a/meta/packages/subversion/subversion_1.5.5.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1DESCRIPTION = "The Subversion (svn) client"
2SECTION = "console/network"
3DEPENDS = "apr-util neon"
4RDEPENDS = "neon"
5LICENSE = "Apache BSD"
6HOMEPAGE = "http://subversion.tigris.org"
7
8PR = "r6"
9
10SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11 file://disable-revision-install.patch;patch=1 \
12 file://neon-detection.patch;patch=1 \
13 file://libtool2.patch;patch=1"
14
15EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
16 --without-berkeley-db --without-apxs --without-apache \
17 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
18 --with-apr-util=${STAGING_BINDIR_CROSS}"
19
20inherit autotools
21
22export LDFLAGS += " -L${STAGING_LIBDIR} "
23
24acpaths = "-I build/ -I build/ac-macros/"
25
26do_configure_prepend () {
27 rm -f ${S}/libtool
28 rm -f ${S}/build/libtool.m4
29}