summaryrefslogtreecommitdiffstats
path: root/meta/packages/subversion/subversion_1.5.5.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-08 11:29:31 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-08 11:29:31 +0000
commit1daca591dd32df7e810fe279c75296cac437dfa8 (patch)
tree3819b15ee086b57e6a21aecd04109121bcfc4c13 /meta/packages/subversion/subversion_1.5.5.bb
parent9602318b9d662cd888c9e4d8cd382c6706be4eb1 (diff)
downloadpoky-1daca591dd32df7e810fe279c75296cac437dfa8.tar.gz
subversion 1.4.5 -> 1.5.5
Diffstat (limited to 'meta/packages/subversion/subversion_1.5.5.bb')
-rw-r--r--meta/packages/subversion/subversion_1.5.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/subversion/subversion_1.5.5.bb b/meta/packages/subversion/subversion_1.5.5.bb
new file mode 100644
index 0000000000..4a1153ce0b
--- /dev/null
+++ b/meta/packages/subversion/subversion_1.5.5.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "The Subversion (svn) client"
2SECTION = "console/network"
3DEPENDS = "apr-util neon"
4RDEPENDS = "neon"
5LICENSE = "Apache BSD"
6HOMEPAGE = "http://subversion.tigris.org"
7
8PR = "r4"
9
10SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11 file://disable-revision-install.patch;patch=1 \
12 file://neon-detection.patch;patch=1 \
13 file://libtool2.patch;patch=1"
14
15EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
16 --without-berkeley-db --without-apxs --without-apache \
17 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
18 --with-apr-util=${STAGING_BINDIR_CROSS}"
19
20inherit autotools_stage
21
22export LDFLAGS += " -L${STAGING_LIBDIR} "
23
24acpaths = "-I build/ -I build/ac-macros/"
25
26do_configure_prepend () {
27 rm -f ${S}/libtool
28 rm -f ${S}/build/libtool.m4
29}