diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/rsync | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/rsync')
-rw-r--r-- | meta/packages/rsync/files/acinclude.m4 | 95 | ||||
-rw-r--r-- | meta/packages/rsync/files/rsyncd.conf | 15 | ||||
-rw-r--r-- | meta/packages/rsync/rsync.inc | 24 | ||||
-rw-r--r-- | meta/packages/rsync/rsync_2.6.9.bb | 25 | ||||
-rw-r--r-- | meta/packages/rsync/rsync_3.0.7.bb | 18 |
5 files changed, 0 insertions, 177 deletions
diff --git a/meta/packages/rsync/files/acinclude.m4 b/meta/packages/rsync/files/acinclude.m4 deleted file mode 100644 index 735b41dec8..0000000000 --- a/meta/packages/rsync/files/acinclude.m4 +++ /dev/null | |||
@@ -1,95 +0,0 @@ | |||
1 | dnl verbatim renamed from aclocal.m4 in rsync_3.0.7 | ||
2 | dnl 07/06/2010 - qhe | ||
3 | |||
4 | dnl AC_VALIDATE_CACHE_SYSTEM_TYPE[(cmd)] | ||
5 | dnl if the cache file is inconsistent with the current host, | ||
6 | dnl target and build system types, execute CMD or print a default | ||
7 | dnl error message. | ||
8 | AC_DEFUN(AC_VALIDATE_CACHE_SYSTEM_TYPE, [ | ||
9 | AC_REQUIRE([AC_CANONICAL_SYSTEM]) | ||
10 | AC_MSG_CHECKING([config.cache system type]) | ||
11 | if { test x"${ac_cv_host_system_type+set}" = x"set" && | ||
12 | test x"$ac_cv_host_system_type" != x"$host"; } || | ||
13 | { test x"${ac_cv_build_system_type+set}" = x"set" && | ||
14 | test x"$ac_cv_build_system_type" != x"$build"; } || | ||
15 | { test x"${ac_cv_target_system_type+set}" = x"set" && | ||
16 | test x"$ac_cv_target_system_type" != x"$target"; }; then | ||
17 | AC_MSG_RESULT([different]) | ||
18 | ifelse($#, 1, [$1], | ||
19 | [AC_MSG_ERROR(["you must remove config.cache and restart configure"])]) | ||
20 | else | ||
21 | AC_MSG_RESULT([same]) | ||
22 | fi | ||
23 | ac_cv_host_system_type="$host" | ||
24 | ac_cv_build_system_type="$build" | ||
25 | ac_cv_target_system_type="$target" | ||
26 | ]) | ||
27 | |||
28 | dnl Check for socklen_t: historically on BSD it is an int, and in | ||
29 | dnl POSIX 1g it is a type of its own, but some platforms use different | ||
30 | dnl types for the argument to getsockopt, getpeername, etc. So we | ||
31 | dnl have to test to find something that will work. | ||
32 | |||
33 | dnl This is no good, because passing the wrong pointer on C compilers is | ||
34 | dnl likely to only generate a warning, not an error. We don't call this at | ||
35 | dnl the moment. | ||
36 | |||
37 | AC_DEFUN([TYPE_SOCKLEN_T], | ||
38 | [ | ||
39 | AC_CHECK_TYPE([socklen_t], ,[ | ||
40 | AC_MSG_CHECKING([for socklen_t equivalent]) | ||
41 | AC_CACHE_VAL([rsync_cv_socklen_t_equiv], | ||
42 | [ | ||
43 | # Systems have either "struct sockaddr *" or | ||
44 | # "void *" as the second argument to getpeername | ||
45 | rsync_cv_socklen_t_equiv= | ||
46 | for arg2 in "struct sockaddr" void; do | ||
47 | for t in int size_t unsigned long "unsigned long"; do | ||
48 | AC_TRY_COMPILE([ | ||
49 | #include <sys/types.h> | ||
50 | #include <sys/socket.h> | ||
51 | |||
52 | int getpeername (int, $arg2 *, $t *); | ||
53 | ],[ | ||
54 | $t len; | ||
55 | getpeername(0,0,&len); | ||
56 | ],[ | ||
57 | rsync_cv_socklen_t_equiv="$t" | ||
58 | break | ||
59 | ]) | ||
60 | done | ||
61 | done | ||
62 | |||
63 | if test "x$rsync_cv_socklen_t_equiv" = x; then | ||
64 | AC_MSG_ERROR([Cannot find a type to use in place of socklen_t]) | ||
65 | fi | ||
66 | ]) | ||
67 | AC_MSG_RESULT($rsync_cv_socklen_t_equiv) | ||
68 | AC_DEFINE_UNQUOTED(socklen_t, $rsync_cv_socklen_t_equiv, | ||
69 | [type to use in place of socklen_t if not defined])], | ||
70 | [#include <sys/types.h> | ||
71 | #include <sys/socket.h>]) | ||
72 | ]) | ||
73 | |||
74 | dnl AC_HAVE_TYPE(TYPE,INCLUDES) | ||
75 | AC_DEFUN([AC_HAVE_TYPE], [ | ||
76 | AC_REQUIRE([AC_HEADER_STDC]) | ||
77 | cv=`echo "$1" | sed 'y%./+- %__p__%'` | ||
78 | AC_MSG_CHECKING(for $1) | ||
79 | AC_CACHE_VAL([ac_cv_type_$cv], | ||
80 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ | ||
81 | AC_INCLUDES_DEFAULT | ||
82 | $2]], | ||
83 | [[$1 foo;]])], | ||
84 | [eval "ac_cv_type_$cv=yes"], | ||
85 | [eval "ac_cv_type_$cv=no"]))dnl | ||
86 | ac_foo=`eval echo \\$ac_cv_type_$cv` | ||
87 | AC_MSG_RESULT($ac_foo) | ||
88 | if test "$ac_foo" = yes; then | ||
89 | ac_tr_hdr=HAVE_`echo $1 | sed 'y%abcdefghijklmnopqrstuvwxyz./- %ABCDEFGHIJKLMNOPQRSTUVWXYZ____%'` | ||
90 | if false; then | ||
91 | AC_CHECK_TYPES($1) | ||
92 | fi | ||
93 | AC_DEFINE_UNQUOTED($ac_tr_hdr, 1, [Define if you have type `$1']) | ||
94 | fi | ||
95 | ]) | ||
diff --git a/meta/packages/rsync/files/rsyncd.conf b/meta/packages/rsync/files/rsyncd.conf deleted file mode 100644 index 845f5b33f5..0000000000 --- a/meta/packages/rsync/files/rsyncd.conf +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | # /etc/rsyncd.conf | ||
2 | |||
3 | # Minimal configuration file for rsync daemon | ||
4 | # See rsync(1) and rsyncd.conf(5) man pages for help | ||
5 | |||
6 | # This file is required by rsync --daemon | ||
7 | pid file = /var/run/rsyncd.pid | ||
8 | use chroot = yes | ||
9 | read only = yes | ||
10 | |||
11 | # Simple example for enabling your own local rsync server | ||
12 | #[everything] | ||
13 | # path = / | ||
14 | # comment = Everything except /etc exposed | ||
15 | # exclude = /etc | ||
diff --git a/meta/packages/rsync/rsync.inc b/meta/packages/rsync/rsync.inc deleted file mode 100644 index fdc7e37cf6..0000000000 --- a/meta/packages/rsync/rsync.inc +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | DESCRIPTION = "A file-synchronization tool" | ||
2 | HOMEPAGE = "http://rsync.samba.org/" | ||
3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" | ||
4 | SECTION = "console/network" | ||
5 | PRIORITY = "optional" | ||
6 | |||
7 | # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0) | ||
8 | LICENSE = "GPLv3+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
10 | |||
11 | # needs to add acl and attr | ||
12 | DEPENDS = "popt" | ||
13 | |||
14 | SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \ | ||
15 | file://rsyncd.conf" | ||
16 | |||
17 | inherit autotools | ||
18 | |||
19 | do_install_append() { | ||
20 | install -d ${D}/etc | ||
21 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc | ||
22 | } | ||
23 | |||
24 | EXTRA_OEMAKE='STRIP=""' | ||
diff --git a/meta/packages/rsync/rsync_2.6.9.bb b/meta/packages/rsync/rsync_2.6.9.bb deleted file mode 100644 index 43379829ea..0000000000 --- a/meta/packages/rsync/rsync_2.6.9.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | DESCRIPTION = "A file-synchronization tool" | ||
2 | HOMEPAGE = "http://rsync.samba.org/" | ||
3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" | ||
4 | SECTION = "console/network" | ||
5 | PRIORITY = "optional" | ||
6 | |||
7 | # needs to add acl and attr | ||
8 | DEPENDS = "popt" | ||
9 | |||
10 | SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \ | ||
11 | file://rsyncd.conf" | ||
12 | |||
13 | inherit autotools | ||
14 | |||
15 | do_install_append() { | ||
16 | install -d ${D}/etc | ||
17 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc | ||
18 | } | ||
19 | |||
20 | EXTRA_OEMAKE='STRIP=""' | ||
21 | |||
22 | LICENSE = "GPLv2+" | ||
23 | LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c" | ||
24 | |||
25 | PR = "r2" | ||
diff --git a/meta/packages/rsync/rsync_3.0.7.bb b/meta/packages/rsync/rsync_3.0.7.bb deleted file mode 100644 index 3a1e48a61d..0000000000 --- a/meta/packages/rsync/rsync_3.0.7.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | require rsync.inc | ||
2 | |||
3 | PR = "r1" | ||
4 | |||
5 | SRC_URI += "file://acinclude.m4" | ||
6 | |||
7 | EXTRA_OECONF += "--disable-xattr-support --disable-acl-support" | ||
8 | |||
9 | # rsync 3.0 uses configure.sh instead of configure, and | ||
10 | # makefile checks the existence of configure.sh | ||
11 | do_configure_prepend () { | ||
12 | rm -f configure configure.sh | ||
13 | cp -f ${WORKDIR}/acinclude.m4 ${S}/ | ||
14 | } | ||
15 | |||
16 | do_configure_append () { | ||
17 | cp -f configure configure.sh | ||
18 | } | ||