summaryrefslogtreecommitdiffstats
path: root/meta/packages/rsync
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-12-11 13:43:19 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-12-11 13:43:19 +0000
commit4e9ca346a3adf35a2914b46d8ba24c3afaf11cf0 (patch)
tree995fbd0108a560a6b1d62eac774dc2e1ea16f5d6 /meta/packages/rsync
parent66be3d9af77b29d08251034791c60f156d40bb9d (diff)
downloadpoky-4e9ca346a3adf35a2914b46d8ba24c3afaf11cf0.tar.gz
rsync: added 2.6.9 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3328 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/rsync')
-rw-r--r--meta/packages/rsync/files/rsyncd.conf15
-rw-r--r--meta/packages/rsync/rsync_2.6.9.bb17
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/rsync/files/rsyncd.conf b/meta/packages/rsync/files/rsyncd.conf
new file mode 100644
index 0000000000..845f5b33f5
--- /dev/null
+++ b/meta/packages/rsync/files/rsyncd.conf
@@ -0,0 +1,15 @@
1# /etc/rsyncd.conf
2
3# Minimal configuration file for rsync daemon
4# See rsync(1) and rsyncd.conf(5) man pages for help
5
6# This file is required by rsync --daemon
7pid file = /var/run/rsyncd.pid
8use chroot = yes
9read only = yes
10
11# Simple example for enabling your own local rsync server
12#[everything]
13# path = /
14# comment = Everything except /etc exposed
15# exclude = /etc
diff --git a/meta/packages/rsync/rsync_2.6.9.bb b/meta/packages/rsync/rsync_2.6.9.bb
new file mode 100644
index 0000000000..ab7ae43428
--- /dev/null
+++ b/meta/packages/rsync/rsync_2.6.9.bb
@@ -0,0 +1,17 @@
1LICENSE = "GPL"
2DESCRIPTION = "A file-synchronization tool"
3SECTION = "console/network"
4PRIORITY = "optional"
5PR = "r0"
6
7SRC_URI = "http://rsync.samba.org/ftp/rsync/rsync-${PV}.tar.gz \
8 file://rsyncd.conf"
9
10inherit autotools
11
12do_install_append() {
13 install -d ${D}/etc
14 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
15}
16
17EXTRA_OEMAKE='STRIP=""'