summaryrefslogtreecommitdiffstats
path: root/meta/packages/rpm
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-09-07 09:59:57 +0000
committerRichard Purdie <richard@openedhand.com>2008-09-07 09:59:57 +0000
commit4be407b4d92411c2963f31120d9b96a0231faf59 (patch)
treecbcf9561abdb9bd2fe455bd92a09683e5a84d1bb /meta/packages/rpm
parent4a2e4c725da102fa17d6165943bebec79aea2ce9 (diff)
downloadpoky-4be407b4d92411c2963f31120d9b96a0231faf59.tar.gz
rpm: Handle PYTHONVER differently in EXTRA_OECONF to stop gettext/uclibc failures during parsing
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5152 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/rpm')
-rw-r--r--meta/packages/rpm/rpm_4.4.2.3.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/meta/packages/rpm/rpm_4.4.2.3.bb b/meta/packages/rpm/rpm_4.4.2.3.bb
index 6718042f8e..ef6087893c 100644
--- a/meta/packages/rpm/rpm_4.4.2.3.bb
+++ b/meta/packages/rpm/rpm_4.4.2.3.bb
@@ -2,13 +2,15 @@ DESCRIPTION = "The RPM Package Manager."
2HOMEPAGE = "http://rpm.org/" 2HOMEPAGE = "http://rpm.org/"
3LICENSE = "LGPL GPL" 3LICENSE = "LGPL GPL"
4DEPENDS = "zlib beecrypt file popt python" 4DEPENDS = "zlib beecrypt file popt python"
5PR = "r7" 5PR = "r9"
6 6
7SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \ 7SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
8 file://external-tools.patch;patch=1 \ 8 file://external-tools.patch;patch=1 \
9 file://cross_libpaths.patch;patch=1 \ 9 file://cross_libpaths.patch;patch=1 \
10 file://weakdeps.patch;patch=1;pnum=0 \ 10 file://weakdeps.patch;patch=1;pnum=0 \
11 file://tagsbackport.patch;patch=1;pnum=0" 11 file://tagsbackport.patch;patch=1;pnum=0 \
12 file://missingok.patch;patch=1;pnum=0 \
13 file://extcond.patch;patch=1;pnum=0"
12 14
13inherit autotools gettext 15inherit autotools gettext
14 16
@@ -16,9 +18,9 @@ S = "${WORKDIR}/rpm-${PV}"
16 18
17acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java" 19acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
18 20
19EXTRA_OECONF = "--with-python=${PYTHONVER} \ 21EXTRA_OECONF = "--with-python=$PYTHONVER \
20 --with-python-incdir=${STAGING_INCDIR}/python${PYTHONVER} \ 22 --with-python-incdir=${STAGING_INCDIR}/python$PYTHONVER \
21 --with-python-libdir=${STAGING_LIBDIR}/python${PYTHONVER} \ 23 --with-python-libdir=${STAGING_LIBDIR}/python$PYTHONVER \
22 --without-apidocs \ 24 --without-apidocs \
23 --without-selinux \ 25 --without-selinux \
24 --without-lua \ 26 --without-lua \
@@ -97,4 +99,6 @@ def rpm_python_version(d):
97 if os.path.exists( "%s/python2.3" % staging_incdir ): return "2.3" 99 if os.path.exists( "%s/python2.3" % staging_incdir ): return "2.3"
98 raise "No Python in STAGING_INCDIR. Forgot to build python/python-native?" 100 raise "No Python in STAGING_INCDIR. Forgot to build python/python-native?"
99 101
100PYTHONVER = "${@rpm_python_version(d)}" 102# Use a shell variable here since otherwise gettext trys to expand this at
103# parse time when it manipulates EXTRA_OECONF which fails
104export PYTHONVER = "${@rpm_python_version(d)}"