diff options
author | Richard Purdie <richard@openedhand.com> | 2008-08-25 20:37:34 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-08-25 20:37:34 +0000 |
commit | 603e247e23fe95f32a7ea45649c74878dfa49b21 (patch) | |
tree | 1a23cd7d21eefb53631487ccf8deb5def26bfe3a /meta/packages/rpm | |
parent | 16e6877c4ce53fd3be88dd77263a03e7d88c3163 (diff) | |
download | poky-603e247e23fe95f32a7ea45649c74878dfa49b21.tar.gz |
rpm: Enable python extensions and improve cross compiling patches
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5093 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/rpm')
-rw-r--r-- | meta/packages/rpm/files/cross_libpaths.patch | 140 | ||||
-rw-r--r-- | meta/packages/rpm/files/external-tools.patch | 4 | ||||
-rw-r--r-- | meta/packages/rpm/rpm-native_4.4.2.3.bb | 3 | ||||
-rw-r--r-- | meta/packages/rpm/rpm_4.4.2.3.bb | 18 |
4 files changed, 133 insertions, 32 deletions
diff --git a/meta/packages/rpm/files/cross_libpaths.patch b/meta/packages/rpm/files/cross_libpaths.patch index 4fed9b751a..798db15cf0 100644 --- a/meta/packages/rpm/files/cross_libpaths.patch +++ b/meta/packages/rpm/files/cross_libpaths.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | Index: rpm-4.4.2.3/configure.ac | 1 | Index: rpm-4.4.2.3/configure.ac |
2 | =================================================================== | 2 | =================================================================== |
3 | --- rpm-4.4.2.3.orig/configure.ac 2008-08-18 10:25:14.000000000 +0100 | 3 | --- rpm-4.4.2.3.orig/configure.ac 2008-08-23 16:03:51.000000000 +0100 |
4 | +++ rpm-4.4.2.3/configure.ac 2008-08-18 10:25:14.000000000 +0100 | 4 | +++ rpm-4.4.2.3/configure.ac 2008-08-25 16:26:11.000000000 +0100 |
5 | @@ -326,10 +326,8 @@ | 5 | @@ -326,10 +326,8 @@ |
6 | 6 | ||
7 | localdone= | 7 | localdone= |
@@ -40,23 +40,47 @@ Index: rpm-4.4.2.3/configure.ac | |||
40 | WITH_NEON_LIB="-lneon" | 40 | WITH_NEON_LIB="-lneon" |
41 | ]) | 41 | ]) |
42 | ],[ | 42 | ],[ |
43 | @@ -857,6 +856,12 @@ | ||
44 | dnl | ||
45 | dnl Auto-detect which python bindings should be built. | ||
46 | dnl | ||
47 | + | ||
48 | +AC_ARG_WITH(python-incdir, [ --with-python-incdir python include directory ]) | ||
49 | +PYTHON_INCDIR=$withval | ||
50 | +AC_ARG_WITH(python-libdir, [ --with-python-libdir python library directory ]) | ||
51 | +PYTHON_LIBDIR=$withval | ||
52 | + | ||
53 | withval=auto | ||
54 | AC_ARG_WITH(python, [ --with-python build rpm python bindings ]) | ||
55 | |||
56 | @@ -934,6 +939,8 @@ | ||
57 | AC_SUBST(WITH_PYTHON_SUBDIR) | ||
58 | AC_SUBST(WITH_PYTHON_SUBPACKAGE) | ||
59 | AC_SUBST(WITH_PYTHON_VERSION) | ||
60 | +AC_SUBST(PYTHON_LIBDIR) | ||
61 | +AC_SUBST(PYTHON_INCDIR) | ||
62 | |||
63 | AC_PATH_PROG(__DOXYGEN, doxygen, no, $PATH) | ||
64 | dnl | ||
43 | Index: rpm-4.4.2.3/rpmio/Makefile.am | 65 | Index: rpm-4.4.2.3/rpmio/Makefile.am |
44 | =================================================================== | 66 | =================================================================== |
45 | --- rpm-4.4.2.3.orig/rpmio/Makefile.am 2008-04-01 08:28:22.000000000 +0100 | 67 | --- rpm-4.4.2.3.orig/rpmio/Makefile.am 2008-04-01 08:28:22.000000000 +0100 |
46 | +++ rpm-4.4.2.3/rpmio/Makefile.am 2008-08-18 10:25:14.000000000 +0100 | 68 | +++ rpm-4.4.2.3/rpmio/Makefile.am 2008-08-23 12:14:12.000000000 +0100 |
47 | @@ -26,8 +26,6 @@ | 69 | @@ -26,9 +26,7 @@ |
48 | 70 | ||
49 | BEECRYPTLOBJS = $(shell test X"@WITH_BEECRYPT_SUBDIR@" != X && cat $(top_builddir)/@WITH_BEECTYPT_SUBDIR@/listobjs) | 71 | BEECRYPTLOBJS = $(shell test X"@WITH_BEECRYPT_SUBDIR@" != X && cat $(top_builddir)/@WITH_BEECTYPT_SUBDIR@/listobjs) |
50 | 72 | ||
51 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) | 73 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) |
52 | - | 74 | - |
53 | usrlibdir = $(libdir)@MARK64@ | 75 | -usrlibdir = $(libdir)@MARK64@ |
76 | +usrlibdir = $(libdir) | ||
54 | usrlib_LTLIBRARIES = librpmio.la | 77 | usrlib_LTLIBRARIES = librpmio.la |
55 | librpmio_la_SOURCES = \ | 78 | librpmio_la_SOURCES = \ |
79 | argv.c digest.c fts.c macro.c rpmdav.c \ | ||
56 | Index: rpm-4.4.2.3/rpmio/rpmio_internal.h | 80 | Index: rpm-4.4.2.3/rpmio/rpmio_internal.h |
57 | =================================================================== | 81 | =================================================================== |
58 | --- rpm-4.4.2.3.orig/rpmio/rpmio_internal.h 2008-04-01 08:28:22.000000000 +0100 | 82 | --- rpm-4.4.2.3.orig/rpmio/rpmio_internal.h 2008-04-01 08:28:22.000000000 +0100 |
59 | +++ rpm-4.4.2.3/rpmio/rpmio_internal.h 2008-08-18 10:25:14.000000000 +0100 | 83 | +++ rpm-4.4.2.3/rpmio/rpmio_internal.h 2008-08-23 12:07:29.000000000 +0100 |
60 | @@ -12,22 +12,22 @@ | 84 | @@ -12,22 +12,22 @@ |
61 | #if HAVE_BEECRYPT_API_H | 85 | #if HAVE_BEECRYPT_API_H |
62 | #include <api.h> | 86 | #include <api.h> |
@@ -93,7 +117,7 @@ Index: rpm-4.4.2.3/rpmio/rpmio_internal.h | |||
93 | Index: rpm-4.4.2.3/Makefile.am | 117 | Index: rpm-4.4.2.3/Makefile.am |
94 | =================================================================== | 118 | =================================================================== |
95 | --- rpm-4.4.2.3.orig/Makefile.am 2008-04-01 08:28:21.000000000 +0100 | 119 | --- rpm-4.4.2.3.orig/Makefile.am 2008-04-01 08:28:21.000000000 +0100 |
96 | +++ rpm-4.4.2.3/Makefile.am 2008-08-20 08:26:44.000000000 +0100 | 120 | +++ rpm-4.4.2.3/Makefile.am 2008-08-23 12:07:29.000000000 +0100 |
97 | @@ -10,7 +10,7 @@ | 121 | @@ -10,7 +10,7 @@ |
98 | po/*.in po/*.po po/rpm.pot \ | 122 | po/*.in po/*.po po/rpm.pot \ |
99 | rpm.magic rpmpopt-$(VERSION) rpmqv.c | 123 | rpm.magic rpmpopt-$(VERSION) rpmqv.c |
@@ -103,52 +127,118 @@ Index: rpm-4.4.2.3/Makefile.am | |||
103 | 127 | ||
104 | INCLUDES = \ | 128 | INCLUDES = \ |
105 | -I$(top_srcdir)/build \ | 129 | -I$(top_srcdir)/build \ |
106 | @@ -93,7 +93,7 @@ | ||
107 | rpm2cpio_LDFLAGS = $(myLDFLAGS) | ||
108 | rpm2cpio_LDADD = $(myLDADD) @LIBMISC@ | ||
109 | |||
110 | -$(PROGRAMS): $(myLDADD) @WITH_APIDOCS_TARGET@ | ||
111 | +$(PROGRAMS): @WITH_APIDOCS_TARGET@ | ||
112 | |||
113 | .PHONY: splint | ||
114 | splint: | ||
115 | Index: rpm-4.4.2.3/rpmdb/Makefile.am | 130 | Index: rpm-4.4.2.3/rpmdb/Makefile.am |
116 | =================================================================== | 131 | =================================================================== |
117 | --- rpm-4.4.2.3.orig/rpmdb/Makefile.am 2008-04-01 08:28:22.000000000 +0100 | 132 | --- rpm-4.4.2.3.orig/rpmdb/Makefile.am 2008-04-01 08:28:22.000000000 +0100 |
118 | +++ rpm-4.4.2.3/rpmdb/Makefile.am 2008-08-18 10:25:14.000000000 +0100 | 133 | +++ rpm-4.4.2.3/rpmdb/Makefile.am 2008-08-23 12:13:18.000000000 +0100 |
119 | @@ -41,9 +41,6 @@ | 134 | @@ -41,10 +41,7 @@ |
120 | # XXX watchout, ../db3/libdb.la created by this Makefile may surprise | 135 | # XXX watchout, ../db3/libdb.la created by this Makefile may surprise |
121 | libdb_la = $(top_builddir)/$(WITH_DB_SUBDIR)/libdb.la | 136 | libdb_la = $(top_builddir)/$(WITH_DB_SUBDIR)/libdb.la |
122 | 137 | ||
123 | -# XXX grrr, RPM_BUILD_ROOT prevents build pollution if/when -lrpm different | 138 | -# XXX grrr, RPM_BUILD_ROOT prevents build pollution if/when -lrpm different |
124 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) | 139 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) |
125 | - | 140 | - |
126 | usrlibdir = $(libdir)@MARK64@ | 141 | -usrlibdir = $(libdir)@MARK64@ |
142 | +usrlibdir = $(libdir) | ||
127 | usrlib_LTLIBRARIES = librpmdb.la | 143 | usrlib_LTLIBRARIES = librpmdb.la |
128 | librpmdb_la_SOURCES = \ | 144 | librpmdb_la_SOURCES = \ |
145 | dbconfig.c fprint.c \ | ||
129 | Index: rpm-4.4.2.3/lib/Makefile.am | 146 | Index: rpm-4.4.2.3/lib/Makefile.am |
130 | =================================================================== | 147 | =================================================================== |
131 | --- rpm-4.4.2.3.orig/lib/Makefile.am 2008-04-01 08:28:22.000000000 +0100 | 148 | --- rpm-4.4.2.3.orig/lib/Makefile.am 2008-04-01 08:28:22.000000000 +0100 |
132 | +++ rpm-4.4.2.3/lib/Makefile.am 2008-08-18 10:25:14.000000000 +0100 | 149 | +++ rpm-4.4.2.3/lib/Makefile.am 2008-08-23 16:03:51.000000000 +0100 |
133 | @@ -29,8 +29,6 @@ | 150 | @@ -29,9 +29,7 @@ |
134 | mylibs = librpm.la | 151 | mylibs = librpm.la |
135 | LIBS = | 152 | LIBS = |
136 | 153 | ||
137 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) | 154 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) |
138 | - | 155 | - |
139 | usrlibdir = $(libdir)@MARK64@ | 156 | -usrlibdir = $(libdir)@MARK64@ |
157 | +usrlibdir = $(libdir) | ||
140 | usrlib_LTLIBRARIES = librpm.la | 158 | usrlib_LTLIBRARIES = librpm.la |
141 | librpm_la_SOURCES = \ | 159 | librpm_la_SOURCES = \ |
160 | cpio.c depends.c formats.c fs.c fsm.c getdate.c \ | ||
142 | Index: rpm-4.4.2.3/build/Makefile.am | 161 | Index: rpm-4.4.2.3/build/Makefile.am |
143 | =================================================================== | 162 | =================================================================== |
144 | --- rpm-4.4.2.3.orig/build/Makefile.am 2008-04-01 08:28:21.000000000 +0100 | 163 | --- rpm-4.4.2.3.orig/build/Makefile.am 2008-04-01 08:28:21.000000000 +0100 |
145 | +++ rpm-4.4.2.3/build/Makefile.am 2008-08-18 10:25:14.000000000 +0100 | 164 | +++ rpm-4.4.2.3/build/Makefile.am 2008-08-23 16:03:51.000000000 +0100 |
146 | @@ -22,8 +22,6 @@ | 165 | @@ -22,9 +22,7 @@ |
147 | pkginc_HEADERS = rpmbuild.h rpmfc.h rpmfile.h rpmspec.h | 166 | pkginc_HEADERS = rpmbuild.h rpmfc.h rpmfile.h rpmspec.h |
148 | noinst_HEADERS = buildio.h | 167 | noinst_HEADERS = buildio.h |
149 | 168 | ||
150 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) | 169 | -LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir) |
151 | - | 170 | - |
152 | usrlibdir = $(libdir)@MARK64@ | 171 | -usrlibdir = $(libdir)@MARK64@ |
172 | +usrlibdir = $(libdir) | ||
153 | usrlib_LTLIBRARIES = librpmbuild.la | 173 | usrlib_LTLIBRARIES = librpmbuild.la |
154 | librpmbuild_la_SOURCES = \ | 174 | librpmbuild_la_SOURCES = \ |
175 | build.c expression.c files.c misc.c names.c pack.c \ | ||
176 | Index: rpm-4.4.2.3/python/Makefile.am | ||
177 | =================================================================== | ||
178 | --- rpm-4.4.2.3.orig/python/Makefile.am 2008-04-01 08:28:22.000000000 +0100 | ||
179 | +++ rpm-4.4.2.3/python/Makefile.am 2008-08-25 16:26:56.000000000 +0100 | ||
180 | @@ -4,8 +4,8 @@ | ||
181 | |||
182 | LINT = splint | ||
183 | |||
184 | -pylibdir = ${prefix}/lib@MARK64@/python@WITH_PYTHON_VERSION@ | ||
185 | -pyincdir = $(prefix)/include/python@WITH_PYTHON_VERSION@ | ||
186 | +pylibdir = @PYTHON_LIBDIR@ | ||
187 | +pyincdir = @PYTHON_INCDIR@ | ||
188 | |||
189 | SUBDIRS = rpm | ||
190 | |||
191 | Index: rpm-4.4.2.3/python/rpm/Makefile.am | ||
192 | =================================================================== | ||
193 | --- rpm-4.4.2.3.orig/python/rpm/Makefile.am 2008-04-01 08:28:22.000000000 +0100 | ||
194 | +++ rpm-4.4.2.3/python/rpm/Makefile.am 2008-08-25 16:27:29.000000000 +0100 | ||
195 | @@ -4,8 +4,8 @@ | ||
196 | |||
197 | PYVER = @WITH_PYTHON_VERSION@ | ||
198 | |||
199 | -pylibdir = ${prefix}/lib@MARK64@/python@WITH_PYTHON_VERSION@ | ||
200 | -pyincdir = $(prefix)/include/python@WITH_PYTHON_VERSION@ | ||
201 | +pylibdir = @PYTHON_LIBDIR@ | ||
202 | +pyincdir = @PYTHON_INCDIR@ | ||
203 | |||
204 | EXTRA_DIST = \ | ||
205 | __init__.py | ||
206 | Index: rpm-4.4.2.3/file/src/Makefile.am | ||
207 | =================================================================== | ||
208 | --- rpm-4.4.2.3.orig/file/src/Makefile.am 2008-08-23 16:06:25.000000000 +0100 | ||
209 | +++ rpm-4.4.2.3/file/src/Makefile.am 2008-08-23 16:06:39.000000000 +0100 | ||
210 | @@ -4,7 +4,7 @@ | ||
211 | EXTRA_DIST = test.c | ||
212 | |||
213 | # XXX Make sure compress.c links internal zlib | ||
214 | -INCLUDES = -I. -I ../../zlib | ||
215 | +INCLUDES = -I. | ||
216 | |||
217 | pkglibdir = @prefix@/lib/rpm | ||
218 | MAGIC = $(pkglibdir)/magic | ||
219 | @@ -26,7 +26,7 @@ | ||
220 | |||
221 | noinst_PROGRAMS = file | ||
222 | file_SOURCES = file.c | ||
223 | -file_LDFLAGS = -L../../zlib # -all-static | ||
224 | +#file_LDFLAGS = -L../../zlib # -all-static | ||
225 | file_LDADD = libmagic.la | ||
226 | |||
227 | listobjs: | ||
228 | Index: rpm-4.4.2.3/file/magic/Makefile.am | ||
229 | =================================================================== | ||
230 | --- rpm-4.4.2.3.orig/file/magic/Makefile.am 2008-08-25 16:14:47.000000000 +0100 | ||
231 | +++ rpm-4.4.2.3/file/magic/Makefile.am 2008-08-25 16:15:02.000000000 +0100 | ||
232 | @@ -18,10 +18,10 @@ | ||
233 | done >> $@ | ||
234 | |||
235 | magic.mgc: magic | ||
236 | - $(top_builddir)/src/file -C -m magic | ||
237 | + file -C -m magic | ||
238 | |||
239 | magic.mime.mgc: magic.mime | ||
240 | - $(top_builddir)/src/file -C -m $(srcdir)/magic.mime | ||
241 | + file -C -m $(srcdir)/magic.mime | ||
242 | |||
243 | magic_FRAGMENTS = \ | ||
244 | Magdir/acorn \ | ||
diff --git a/meta/packages/rpm/files/external-tools.patch b/meta/packages/rpm/files/external-tools.patch index e967b872fa..2b2ff701ad 100644 --- a/meta/packages/rpm/files/external-tools.patch +++ b/meta/packages/rpm/files/external-tools.patch | |||
@@ -7,7 +7,7 @@ Index: rpm-4.4.2.3/configure.ac | |||
7 | WITH_MAGIC_LIB= | 7 | WITH_MAGIC_LIB= |
8 | 8 | ||
9 | -if test -d file ; then | 9 | -if test -d file ; then |
10 | +if test -d file_disabled ; then | 10 | +if test -d file ; then |
11 | WITH_RPMFILE=rpmfile | 11 | WITH_RPMFILE=rpmfile |
12 | WITH_MAGIC_SUBDIR=file | 12 | WITH_MAGIC_SUBDIR=file |
13 | WITH_MAGIC_INCLUDE="-I\${top_srcdir}/${WITH_MAGIC_SUBDIR}/src" | 13 | WITH_MAGIC_INCLUDE="-I\${top_srcdir}/${WITH_MAGIC_SUBDIR}/src" |
@@ -16,7 +16,7 @@ Index: rpm-4.4.2.3/configure.ac | |||
16 | dnl export LIBS INCPATH CONFIG_SITE | 16 | dnl export LIBS INCPATH CONFIG_SITE |
17 | 17 | ||
18 | -AC_CONFIG_SUBDIRS(popt file db3) | 18 | -AC_CONFIG_SUBDIRS(popt file db3) |
19 | +AC_CONFIG_SUBDIRS(db/dist) | 19 | +AC_CONFIG_SUBDIRS(db/dist file) |
20 | 20 | ||
21 | AC_CONFIG_FILES([ Doxyfile Makefile rpmrc macros platform rpmpopt | 21 | AC_CONFIG_FILES([ Doxyfile Makefile rpmrc macros platform rpmpopt |
22 | rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile | 22 | rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile |
diff --git a/meta/packages/rpm/rpm-native_4.4.2.3.bb b/meta/packages/rpm/rpm-native_4.4.2.3.bb index f122a47aa9..517b571db5 100644 --- a/meta/packages/rpm/rpm-native_4.4.2.3.bb +++ b/meta/packages/rpm/rpm-native_4.4.2.3.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | require rpm_${PV}.bb | 1 | require rpm_${PV}.bb |
2 | inherit native | 2 | inherit native |
3 | 3 | ||
4 | DEPENDS = "beecrypt-native zlib-native file-native popt-native" | 4 | DEPENDS = "beecrypt-native zlib-native file-native popt-native python-native" |
5 | 5 | ||
6 | PR = "r2" | 6 | PR = "r2" |
7 | 7 | ||
8 | export sharedstatedir = "${layout_sharedstatedir}" | 8 | export sharedstatedir = "${layout_sharedstatedir}" |
9 | export localstatedir = "${layout_localstatedir}" | 9 | export localstatedir = "${layout_localstatedir}" |
10 | |||
diff --git a/meta/packages/rpm/rpm_4.4.2.3.bb b/meta/packages/rpm/rpm_4.4.2.3.bb index a568ea8c0e..7edecbcba6 100644 --- a/meta/packages/rpm/rpm_4.4.2.3.bb +++ b/meta/packages/rpm/rpm_4.4.2.3.bb | |||
@@ -1,8 +1,8 @@ | |||
1 | DESCRIPTION = "The RPM Package Manager." | 1 | DESCRIPTION = "The RPM Package Manager." |
2 | HOMEPAGE = "http://rpm.org/" | 2 | HOMEPAGE = "http://rpm.org/" |
3 | LICENSE = "LGPL GPL" | 3 | LICENSE = "LGPL GPL" |
4 | DEPENDS = "zlib beecrypt file popt" | 4 | DEPENDS = "zlib beecrypt file popt python" |
5 | PR = "r2" | 5 | PR = "r3" |
6 | 6 | ||
7 | SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \ | 7 | SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \ |
8 | file://external-tools.patch;patch=1 \ | 8 | file://external-tools.patch;patch=1 \ |
@@ -14,7 +14,9 @@ S = "${WORKDIR}/rpm-${PV}" | |||
14 | 14 | ||
15 | acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java" | 15 | acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java" |
16 | 16 | ||
17 | EXTRA_OECONF = "--without-python \ | 17 | EXTRA_OECONF = "--with-python=${PYTHONVER} \ |
18 | --with-python-incdir=${STAGING_INCDIR}/python${PYTHONVER} \ | ||
19 | --with-python-libdir=${STAGING_LIBDIR}/python${PYTHONVER} \ | ||
18 | --without-apidocs \ | 20 | --without-apidocs \ |
19 | --without-selinux \ | 21 | --without-selinux \ |
20 | --without-lua \ | 22 | --without-lua \ |
@@ -82,3 +84,13 @@ do_configure () { | |||
82 | --with-pic | 84 | --with-pic |
83 | 85 | ||
84 | } | 86 | } |
87 | |||
88 | def rpm_python_version(d): | ||
89 | import os, bb | ||
90 | staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 ) | ||
91 | if os.path.exists( "%s/python2.5" % staging_incdir ): return "2.5" | ||
92 | if os.path.exists( "%s/python2.4" % staging_incdir ): return "2.4" | ||
93 | if os.path.exists( "%s/python2.3" % staging_incdir ): return "2.3" | ||
94 | raise "No Python in STAGING_INCDIR. Forgot to build python/python-native?" | ||
95 | |||
96 | PYTHONVER = "${@rpm_python_version(d)}" | ||