summaryrefslogtreecommitdiffstats
path: root/meta/packages/rpm/rpm_4.4.2.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-18 08:03:18 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-18 08:03:18 +0000
commit9add0a8cc54b4faec3441083eadc259a293e6052 (patch)
treee4c442b9bbfa4c0f4e30d2a619dca28a332f7112 /meta/packages/rpm/rpm_4.4.2.3.bb
parente8f85b3787befaa58a52ea3f61ceb31e2fd7eb51 (diff)
downloadpoky-9add0a8cc54b4faec3441083eadc259a293e6052.tar.gz
rpm/rpm-native: Add recipe for 4.4.2.3
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5069 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/rpm/rpm_4.4.2.3.bb')
-rw-r--r--meta/packages/rpm/rpm_4.4.2.3.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/packages/rpm/rpm_4.4.2.3.bb b/meta/packages/rpm/rpm_4.4.2.3.bb
new file mode 100644
index 0000000000..b04b500b86
--- /dev/null
+++ b/meta/packages/rpm/rpm_4.4.2.3.bb
@@ -0,0 +1,84 @@
1DESCRIPTION = "The RPM Package Manager."
2HOMEPAGE = "http://rpm.org/"
3LICENSE = "LGPL GPL"
4DEPENDS = "zlib beecrypt file popt"
5PR = "r1"
6
7SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
8 file://external-tools.patch;patch=1 \
9 file://cross_libpaths.patch;patch=1"
10
11inherit autotools gettext
12
13S = "${WORKDIR}/rpm-${PV}"
14
15acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
16
17EXTRA_OECONF = "--without-python \
18 --without-apidocs \
19 --without-selinux \
20 --without-lua \
21 --without-dmalloc \
22 --without-efence"
23
24# Handle the db MUTEX settings here, the POSIX library is
25# the default - "POSIX/pthreads/library".
26# Don't ignore the nice SWP instruction on the ARM:
27# These enable the ARM assembler mutex code, this won't
28# work with thumb compilation...
29ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
30MUTEX = ""
31MUTEX_arm = "${ARM_MUTEX}"
32MUTEX_armeb = "${ARM_MUTEX}"
33EXTRA_OECONF += "${MUTEX}"
34
35do_configure () {
36 rm ${S}/popt/ -Rf
37 rm ${S}/db/dist/configure.in -f
38 cd ${S}/db/dist/aclocal
39 rm libtool* -f
40 for i in `ls *.ac`; do
41 j=`echo $i | sed 's/.ac/.m4/g'`
42 mv $i $j
43 done
44 cd ${S}/db/dist/aclocal_java
45 for i in `ls *.ac`; do
46 j=`echo $i | sed 's/.ac/.m4/g'`
47 mv $i $j
48 done
49 cd ${S}
50 autotools_do_configure
51 cd ${S}/db/dist
52 . ./RELEASE
53 # Edit version information we couldn't pre-compute.
54 (echo "1,\$s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" &&
55 echo "1,\$s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" &&
56 echo "1,\$s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" &&
57 echo "1,\$s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" &&
58 echo "1,\$s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" &&
59 echo "1,\$s/__EDIT_DB_VERSION__/$DB_VERSION/g" &&
60 echo "w" &&
61 echo "q") | ed configure
62 cd ${S}/db3
63 ${S}/db3/configure \
64 --build=${BUILD_SYS} \
65 --host=${HOST_SYS} \
66 --target=${TARGET_SYS} \
67 --prefix=${prefix} \
68 --exec_prefix=${exec_prefix} \
69 --bindir=${bindir} \
70 --sbindir=${sbindir} \
71 --libexecdir=${libexecdir} \
72 --datadir=${datadir} \
73 --sysconfdir=${sysconfdir} \
74 --sharedstatedir=${sharedstatedir} \
75 --localstatedir=${localstatedir} \
76 --libdir=${libdir} \
77 --includedir=${includedir} \
78 --oldincludedir=${oldincludedir} \
79 --infodir=${infodir} \
80 --mandir=${mandir} \
81 ${EXTRA_OECONF} \
82 --with-pic
83
84}