summaryrefslogtreecommitdiffstats
path: root/meta/packages/readline
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-06-17 10:37:07 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:19:03 +0100
commit6d275f76675851f5080d292ab00d285b4eb0ee01 (patch)
tree00cd2c7618d4066af9b485610088fe33f84eb2a8 /meta/packages/readline
parent90747bcf0076928c6d176478f61ea6c6a07fbf33 (diff)
downloadpoky-6d275f76675851f5080d292ab00d285b4eb0ee01.tar.gz
readline: update to version 6.1
from 5.2 version 5.2 is still kept since it's the latest version under GPLv2+. changes: - change autotools_do_configure and use do_configure_prepend - similar to do_install_append Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/readline')
-rw-r--r--meta/packages/readline/files/acinclude.m4 (renamed from meta/packages/readline/readline-5.2/acinclude.m4)0
-rw-r--r--meta/packages/readline/files/configure-fix.patch (renamed from meta/packages/readline/readline-5.2/configure_fix.patch)0
-rw-r--r--meta/packages/readline/readline.inc35
-rw-r--r--meta/packages/readline/readline_5.2.bb36
-rw-r--r--meta/packages/readline/readline_6.1.bb3
5 files changed, 42 insertions, 32 deletions
diff --git a/meta/packages/readline/readline-5.2/acinclude.m4 b/meta/packages/readline/files/acinclude.m4
index 8a45f99084..8a45f99084 100644
--- a/meta/packages/readline/readline-5.2/acinclude.m4
+++ b/meta/packages/readline/files/acinclude.m4
diff --git a/meta/packages/readline/readline-5.2/configure_fix.patch b/meta/packages/readline/files/configure-fix.patch
index 4100fe42a7..4100fe42a7 100644
--- a/meta/packages/readline/readline-5.2/configure_fix.patch
+++ b/meta/packages/readline/files/configure-fix.patch
diff --git a/meta/packages/readline/readline.inc b/meta/packages/readline/readline.inc
new file mode 100644
index 0000000000..f8bb45abea
--- /dev/null
+++ b/meta/packages/readline/readline.inc
@@ -0,0 +1,35 @@
1DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
3additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
4lines, and perform csh-like history expansion on previous commands."
5SECTION = "libs"
6PRIORITY = "optional"
7
8# GPLv2+ (< 6.0), GPLv3+ (>= 6.0)
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12DEPENDS += "ncurses"
13RPROVIDES_${PN} += "readline"
14
15SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz \
16 file://configure-fix.patch \
17 file://acinclude.m4"
18
19S = "${WORKDIR}/${BPN}-${PV}"
20
21inherit autotools
22
23LEAD_SONAME = "libreadline.so"
24
25do_configure_prepend () {
26 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
27}
28
29do_install_append () {
30 # Make install doesn't properly install these
31 oe_libinstall -so -C shlib libhistory ${D}${libdir}
32 oe_libinstall -so -C shlib libreadline ${D}${libdir}
33}
34
35BBCLASSEXTEND = "native"
diff --git a/meta/packages/readline/readline_5.2.bb b/meta/packages/readline/readline_5.2.bb
index 10ce18fe9a..10f88ce196 100644
--- a/meta/packages/readline/readline_5.2.bb
+++ b/meta/packages/readline/readline_5.2.bb
@@ -1,33 +1,5 @@
1DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \ 1require readline.inc
2command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
3additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
4lines, and perform csh-like history expansion on previous commands."
5SECTION = "libs"
6PRIORITY = "optional"
7LICENSE = "GPLv2"
8DEPENDS += "ncurses"
9RPROVIDES_${PN} += "readline"
10LEAD_SONAME = "libreadline.so"
11PR = "r4"
12 2
13SRC_URI = "ftp://ftp.gnu.org/gnu/readline/readline-${PV}.tar.gz \ 3LICENSE = "GPLv2+"
14 file://configure_fix.patch;patch=1 \ 4LIC_FILES_CHKSUM = "file://COPYING;md5=03b36fdd84f74b8d8189a202b980b67f"
15 file://acinclude.m4" 5PR = "r5"
16
17S = "${WORKDIR}/readline-${PV}"
18
19inherit autotools
20
21do_configure () {
22 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
23 autotools_do_configure
24}
25
26do_install () {
27 autotools_do_install
28 # Make install doesn't properly install these
29 oe_libinstall -so -C shlib libhistory ${D}${libdir}
30 oe_libinstall -so -C shlib libreadline ${D}${libdir}
31}
32
33BBCLASSEXTEND = "native"
diff --git a/meta/packages/readline/readline_6.1.bb b/meta/packages/readline/readline_6.1.bb
new file mode 100644
index 0000000000..c32755669c
--- /dev/null
+++ b/meta/packages/readline/readline_6.1.bb
@@ -0,0 +1,3 @@
1require readline.inc
2
3PR = "r0"