diff options
author | Joshua Lock <josh@linux.intel.com> | 2010-06-15 12:22:01 +0100 |
---|---|---|
committer | Joshua Lock <josh@linux.intel.com> | 2010-06-15 12:33:11 +0100 |
commit | c87bf0cfc656b4ae32b5e6ea926a71135b609a2e (patch) | |
tree | 8e561e344145ee4188487c8a53d7582b28dfb018 /meta/packages/qemu | |
parent | 5101076eab596d966e5a8a5ef749a48c5334a17e (diff) | |
download | poky-c87bf0cfc656b4ae32b5e6ea926a71135b609a2e.tar.gz |
qemu: Fix linking of the native package on Fedora 13
Fedora 13 switched the default behaviour of the linker to no longer
indirectly link to required libraries (i.e. dependencies of a library
already linked to). Therefore we need to explicitly pass the depended on
libraries into the linker for building to work on Fedora 13.
Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r-- | meta/packages/qemu/qemu-0.12.4/linker-flags.patch | 22 | ||||
-rw-r--r-- | meta/packages/qemu/qemu.inc | 2 | ||||
-rw-r--r-- | meta/packages/qemu/qemu_0.12.4.bb | 15 | ||||
-rw-r--r-- | meta/packages/qemu/qemu_git.bb | 15 |
4 files changed, 39 insertions, 15 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/linker-flags.patch b/meta/packages/qemu/qemu-0.12.4/linker-flags.patch new file mode 100644 index 0000000000..7b33aa4840 --- /dev/null +++ b/meta/packages/qemu/qemu-0.12.4/linker-flags.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | Fedora 13 switched the default behaviour of the linker to no longer | ||
2 | indirectly link to required libraries (i.e. dependencies of a library | ||
3 | already linked to). Therefore we need to explicitly pass the depended on | ||
4 | libraries into the linker for building to work on Fedora 13. | ||
5 | |||
6 | More information is available on the Fedora Wiki: | ||
7 | https://fedoraproject.org/wiki/UnderstandingDSOLinkChange | ||
8 | |||
9 | JL - 15/06/10 | ||
10 | Index: qemu-0.12.4/Makefile.target | ||
11 | =================================================================== | ||
12 | --- qemu-0.12.4.orig/Makefile.target 2010-06-15 11:21:52.000000000 +0100 | ||
13 | +++ qemu-0.12.4/Makefile.target 2010-06-15 11:25:27.212852910 +0100 | ||
14 | @@ -178,7 +178,7 @@ | ||
15 | obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-pci.o | ||
16 | obj-$(CONFIG_KVM) += kvm.o kvm-all.o | ||
17 | obj-$(CONFIG_ISA_MMIO) += isa_mmio.o | ||
18 | -LIBS+=-lz | ||
19 | +LIBS+=-lz -lX11 -ldl | ||
20 | |||
21 | sound-obj-y = | ||
22 | sound-obj-$(CONFIG_SB16) += sb16.o | ||
diff --git a/meta/packages/qemu/qemu.inc b/meta/packages/qemu/qemu.inc index 0a0de2cc4c..c744990d0f 100644 --- a/meta/packages/qemu/qemu.inc +++ b/meta/packages/qemu/qemu.inc | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://qemu.org" | |||
3 | LICENSE = "GPL" | 3 | LICENSE = "GPL" |
4 | DEPENDS = "zlib" | 4 | DEPENDS = "zlib" |
5 | 5 | ||
6 | EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls --extra-ldflags=-ldl" | 6 | EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls" |
7 | #EXTRA_OECONF += "--disable-sdl" | 7 | #EXTRA_OECONF += "--disable-sdl" |
8 | 8 | ||
9 | inherit autotools | 9 | inherit autotools |
diff --git a/meta/packages/qemu/qemu_0.12.4.bb b/meta/packages/qemu/qemu_0.12.4.bb index 43a40c2a27..79b73d38ad 100644 --- a/meta/packages/qemu/qemu_0.12.4.bb +++ b/meta/packages/qemu/qemu_0.12.4.bb | |||
@@ -1,17 +1,18 @@ | |||
1 | require qemu.inc | 1 | require qemu.inc |
2 | 2 | ||
3 | PR = "r13" | 3 | PR = "r14" |
4 | 4 | ||
5 | FILESPATH = "${FILE_DIRNAME}/qemu-${PV}" | 5 | FILESPATH = "${FILE_DIRNAME}/qemu-${PV}" |
6 | FILESDIR = "${WORKDIR}" | 6 | FILESDIR = "${WORKDIR}" |
7 | 7 | ||
8 | SRC_URI = "\ | 8 | SRC_URI = "\ |
9 | http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz \ | 9 | http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz \ |
10 | file://workaround_bad_futex_headers.patch;patch=1 \ | 10 | file://workaround_bad_futex_headers.patch \ |
11 | file://qemu-git-qemugl-host.patch;patch=1 \ | 11 | file://qemu-git-qemugl-host.patch \ |
12 | file://no-strip.patch;patch=1 \ | 12 | file://no-strip.patch \ |
13 | file://fix-dirent.patch;patch=1 \ | 13 | file://fix-dirent.patch \ |
14 | file://fix-nogl.patch;patch=1 \ | 14 | file://fix-nogl.patch \ |
15 | file://qemugl-allow-glxcontext-release.patch;patch=1" | 15 | file://qemugl-allow-glxcontext-release.patch \ |
16 | file://linker-flags.patch" | ||
16 | 17 | ||
17 | S = "${WORKDIR}/qemu-${PV}" | 18 | S = "${WORKDIR}/qemu-${PV}" |
diff --git a/meta/packages/qemu/qemu_git.bb b/meta/packages/qemu/qemu_git.bb index 8f39f5b6f8..b1468704ac 100644 --- a/meta/packages/qemu/qemu_git.bb +++ b/meta/packages/qemu/qemu_git.bb | |||
@@ -1,19 +1,20 @@ | |||
1 | require qemu.inc | 1 | require qemu.inc |
2 | 2 | ||
3 | PV = "0.12.4" | 3 | PV = "0.12.4" |
4 | PR = "r7" | 4 | PR = "r8" |
5 | 5 | ||
6 | FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/" | 6 | FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/" |
7 | FILESDIR = "${WORKDIR}" | 7 | FILESDIR = "${WORKDIR}" |
8 | 8 | ||
9 | SRC_URI = "\ | 9 | SRC_URI = "\ |
10 | git://git.sv.gnu.org/qemu.git;protocol=git \ | 10 | git://git.sv.gnu.org/qemu.git;protocol=git \ |
11 | file://workaround_bad_futex_headers.patch;patch=1 \ | 11 | file://workaround_bad_futex_headers.patch \ |
12 | file://qemu-git-qemugl-host.patch;patch=1 \ | 12 | file://qemu-git-qemugl-host.patch \ |
13 | file://no-strip.patch;patch=1 \ | 13 | file://no-strip.patch \ |
14 | file://fix-dirent.patch;patch=1 \ | 14 | file://fix-dirent.patch \ |
15 | file://fix-nogl.patch;patch=1 \ | 15 | file://fix-nogl.patch \ |
16 | file://qemugl-allow-glxcontext-release.patch;patch=1" | 16 | file://qemugl-allow-glxcontext-release.patch \ |
17 | file://linker-flags.patch" | ||
17 | 18 | ||
18 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
19 | 20 | ||