diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-08-09 14:02:59 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-08-09 14:02:59 +0000 |
commit | d1798db3ca4cb25ffc4bc46d3f87f932a2940486 (patch) | |
tree | de6504e78f51a251d4f9169f60c351097ada873e /meta/packages/qemu | |
parent | 62f662256a6cd1e55849e98715d0d3a654d7f78a (diff) | |
download | poky-d1798db3ca4cb25ffc4bc46d3f87f932a2940486.tar.gz |
qemu: fix lack of MAP_32BIT on 32bit machines
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2475 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r-- | meta/packages/qemu/files/qemu-amd64-32b-mapping-0.9.0.patch | 20 | ||||
-rw-r--r-- | meta/packages/qemu/qemu_cvs.bb | 2 |
2 files changed, 16 insertions, 6 deletions
diff --git a/meta/packages/qemu/files/qemu-amd64-32b-mapping-0.9.0.patch b/meta/packages/qemu/files/qemu-amd64-32b-mapping-0.9.0.patch index 8f5e9d8b4b..d9303e3464 100644 --- a/meta/packages/qemu/files/qemu-amd64-32b-mapping-0.9.0.patch +++ b/meta/packages/qemu/files/qemu-amd64-32b-mapping-0.9.0.patch | |||
@@ -1,7 +1,17 @@ | |||
1 | diff -Naru qemu-snapshot-2007-07-01_05.orig/linux-user/mmap.c qemu-snapshot-2007-07-01_05/linux-user/mmap.c | 1 | --- qemu.orig/linux-user/mmap.c |
2 | --- qemu-snapshot-2007-07-01_05.orig/linux-user/mmap.c 2007-06-03 17:31:32.000000000 +0200 | 2 | +++ qemu/linux-user/mmap.c |
3 | +++ qemu-snapshot-2007-07-01_05/linux-user/mmap.c 2007-07-02 14:00:30.000000000 +0200 | 3 | @@ -29,6 +29,10 @@ |
4 | @@ -234,7 +234,7 @@ | 4 | |
5 | //#define DEBUG_MMAP | ||
6 | |||
7 | +#ifndef MAP_32BIT | ||
8 | +#define MAP_32BIT 0 | ||
9 | +#endif | ||
10 | + | ||
11 | /* NOTE: all the constants are the HOST ones, but addresses are target. */ | ||
12 | int target_mprotect(target_ulong start, target_ulong len, int prot) | ||
13 | { | ||
14 | @@ -234,7 +238,7 @@ | ||
5 | host_offset = offset & qemu_host_page_mask; | 15 | host_offset = offset & qemu_host_page_mask; |
6 | host_len = len + offset - host_offset; | 16 | host_len = len + offset - host_offset; |
7 | host_start = (long)mmap(real_start ? g2h(real_start) : NULL, | 17 | host_start = (long)mmap(real_start ? g2h(real_start) : NULL, |
@@ -10,7 +20,7 @@ diff -Naru qemu-snapshot-2007-07-01_05.orig/linux-user/mmap.c qemu-snapshot-2007 | |||
10 | if (host_start == -1) | 20 | if (host_start == -1) |
11 | return host_start; | 21 | return host_start; |
12 | /* update start so that it points to the file position at 'offset' */ | 22 | /* update start so that it points to the file position at 'offset' */ |
13 | @@ -388,7 +388,7 @@ | 23 | @@ -388,7 +392,7 @@ |
14 | int prot; | 24 | int prot; |
15 | 25 | ||
16 | /* XXX: use 5 args syscall */ | 26 | /* XXX: use 5 args syscall */ |
diff --git a/meta/packages/qemu/qemu_cvs.bb b/meta/packages/qemu/qemu_cvs.bb index 740bf12589..29d68438ae 100644 --- a/meta/packages/qemu/qemu_cvs.bb +++ b/meta/packages/qemu/qemu_cvs.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | LICENSE = "GPL" | 1 | LICENSE = "GPL" |
2 | DEPENDS = "zlib" | 2 | DEPENDS = "zlib" |
3 | PV = "0.9.0+cvs${SRCDATE}" | 3 | PV = "0.9.0+cvs${SRCDATE}" |
4 | PR = "r2" | 4 | PR = "r3" |
5 | 5 | ||
6 | FILESDIR = "${WORKDIR}" | 6 | FILESDIR = "${WORKDIR}" |
7 | 7 | ||