summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-08-22 16:30:00 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-08-22 16:30:00 +0000
commitf8b928e9bab33fb60945fc9abfb8e4ffc404de6f (patch)
tree30e7527fdee03e5c925db4bc41e38ba7191b21b0 /meta/packages/qemu
parent4ff6f39f334afe76f6fa79eec8a49cbefe9904e6 (diff)
downloadpoky-f8b928e9bab33fb60945fc9abfb8e4ffc404de6f.tar.gz
qemu: added 20070613 version (as default), made CVS floating
This version works on 32 and 64 bit machines. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2540 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r--meta/packages/qemu/qemu-native_20070613.bb18
-rw-r--r--meta/packages/qemu/qemu_20070613.bb55
-rw-r--r--meta/packages/qemu/qemu_cvs.bb1
3 files changed, 74 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-native_20070613.bb b/meta/packages/qemu/qemu-native_20070613.bb
new file mode 100644
index 0000000000..03a433b232
--- /dev/null
+++ b/meta/packages/qemu/qemu-native_20070613.bb
@@ -0,0 +1,18 @@
1require qemu_${PV}.bb
2inherit native
3DEPENDS = "zlib-native"
4prefix = "${STAGING_DIR}/${BUILD_SYS}"
5
6python __anonymous() {
7 from bb import which, data
8
9 path = data.getVar('PATH', d)
10 oeconf = data.getVar('EXTRA_OECONF', d) or ''
11 if len(which(path, 'gcc-3.4')) != 0:
12 data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.4", d)
13 elif len(which(path, 'gcc34')) != 0:
14 data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc34", d)
15 elif len(which(path, 'gcc-3.3')) != 0:
16 data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.3", d)
17 #data.setVarFlag('PKG_CONFIG_PATH', 'unexport', '1', d)
18}
diff --git a/meta/packages/qemu/qemu_20070613.bb b/meta/packages/qemu/qemu_20070613.bb
new file mode 100644
index 0000000000..590641b84f
--- /dev/null
+++ b/meta/packages/qemu/qemu_20070613.bb
@@ -0,0 +1,55 @@
1LICENSE = "GPL"
2DEPENDS = "zlib"
3SRCDATE = "20070613"
4PV = "0.9.0+cvs${SRCDATE}"
5PR = "r4"
6
7FILESDIR = "${WORKDIR}"
8
9SRC_URI = "\
10 cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
11 file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
12 file://03_machines_list_no_error.patch;patch=1;pnum=0 \
13 file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
14 file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
15 file://06_exit_segfault.patch;patch=1;pnum=0 \
16 file://10_signal_jobs.patch;patch=1;pnum=0 \
17 file://11_signal_sigaction.patch;patch=1;pnum=0 \
18 file://12_signal_powerpc_support.patch;patch=1;pnum=1 \
19 file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
20 file://31_syscalls.patch;patch=1;pnum=0 \
21 file://32_syscall_sysctl.patch;patch=1;pnum=0 \
22 file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
23 file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
24 file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
25 file://52_ne2000_return.patch;patch=1;pnum=1 \
26 file://61_safe_64bit_int.patch;patch=1;pnum=0 \
27 file://63_sparc_build.patch;patch=1;pnum=0 \
28 file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
29 file://65_kfreebsd.patch;patch=1;pnum=0 \
30 file://66_tls_ld.patch;patch=1;pnum=0 \
31 file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
32 file://93-oh-pl110-rgb.patch;patch=1;pnum=0 \
33 file://qemu-0.9.0-nptl.patch;patch=1 \
34 file://qemu-0.9.0-nptl-update.patch;patch=1 \
35 file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
36 file://workaround_bad_futex_headers.patch;patch=1 \
37 file://fix_segfault.patch;patch=1"
38
39# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
40# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
41# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
42# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
43# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
44# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
45# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
46# file://debian/patches/96-x.patch;patch=1"
47
48S = "${WORKDIR}/qemu"
49
50#EXTRA_OECONF = "--disable-sdl"
51#EXTRA_OECONF = "--disable-gfx-check --target-list=arm-linux-user"
52EXTRA_OECONF = "--disable-gfx-check"
53
54inherit autotools
55
diff --git a/meta/packages/qemu/qemu_cvs.bb b/meta/packages/qemu/qemu_cvs.bb
index ddad39c6c0..c64875bda6 100644
--- a/meta/packages/qemu/qemu_cvs.bb
+++ b/meta/packages/qemu/qemu_cvs.bb
@@ -3,6 +3,7 @@ DEPENDS = "zlib"
3PV = "0.9.0+cvs${SRCDATE}" 3PV = "0.9.0+cvs${SRCDATE}"
4PR = "r4" 4PR = "r4"
5 5
6DEFAULT_PREFERENCE = "-1"
6FILESDIR = "${WORKDIR}" 7FILESDIR = "${WORKDIR}"
7 8
8SRC_URI = "\ 9SRC_URI = "\