summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-23 23:25:07 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-23 23:25:07 +0100
commit4e3afe59683350983aa7ffece47e75c828f181d2 (patch)
tree36e2fb8bb7642821a62b801eaaefa46ef6b411c5 /meta/packages/qemu/qemu_git.bb
parent79b7a566a29386b6075834a46c9c926d503581d9 (diff)
downloadpoky-4e3afe59683350983aa7ffece47e75c828f181d2.tar.gz
qemu: Switch to git and version 0.10.5
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu/qemu_git.bb')
-rw-r--r--meta/packages/qemu/qemu_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu_git.bb b/meta/packages/qemu/qemu_git.bb
new file mode 100644
index 0000000000..fc6d9dc553
--- /dev/null
+++ b/meta/packages/qemu/qemu_git.bb
@@ -0,0 +1,36 @@
1LICENSE = "GPL"
2DEPENDS = "zlib"
3PV = "0.10.2+git${SRCREV}"
4PR = "r0"
5
6FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
7
8SRC_URI = "\
9 git://git.sv.gnu.org/qemu.git;protocol=git \
10 file://06_exit_segfault.patch;patch=1;pnum=0 \
11 file://11_signal_sigaction.patch;patch=1;pnum=0 \
12 file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
13 file://31_syscalls.patch;patch=1;pnum=0 \
14 file://52_ne2000_return.patch;patch=1;pnum=1 \
15 file://63_sparc_build.patch;patch=1;pnum=0 \
16 file://66_tls_ld.patch;patch=1;pnum=0 \
17 file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
18 file://workaround_bad_futex_headers.patch;patch=1 \
19 file://qemu-add-gl-host-code.patch;patch=1 \
20 file://no-strip.patch;patch=1 \
21 file://fix-dirent.patch;patch=1"
22
23# file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1
24
25S = "${WORKDIR}/git"
26
27#EXTRA_OECONF += "--disable-sdl"
28EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu"
29EXTRA_OECONF += "--disable-gfx-check"
30
31inherit autotools
32
33do_configure() {
34 ${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
35 chmod a+x ${S}/target-i386/beginend_funcs.sh
36}