diff options
author | Jeff Dike <jdike@x86_64.user-mode-linux.org> | 2010-08-05 11:29:35 -0400 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-20 16:20:09 +0100 |
commit | e4bc3e36e455e7fca48ccc5431c6bb83f531fab6 (patch) | |
tree | 1482f2609a2ac08b14ee892cfed384664517b3e2 /meta/packages/qemu/qemu-helper-nativesdk_1.0.bb | |
parent | d9aa25a3379c21a999bd39e78702f932ead7b840 (diff) | |
download | poky-e4bc3e36e455e7fca48ccc5431c6bb83f531fab6.tar.gz |
tunctl: Added an tunctl which supports TUNSETGROUP
TUNSETGROUP is needed in order to preconfigure a set of tap devices
that can be used by non-root users. The requirement is that the qemu
users be members of whatever group the tap devices are assigned to.
Include tunctl in the qemu-helper package, and add a -native version.
Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/packages/qemu/qemu-helper-nativesdk_1.0.bb')
-rw-r--r-- | meta/packages/qemu/qemu-helper-nativesdk_1.0.bb | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb b/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb index a4294ef5cf..a764a0e28a 100644 --- a/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb +++ b/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb | |||
@@ -10,13 +10,16 @@ SRC_URI = "file://${POKYBASE}/scripts/poky-qemu \ | |||
10 | file://${POKYBASE}/scripts/poky-addptable2image \ | 10 | file://${POKYBASE}/scripts/poky-addptable2image \ |
11 | file://${POKYBASE}/scripts/poky-qemu-ifup \ | 11 | file://${POKYBASE}/scripts/poky-qemu-ifup \ |
12 | file://${POKYBASE}/scripts/poky-qemu-ifdown \ | 12 | file://${POKYBASE}/scripts/poky-qemu-ifdown \ |
13 | file://raw2flash.c" | 13 | file://tunctl.c \ |
14 | file://raw2flash.c \ | ||
15 | " | ||
14 | 16 | ||
15 | S = "${WORKDIR}" | 17 | S = "${WORKDIR}" |
16 | 18 | ||
17 | inherit nativesdk | 19 | inherit nativesdk |
18 | 20 | ||
19 | do_compile() { | 21 | do_compile() { |
22 | ${CC} tunctl.c -o tunctl | ||
20 | ${CC} raw2flash.c -o raw2flash.spitz | 23 | ${CC} raw2flash.c -o raw2flash.spitz |
21 | ${CC} raw2flash.c -o flash2raw.spitz -Dflash2raw | 24 | ${CC} raw2flash.c -o flash2raw.spitz -Dflash2raw |
22 | } | 25 | } |
@@ -24,6 +27,7 @@ do_compile() { | |||
24 | do_install() { | 27 | do_install() { |
25 | install -d ${D}${bindir} | 28 | install -d ${D}${bindir} |
26 | install -m 0755 ${WORKDIR}${POKYBASE}/scripts/poky-* ${D}${bindir}/ | 29 | install -m 0755 ${WORKDIR}${POKYBASE}/scripts/poky-* ${D}${bindir}/ |
30 | install tunctl ${D}${bindir}/ | ||
27 | install raw2flash.spitz ${D}${bindir}/ | 31 | install raw2flash.spitz ${D}${bindir}/ |
28 | install flash2raw.spitz ${D}${bindir}/ | 32 | install flash2raw.spitz ${D}${bindir}/ |
29 | ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.akita | 33 | ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.akita |