summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu-0.12.4
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-06-15 12:22:01 +0100
committerJoshua Lock <josh@linux.intel.com>2010-06-17 15:08:49 +0100
commit01a588361686a2eee40018cdbb6f47051542e5bc (patch)
treeb336f7d5cf82a331858a76abce245d5e0d5caa8d /meta/packages/qemu/qemu-0.12.4
parented145bbdfee4dc9794bd5e0910a2acb99db32db0 (diff)
downloadpoky-01a588361686a2eee40018cdbb6f47051542e5bc.tar.gz
qemu: Fix linking of the native package on Fedora 13
Fedora 13 switched the default behaviour of the linker to no longer indirectly link to required libraries (i.e. dependencies of a library already linked to). Therefore we need to explicitly pass the depended on libraries into the linker for building to work on Fedora 13. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu/qemu-0.12.4')
-rw-r--r--meta/packages/qemu/qemu-0.12.4/linker-flags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/linker-flags.patch b/meta/packages/qemu/qemu-0.12.4/linker-flags.patch
new file mode 100644
index 0000000000..7b33aa4840
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.12.4/linker-flags.patch
@@ -0,0 +1,22 @@
1Fedora 13 switched the default behaviour of the linker to no longer
2indirectly link to required libraries (i.e. dependencies of a library
3already linked to). Therefore we need to explicitly pass the depended on
4libraries into the linker for building to work on Fedora 13.
5
6More information is available on the Fedora Wiki:
7https://fedoraproject.org/wiki/UnderstandingDSOLinkChange
8
9JL - 15/06/10
10Index: qemu-0.12.4/Makefile.target
11===================================================================
12--- qemu-0.12.4.orig/Makefile.target 2010-06-15 11:21:52.000000000 +0100
13+++ qemu-0.12.4/Makefile.target 2010-06-15 11:25:27.212852910 +0100
14@@ -178,7 +178,7 @@
15 obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-pci.o
16 obj-$(CONFIG_KVM) += kvm.o kvm-all.o
17 obj-$(CONFIG_ISA_MMIO) += isa_mmio.o
18-LIBS+=-lz
19+LIBS+=-lz -lX11 -ldl
20
21 sound-obj-y =
22 sound-obj-$(CONFIG_SB16) += sb16.o