diff options
author | Joshua Lock <josh@linux.intel.com> | 2010-03-25 12:19:17 +0000 |
---|---|---|
committer | Joshua Lock <josh@linux.intel.com> | 2010-03-26 10:29:18 +0000 |
commit | 678537c6844662f7b156587fc324bdfe0aa03621 (patch) | |
tree | 02a2f577d4c245661f5e967dbd94f16b5867f8f9 /meta/packages/python | |
parent | a2d5806f5d5eebea3828b18cffa3cb0df327a9b8 (diff) | |
download | poky-678537c6844662f7b156587fc324bdfe0aa03621.tar.gz |
pyton-pycurl: Add new recipe from OE.dev
Add python-pycurl_7.19.0 from OE.dev with some tweaks to enable a native
version. This package is a dependancy of newer Yum
Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/python')
-rw-r--r-- | meta/packages/python/python-pycurl/no-static-link.patch | 14 | ||||
-rw-r--r-- | meta/packages/python/python-pycurl_7.19.0.bb | 23 |
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/packages/python/python-pycurl/no-static-link.patch b/meta/packages/python/python-pycurl/no-static-link.patch new file mode 100644 index 0000000000..b7c5ab9c9c --- /dev/null +++ b/meta/packages/python/python-pycurl/no-static-link.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Index: pycurl-7.18.2/setup.py | ||
2 | =================================================================== | ||
3 | --- pycurl-7.18.2.orig/setup.py | ||
4 | +++ pycurl-7.18.2/setup.py | ||
5 | @@ -97,8 +97,7 @@ else: | ||
6 | else: | ||
7 | extra_compile_args.append(e) | ||
8 | libs = split_quoted( | ||
9 | - os.popen("'%s' --libs" % CURL_CONFIG).read()+\ | ||
10 | - os.popen("'%s' --static-libs" % CURL_CONFIG).read()) | ||
11 | + os.popen("'%s' --libs" % CURL_CONFIG).read()) | ||
12 | for e in libs: | ||
13 | if e[:2] == "-l": | ||
14 | libraries.append(e[2:]) | ||
diff --git a/meta/packages/python/python-pycurl_7.19.0.bb b/meta/packages/python/python-pycurl_7.19.0.bb new file mode 100644 index 0000000000..84b01dc50f --- /dev/null +++ b/meta/packages/python/python-pycurl_7.19.0.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "libcurl Python Bindings" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "LGPL" | ||
5 | DEPENDS = "curl" | ||
6 | SRCNAME = "pycurl" | ||
7 | PR = "r0" | ||
8 | |||
9 | SRC_URI = "\ | ||
10 | http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \ | ||
11 | file://no-static-link.patch;patch=1 \ | ||
12 | " | ||
13 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
14 | |||
15 | inherit distutils | ||
16 | |||
17 | # need to export these variables for python-config to work | ||
18 | export BUILD_SYS | ||
19 | export HOST_SYS | ||
20 | |||
21 | RDEPENDS = "python-core curl" | ||
22 | |||
23 | BBCLASSEXTEND = "native" | ||