diff options
author | Richard Purdie <richard@openedhand.com> | 2008-08-25 20:33:55 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-08-25 20:33:55 +0000 |
commit | 16e6877c4ce53fd3be88dd77263a03e7d88c3163 (patch) | |
tree | 831004ca391e04c8deaace28b15cb602c0848c77 /meta/packages/python/python-pygtk_2.10.4.bb | |
parent | 07eeb6a8b6d671db7566f839ab22a26b6f118077 (diff) | |
download | poky-16e6877c4ce53fd3be88dd77263a03e7d88c3163.tar.gz |
python: Promote from meta-extras to meta
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5092 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/python/python-pygtk_2.10.4.bb')
-rw-r--r-- | meta/packages/python/python-pygtk_2.10.4.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/packages/python/python-pygtk_2.10.4.bb b/meta/packages/python/python-pygtk_2.10.4.bb new file mode 100644 index 0000000000..6b26f59ad8 --- /dev/null +++ b/meta/packages/python/python-pygtk_2.10.4.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | DESCRIPTION = "Python GTK+ 2.10.x Bindings" | ||
2 | SECTION = "devel/python" | ||
3 | # needs gtk+ 2.10.x | ||
4 | DEPENDS = "gtk+ libglade python-pycairo python-pygobject" | ||
5 | RDEPENDS = "python-shell python-pycairo python-pygobject" | ||
6 | PROVIDES = "python-pygtk2" | ||
7 | SRCNAME = "pygtk" | ||
8 | LICENSE = "LGPL" | ||
9 | PR = "ml8" | ||
10 | |||
11 | SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.10/${SRCNAME}-${PV}.tar.bz2 \ | ||
12 | file://fix-gtkunixprint.patch;patch=1 \ | ||
13 | file://prevent_to_get_display_during_import.patch;patch=1 \ | ||
14 | file://nodocs.patch;patch=1 \ | ||
15 | file://acinclude.m4" | ||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
17 | |||
18 | EXTRA_OECONF = "\ | ||
19 | --disable-docs \ | ||
20 | --with-python-includes=${STAGING_INCDIR}/../ \ | ||
21 | " | ||
22 | |||
23 | inherit autotools pkgconfig distutils-base | ||
24 | |||
25 | do_configure_prepend() { | ||
26 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ | ||
27 | } | ||
28 | |||
29 | # dirty fix #1: remove dependency on python-pygobject-dev | ||
30 | do_install_append() { | ||
31 | find ${D} -name "*.la"|xargs rm -f | ||
32 | rm -f ${D}/${bindir}/pygtk-codegen-2.0 | ||
33 | rm -rf ${D}/${libdir}/pkgconfig | ||
34 | } | ||
35 | |||
36 | # dirty fix #2: fix build system paths leaking in | ||
37 | require fix-path.inc | ||
38 | |||
39 | PACKAGES =+ "${PN}-demo" | ||
40 | FILES_${PN}-demo = "\ | ||
41 | ${bindir}/pygtk-demo \ | ||
42 | ${libdir}/pygtk \ | ||
43 | " | ||
44 | RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang" | ||
45 | |||
46 | # todo: revamp packaging, package demo seperatly | ||
47 | FILES_${PN}-dev += "\ | ||
48 | ${libdir}/pygtk/2.0 \ | ||
49 | ${bindir}/pygtk-* \ | ||
50 | ${datadir}/pygtk/2.0" | ||
51 | |||
52 | do_stage() { | ||
53 | autotools_stage_includes | ||
54 | sed -i s:/usr/share:${STAGING_DATADIR}: codegen/pygtk-codegen-2.0 | ||
55 | install -m 0755 codegen/pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/ | ||
56 | install -d ${STAGING_DATADIR}/pygtk/2.0/codegen | ||
57 | install -d ${STAGING_DATADIR}/pygtk/2.0/defs/ | ||
58 | cp -pPr codegen/*.py* ${STAGING_DATADIR}/pygtk/2.0/codegen/ | ||
59 | cp -pPr *.defs ${STAGING_DATADIR}/pygtk/2.0/defs/ | ||
60 | cp -pPr gtk/*.defs ${STAGING_DATADIR}/pygtk/2.0/defs/ | ||
61 | } | ||