summaryrefslogtreecommitdiffstats
path: root/meta/packages/puzzles/puzzles_r6727.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-23 14:58:09 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-23 14:58:09 +0000
commit436d6560f1338d6d95f06bc0c3d0f9d0a66c7ebd (patch)
tree215052580332804531603246f5c980d3aa362b29 /meta/packages/puzzles/puzzles_r6727.bb
parent6a9c195935a5f8c67767ab9457b7da6754f38b8e (diff)
downloadpoky-436d6560f1338d6d95f06bc0c3d0f9d0a66c7ebd.tar.gz
puzzles: r6727 -> 6915
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@950 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/puzzles/puzzles_r6727.bb')
-rw-r--r--meta/packages/puzzles/puzzles_r6727.bb47
1 files changed, 0 insertions, 47 deletions
diff --git a/meta/packages/puzzles/puzzles_r6727.bb b/meta/packages/puzzles/puzzles_r6727.bb
deleted file mode 100644
index f8ffcb7d01..0000000000
--- a/meta/packages/puzzles/puzzles_r6727.bb
+++ /dev/null
@@ -1,47 +0,0 @@
1
2DEPENDS = "gtk+"
3PR = "r2"
4
5SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz \
6 file://game.png"
7
8do_compile_prepend = " \
9 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR}/pkg-config gtk+-2.0 --libs`'; \
10 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR}/pkg-config gtk+-2.0 --cflags`'; "
11
12FILES_${PN} = "${prefix}/games/* ${datadir}/applications/* ${datadir}/pixmaps"
13FILES_${PN}-dbg += "${prefix}/games/.debug"
14
15do_install () {
16 rm -rf ${D}/*
17 export prefix=${D}
18 export DESTDIR=${D}
19 install -d ${D}/${prefix}/
20 install -d ${D}/${prefix}/games/
21 oe_runmake install
22
23 install -d ${D}/${datadir}/
24 install -d ${D}/${datadir}/applications/
25 install -d ${D}/${datadir}/pixmaps/
26
27 install ${WORKDIR}/game.png ${D}/${datadir}/pixmaps/
28
29 cd ${D}/${prefix}/games
30 for prog in *; do
31 if [ -x $prog ]; then
32 echo "making ${D}/${datadir}/applications/$prog.desktop"
33 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
34[Desktop Entry]
35Encoding=UTF-8
36Name=$prog
37Exec=${prefix}/games/$prog
38Icon=game.png
39Terminal=false
40Type=Application
41Categories=Game
42StartupNotify=true
43SingleInstance=true
44STOP
45 fi
46 done
47}