summaryrefslogtreecommitdiffstats
path: root/meta/packages/psplash
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-19 21:42:36 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-19 21:42:36 +0000
commit76b5863170eebf5ea61fcbf79eb963d4c9092352 (patch)
treeae457347a9a0d9ed089eac305d8c61360071a8d7 /meta/packages/psplash
parent04066bd057c80b72c4472b05e537fa8522f750aa (diff)
downloadpoky-76b5863170eebf5ea61fcbf79eb963d4c9092352.tar.gz
psplash: Remove pointless cat calls, promote to .sh initscript
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5083 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/psplash')
-rwxr-xr-xmeta/packages/psplash/files/psplash-init5
-rw-r--r--meta/packages/psplash/psplash_svn.bb6
2 files changed, 6 insertions, 5 deletions
diff --git a/meta/packages/psplash/files/psplash-init b/meta/packages/psplash/files/psplash-init
index ea370d622b..66c85e9335 100755
--- a/meta/packages/psplash/files/psplash-init
+++ b/meta/packages/psplash/files/psplash-init
@@ -7,7 +7,8 @@
7# Default-Stop: 7# Default-Stop:
8### END INIT INFO 8### END INIT INFO
9 9
10for x in $(cat /proc/cmdline); do 10read CMDLINE < /proc/cmdline
11for x in $CMDLINE; do
11 case $x in 12 case $x in
12 psplash=false) 13 psplash=false)
13 echo "Boot splashscreen disabled" 14 echo "Boot splashscreen disabled"
@@ -21,7 +22,7 @@ mount tmpfs -t tmpfs $TMPDIR -o,size=40k
21 22
22rotation=0 23rotation=0
23if [ -e /etc/rotation ]; then 24if [ -e /etc/rotation ]; then
24 rotation=`cat /etc/rotation` 25 read rotation < /etc/rotation
25fi 26fi
26 27
27/usr/bin/psplash --angle $rotation & 28/usr/bin/psplash --angle $rotation &
diff --git a/meta/packages/psplash/psplash_svn.bb b/meta/packages/psplash/psplash_svn.bb
index f278399069..d46b051c6b 100644
--- a/meta/packages/psplash/psplash_svn.bb
+++ b/meta/packages/psplash/psplash_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
2SECTION = "base" 2SECTION = "base"
3LICENSE = "GPL" 3LICENSE = "GPL"
4PV = "0.0+svnr${SRCREV}" 4PV = "0.0+svnr${SRCREV}"
5PR = "r3" 5PR = "r4"
6 6
7SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \ 7SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
8 file://psplash-init" 8 file://psplash-init"
@@ -16,8 +16,8 @@ FILES_${PN} += "/mnt/.psplash"
16do_install_prepend() { 16do_install_prepend() {
17 install -d ${D}/mnt/.psplash/ 17 install -d ${D}/mnt/.psplash/
18 install -d ${D}${sysconfdir}/init.d/ 18 install -d ${D}${sysconfdir}/init.d/
19 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash 19 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
20} 20}
21 21
22INITSCRIPT_NAME = "psplash" 22INITSCRIPT_NAME = "psplash.sh"
23INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ." 23INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."