summaryrefslogtreecommitdiffstats
path: root/meta/packages/pseudo
diff options
context:
space:
mode:
authorMark Hatle <mhatle@windriver.com>2010-07-21 06:15:53 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 15:43:15 +0100
commitad0ac0ecd38fc77daf42485489fccc10a5e1e3e7 (patch)
tree977d500d8690252437bfff6036f48930ca131a5b /meta/packages/pseudo
parent971907567cff64e74f21d349d6751dadc8c09827 (diff)
downloadpoky-ad0ac0ecd38fc77daf42485489fccc10a5e1e3e7.tar.gz
pseudo: Uprev to the latest git version
Uprev pseudo to the latest head version to resolve a number of issues on older hosts such as RHEL 5. In addition sqlite was changed to link statically into pseudo to avoid a potential LD_LIBRARY_PATH issue. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/packages/pseudo')
-rw-r--r--meta/packages/pseudo/pseudo/ld_sacredness.patch120
-rw-r--r--meta/packages/pseudo/pseudo/make_parallel.patch14
-rw-r--r--meta/packages/pseudo/pseudo/path-munge.patch82
-rw-r--r--meta/packages/pseudo/pseudo/static_sqlite.patch15
-rw-r--r--meta/packages/pseudo/pseudo/tweakflags.patch21
-rw-r--r--meta/packages/pseudo/pseudo_git.bb6
6 files changed, 147 insertions, 111 deletions
diff --git a/meta/packages/pseudo/pseudo/ld_sacredness.patch b/meta/packages/pseudo/pseudo/ld_sacredness.patch
index 55a39d99b4..568c899d7c 100644
--- a/meta/packages/pseudo/pseudo/ld_sacredness.patch
+++ b/meta/packages/pseudo/pseudo/ld_sacredness.patch
@@ -7,62 +7,70 @@ dyanmic linker can figure out anything else with rpaths.
7Inspired by RP's patch of a similar intent for fakeroot 7Inspired by RP's patch of a similar intent for fakeroot
8 8
9JL 15/07/10 9JL 15/07/10
10(updated 20/7/2010 - MGH)
10 11
11Index: git/pseudo_util.c 12--- git.orig/pseudo_util.c 2010-07-20 15:34:41.000000000 -0700
12=================================================================== 13+++ git/pseudo_util.c 2010-07-20 16:00:35.000000000 -0700
13--- git.orig/pseudo_util.c 2010-03-25 17:57:24.000000000 +0000 14diff -ur git.orig/pseudo_util.c git/pseudo_util.c
14+++ git/pseudo_util.c 2010-07-15 16:13:09.431459640 +0100 15--- git.orig/pseudo_util.c 2010-07-20 17:02:13.000000000 -0700
15@@ -362,40 +362,25 @@ 16+++ git/pseudo_util.c 2010-07-20 17:03:26.000000000 -0700
17@@ -65,7 +65,7 @@
18 * the end of the string or a space after it.
16 */ 19 */
17 void 20 static char *libpseudo_name = "libpseudo.so";
18 pseudo_setupenv(char *opts) { 21-static char *libpseudo_pattern = "(=| )libpseudo[^ ]*\\.so($| )";
19- char *ld_env; 22+static char *libpseudo_pattern = "(=| )[^ ]*libpseudo[^ ]*\\.so($| )";
20 char *newenv; 23 static regex_t libpseudo_regex;
21 size_t len; 24 static int libpseudo_regex_compiled = 0;
22 char debugvalue[64];
23 25
24- newenv = "libpseudo.so"; 26@@ -499,8 +499,10 @@
25+ /* need to set LD_PRELOAD to the absolute library path, as tweaking 27 found_opts = 1;
26+ * LD_LIBRARY_PATH makes the Beaver sad. 28 if (!memcmp(environ[i], "PSEUDO_DEBUG=", 13))
27+ * Fortunately we can hack this as we know we don't use lib64 :-) 29 found_debug = 1;
28+ */ 30+#if 0
29+ 31 if (!memcmp(environ[i], "LD_LIBRARY_PATH=", 16))
30+ char *libname = "libpseudo.so"; 32 found_libpath = 1;
31+ char *prefix = pseudo_prefix_path("lib"); 33+#endif
32+ len = strlen(prefix) + strlen(libname) + 2; 34 ++env_count;
33+ newenv = malloc(len); 35 }
34+ 36 env_count += 4 - (found_preload + found_libpath + found_debug + found_opts);
35+ snprintf(newenv, len, "%s/%s", prefix, libname); 37@@ -520,6 +522,7 @@
36+ 38 return NULL;
37 setenv("LD_PRELOAD", newenv, 1); 39 }
38 40 new_environ[j++] = newenv;
39- ld_env = getenv("LD_LIBRARY_PATH"); 41+#if 0
40- if (ld_env) { 42 } else if (!memcmp(environ[i], "LD_LIBRARY_PATH=", 16)) {
41- char *prefix = pseudo_prefix_path(NULL); 43 if (!strstr(environ[i], PSEUDO_PREFIX)) {
42- if (!strstr(ld_env, prefix)) { 44 char *e1, *e2;
43- char *e1, *e2; 45@@ -537,10 +540,12 @@
44- e1 = pseudo_prefix_path("lib"); 46 } else {
45- e2 = pseudo_prefix_path("lib64"); 47 new_environ[j++] = environ[i];
46- len = strlen(ld_env) + strlen(e1) + strlen(e2) + 3; 48 }
47- newenv = malloc(len); 49+#endif
48- snprintf(newenv, len, "%s:%s:%s", ld_env, e1, e2); 50 } else {
49- free(e1); 51 new_environ[j++] = environ[i];
50- free(e2); 52 }
51- setenv("LD_LIBRARY_PATH", newenv, 1); 53 }
52- free(newenv); 54+#if 0
53- } 55 if (!found_libpath) {
54- free(prefix); 56 char *e1, *e2;
55- } else { 57 e1 = pseudo_prefix_path("lib");
56- char *e1, *e2; 58@@ -553,8 +558,18 @@
57- e1 = pseudo_prefix_path("lib"); 59 snprintf(newenv, len, "LD_LIBRARY_PATH=%s:%s", e1, e2);
58- e2 = pseudo_prefix_path("lib64"); 60 new_environ[j++] = newenv;
59- len = strlen(e1) + strlen(e2) + 2; 61 }
60- newenv = malloc(len); 62+#endif
61- snprintf(newenv, len, "%s:%s", e1, e2); 63 if (!found_preload) {
62- setenv("LD_LIBRARY_PATH", newenv, 1); 64+#if 0
63- free(newenv); 65 new_environ[j++] = "LD_PRELOAD=libpseudo.so";
64- } 66+#else
65+ free(newenv); 67+ char *libname = "libpseudo.so";
66 68+ char *prefix = pseudo_prefix_path("lib");
67 if (max_debug_level) { 69+ len = 11 + strlen(prefix) + strlen(libname) + 2;
68 sprintf(debugvalue, "%d", max_debug_level); 70+ newenv = malloc(len);
71+ snprintf(newenv, len, "LD_PRELOAD=%s/%s", prefix, libname);
72+ new_environ[j++] = newenv;
73+#endif
74 }
75 if (!found_debug && max_debug_level > 0) {
76 len = 16;
diff --git a/meta/packages/pseudo/pseudo/make_parallel.patch b/meta/packages/pseudo/pseudo/make_parallel.patch
new file mode 100644
index 0000000000..697b576f74
--- /dev/null
+++ b/meta/packages/pseudo/pseudo/make_parallel.patch
@@ -0,0 +1,14 @@
1Add a missing dependency to fix a problem with building pseudo in a
2parallel build.
3
4--- git.orig/Makefile.in 2010-07-20 16:15:30.000000000 -0700
5+++ git/Makefile.in 2010-07-20 16:15:58.000000000 -0700
6@@ -105,7 +105,7 @@
7
8 .SECONDARY: wrappers
9
10-pseudo_wrapfuncs.c: wrappers
11+pseudo_wrapfuncs.c pseudo_wrapfuncs.h: wrappers
12
13 # no-strict-aliasing is needed for the function pointer trickery.
14 pseudo_wrappers.o: $(GUTS) pseudo_wrappers.c pseudo_wrapfuncs.c pseudo_wrapfuncs.h
diff --git a/meta/packages/pseudo/pseudo/path-munge.patch b/meta/packages/pseudo/pseudo/path-munge.patch
index 2327f2e5af..2ccdea17ea 100644
--- a/meta/packages/pseudo/pseudo/path-munge.patch
+++ b/meta/packages/pseudo/pseudo/path-munge.patch
@@ -3,11 +3,11 @@ $(localstatedir) so this quick hack makes pseudo use a data directory specified
3with --data, and defaults to pseudo's way if it's not set. 3with --data, and defaults to pseudo's way if it's not set.
4 4
5JL 14/07/10 5JL 14/07/10
6(updated 20/7/2010 - MGH)
6 7
7Index: git/Makefile.in 8diff -urN git.orig/Makefile.in git/Makefile.in
8=================================================================== 9--- git.orig/Makefile.in 2010-07-20 15:47:46.000000000 -0700
9--- git.orig/Makefile.in 2010-07-14 16:50:45.772094105 +0100 10+++ git/Makefile.in 2010-07-20 15:43:31.000000000 -0700
10+++ git/Makefile.in 2010-07-14 16:50:45.897400059 +0100
11@@ -20,6 +20,7 @@ 11@@ -20,6 +20,7 @@
12 # configuration flags 12 # configuration flags
13 PREFIX=@PREFIX@ 13 PREFIX=@PREFIX@
@@ -26,17 +26,16 @@ Index: git/Makefile.in
26+DATADIR=$(DATA)/pseudo 26+DATADIR=$(DATA)/pseudo
27+endif 27+endif
28 28
29 CFLAGS_BASE=-pipe -std=gnu99 -Wall 29 CFLAGS_BASE=-pipe -std=gnu99 -Wall -W -Wextra
30 CFLAGS_CODE=-fPIC -D_LARGEFILE64_SOURCE -D_ATFILE_SOURCE -m$(BITS) 30 CFLAGS_CODE=-fPIC -D_LARGEFILE64_SOURCE -D_ATFILE_SOURCE -m$(BITS)
31-CFLAGS_DEFS=-DPSEUDO_PREFIX='"$(PREFIX)"' -DPSEUDO_SUFFIX='"$(SUFFIX)"' -DPSEUDO_VERSION='"$(VERSION)"' 31-CFLAGS_DEFS=-DPSEUDO_PREFIX='"$(PREFIX)"' -DPSEUDO_SUFFIX='"$(SUFFIX)"' -DPSEUDO_VERSION='"$(VERSION)"'
32+CFLAGS_DEFS=-DPSEUDO_PREFIX='"$(PREFIX)"' -DPSEUDO_SUFFIX='"$(SUFFIX)"' -DPSEUDO_VERSION='"$(VERSION)"' -DPSEUDO_DATA='"$(DATADIR)"' 32+CFLAGS_DEFS=-DPSEUDO_PREFIX='"$(PREFIX)"' -DPSEUDO_SUFFIX='"$(SUFFIX)"' -DPSEUDO_VERSION='"$(VERSION)"' -DPSEUDO_DATA='"$(DATADIR)"'
33 CFLAGS_DEBUG=-O2 -g 33 CFLAGS_DEBUG=-O2 -g
34 CFLAGS_SQL=-L$(SQLITE)/lib -I$(SQLITE)/include 34 CFLAGS_SQL=-L$(SQLITE)/lib -I$(SQLITE)/include
35 EXTRA_CFLAGS=$(CFLAGS_BASE) $(CFLAGS_CODE) $(CFLAGS_DEFS) \ 35 EXTRA_CFLAGS=$(CFLAGS_BASE) $(CFLAGS_CODE) $(CFLAGS_DEFS) \
36Index: git/configure 36diff -urN git.orig/configure git/configure
37=================================================================== 37--- git.orig/configure 2010-07-20 15:34:41.000000000 -0700
38--- git.orig/configure 2010-03-25 17:57:24.000000000 +0000 38+++ git/configure 2010-07-20 15:42:23.000000000 -0700
39+++ git/configure 2010-07-14 16:50:45.897400059 +0100
40@@ -20,13 +20,14 @@ 39@@ -20,13 +20,14 @@
41 # not a real configure script... 40 # not a real configure script...
42 opt_prefix= 41 opt_prefix=
@@ -71,11 +70,10 @@ Index: git/configure
71 s,@SQLITE@,'"$opt_sqlite"',g 70 s,@SQLITE@,'"$opt_sqlite"',g
72 s,@MARK64@,'"$opt_mark64"',g 71 s,@MARK64@,'"$opt_mark64"',g
73 s,@BITS@,'"$opt_bits"',g 72 s,@BITS@,'"$opt_bits"',g
74Index: git/pseudo.c 73diff -urN git.orig/pseudo.c git/pseudo.c
75=================================================================== 74--- git.orig/pseudo.c 2010-07-20 15:34:41.000000000 -0700
76--- git.orig/pseudo.c 2010-03-25 17:57:24.000000000 +0000 75+++ git/pseudo.c 2010-07-20 15:42:23.000000000 -0700
77+++ git/pseudo.c 2010-07-14 16:50:45.898400595 +0100 76@@ -272,7 +272,7 @@
78@@ -191,7 +191,7 @@
79 pseudo_new_pid(); 77 pseudo_new_pid();
80 78
81 pseudo_debug(3, "opening lock.\n"); 79 pseudo_debug(3, "opening lock.\n");
@@ -83,12 +81,11 @@ Index: git/pseudo.c
83+ lockname = strdup(PSEUDO_LOCKFILE); 81+ lockname = strdup(PSEUDO_LOCKFILE);
84 if (!lockname) { 82 if (!lockname) {
85 pseudo_diag("Couldn't allocate a file path.\n"); 83 pseudo_diag("Couldn't allocate a file path.\n");
86 exit(1); 84 exit(EXIT_FAILURE);
87Index: git/pseudo.h 85diff -urN git.orig/pseudo.h git/pseudo.h
88=================================================================== 86--- git.orig/pseudo.h 2010-07-20 15:34:41.000000000 -0700
89--- git.orig/pseudo.h 2010-03-25 17:57:24.000000000 +0000 87+++ git/pseudo.h 2010-07-20 15:44:31.000000000 -0700
90+++ git/pseudo.h 2010-07-14 16:50:45.899360463 +0100 88@@ -134,11 +134,10 @@
91@@ -121,8 +121,7 @@
92 89
93 extern char *pseudo_version; 90 extern char *pseudo_version;
94 91
@@ -101,11 +98,13 @@ Index: git/pseudo.h
101+#define PSEUDO_LOGFILE PSEUDO_DATA "/pseudo.log" 98+#define PSEUDO_LOGFILE PSEUDO_DATA "/pseudo.log"
102+#define PSEUDO_PIDFILE PSEUDO_DATA "/pseudo.pid" 99+#define PSEUDO_PIDFILE PSEUDO_DATA "/pseudo.pid"
103+#define PSEUDO_SOCKET PSEUDO_DATA "/pseudo.socket" 100+#define PSEUDO_SOCKET PSEUDO_DATA "/pseudo.socket"
104Index: git/pseudo_db.c 101
105=================================================================== 102 /* some systems might not have *at(). We like to define operations in
106--- git.orig/pseudo_db.c 2010-03-25 17:57:24.000000000 +0000 103 * terms of each other, and for instance, open(...) is the same as
107+++ git/pseudo_db.c 2010-07-14 16:51:07.506464213 +0100 104diff -urN git.orig/pseudo_db.c git/pseudo_db.c
108@@ -458,11 +458,11 @@ 105--- git.orig/pseudo_db.c 2010-07-20 15:34:41.000000000 -0700
106+++ git/pseudo_db.c 2010-07-20 15:42:23.000000000 -0700
107@@ -471,11 +471,11 @@
109 if (*db) 108 if (*db)
110 return 0; 109 return 0;
111 if (db == &file_db) { 110 if (db == &file_db) {
@@ -119,11 +118,10 @@ Index: git/pseudo_db.c
119 rc = sqlite3_open(dbfile, db); 118 rc = sqlite3_open(dbfile, db);
120 free(dbfile); 119 free(dbfile);
121 } 120 }
122Index: git/pseudo_server.c 121diff -urN git.orig/pseudo_server.c git/pseudo_server.c
123=================================================================== 122--- git.orig/pseudo_server.c 2010-07-20 15:34:41.000000000 -0700
124--- git.orig/pseudo_server.c 2010-03-25 17:57:24.000000000 +0000 123+++ git/pseudo_server.c 2010-07-20 15:46:09.000000000 -0700
125+++ git/pseudo_server.c 2010-07-14 16:50:45.901462874 +0100 124@@ -107,9 +107,9 @@
126@@ -101,9 +101,9 @@
127 } 125 }
128 126
129 /* cd to the data directory */ 127 /* cd to the data directory */
@@ -135,7 +133,7 @@ Index: git/pseudo_server.c
135 return 1; 133 return 1;
136 } 134 }
137 if (chdir(pseudo_path) == -1) { 135 if (chdir(pseudo_path) == -1) {
138@@ -132,9 +132,9 @@ 136@@ -138,9 +138,9 @@
139 return 0; 137 return 0;
140 } 138 }
141 setsid(); 139 setsid();
@@ -147,15 +145,15 @@ Index: git/pseudo_server.c
147 return 1; 145 return 1;
148 } 146 }
149 fp = fopen(pseudo_path, "w"); 147 fp = fopen(pseudo_path, "w");
150@@ -152,9 +152,9 @@ 148diff -ur git.orig/pseudo_util.c git/pseudo_util.c
151 pseudo_new_pid(); 149--- git.orig/pseudo_util.c 2010-07-20 17:06:22.000000000 -0700
152 fclose(stdin); 150+++ git/pseudo_util.c 2010-07-20 17:10:50.000000000 -0700
153 fclose(stdout); 151@@ -855,7 +855,7 @@
154- pseudo_path = pseudo_prefix_path(PSEUDO_LOGFILE); 152 pseudo_debug(3, "no special log file requested, using stderr.\n");
155+ pseudo_path = strdup(PSEUDO_LOGFILE); 153 return -1;
156 if (!pseudo_path) {
157- pseudo_diag("can't get path for prefix/%s\n", PSEUDO_LOGFILE);
158+ pseudo_diag("can't get path for %s\n", PSEUDO_LOGFILE);
159 return 1;
160 } 154 }
161 fd = open(pseudo_path, O_WRONLY | O_APPEND | O_CREAT, 0644); 155- pseudo_path = pseudo_prefix_path(defname);
156+ pseudo_path = strdup(defname);
157 if (!pseudo_path) {
158 pseudo_diag("can't get path for prefix/%s\n", PSEUDO_LOGFILE);
159 return -1;
diff --git a/meta/packages/pseudo/pseudo/static_sqlite.patch b/meta/packages/pseudo/pseudo/static_sqlite.patch
new file mode 100644
index 0000000000..0a2fa28d79
--- /dev/null
+++ b/meta/packages/pseudo/pseudo/static_sqlite.patch
@@ -0,0 +1,15 @@
1Due to disabling the LD_LIBRARY_PATH handling, we need to use a static
2libsqlite.
3
4diff -ur git.orig/Makefile.in git/Makefile.in
5--- git.orig/Makefile.in 2010-07-20 17:13:56.000000000 -0700
6+++ git/Makefile.in 2010-07-20 17:12:14.000000000 -0700
7@@ -45,7 +45,7 @@
8 GLOB_PATTERN=guts/*.c
9 GUTS=$(filter-out "$(GLOB_PATTERN)",$(wildcard $(GLOB_PATTERN)))
10
11-DBLDFLAGS=-lsqlite3
12+DBLDFLAGS=$(SQLITE)/lib/libsqlite3.a
13 USE_64=wrapfuncs64.in
14
15 SHOBJS=pseudo_table.o pseudo_util.o
diff --git a/meta/packages/pseudo/pseudo/tweakflags.patch b/meta/packages/pseudo/pseudo/tweakflags.patch
index 65656f137a..a7458f5f4a 100644
--- a/meta/packages/pseudo/pseudo/tweakflags.patch
+++ b/meta/packages/pseudo/pseudo/tweakflags.patch
@@ -6,14 +6,13 @@ until "make install" time when DESTDIR is set. Change the first target
6to "all" for this reason. 6to "all" for this reason.
7 7
8RP 18/3/10 8RP 18/3/10
9(updated 20/7/2010 - MGH)
9 10
10Index: git/Makefile.in 11--- git.orig/Makefile.in 2010-07-20 15:34:41.000000000 -0700
11=================================================================== 12+++ git/Makefile.in 2010-07-20 15:40:42.000000000 -0700
12--- git.orig/Makefile.in 2010-03-17 16:05:17.000000000 +0000
13+++ git/Makefile.in 2010-04-06 15:25:39.000000000 +0100
14@@ -25,7 +25,7 @@ 13@@ -25,7 +25,7 @@
15 MARK64=@MARK64@ 14 MARK64=@MARK64@
16 VERSION=0.2 15 VERSION=0.3
17 16
18-LIBDIR=$(PREFIX)/lib$(MARK64) 17-LIBDIR=$(PREFIX)/lib$(MARK64)
19+LIBDIR=$(PREFIX)/lib 18+LIBDIR=$(PREFIX)/lib
@@ -46,15 +45,15 @@ Index: git/Makefile.in
46@@ -66,26 +66,29 @@ 45@@ -66,26 +66,29 @@
47 install: all install-lib install-bin install-data 46 install: all install-lib install-bin install-data
48 47
49 pseudo: pseudo.o $(SHOBJS) $(DBOBJS) pseudo_server.o pseudo_ipc.o 48 pseudo: pseudo.o $(SHOBJS) $(DBOBJS) pseudo_client.o pseudo_server.o pseudo_ipc.o
50- $(CC) $(CFLAGS) -o pseudo \ 49- $(CC) $(CFLAGS) -o pseudo \
51+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -o pseudo \ 50+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -o pseudo \
52 pseudo.o pseudo_server.o pseudo_client.o pseudo_ipc.o \ 51 pseudo.o pseudo_server.o pseudo_client.o pseudo_ipc.o \
53 $(DBOBJS) $(SHOBJS) $(DBLDFLAGS) 52 $(DBOBJS) $(SHOBJS) $(DBLDFLAGS)
54 53
55 pseudolog: pseudolog.o $(SHOBJS) $(DBOBJS) 54 pseudolog: pseudolog.o $(SHOBJS) $(DBOBJS) pseudo_client.o pseudo_ipc.o
56- $(CC) $(CFLAGS) -o pseudolog pseudolog.o \ 55- $(CC) $(CFLAGS) -o pseudolog pseudolog.o pseudo_client.o pseudo_ipc.o \
57+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -o pseudolog pseudolog.o \ 56+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -o pseudolog pseudolog.o pseudo_client.o pseudo_ipc.o \
58 $(DBOBJS) $(SHOBJS) $(DBLDFLAGS) 57 $(DBOBJS) $(SHOBJS) $(DBLDFLAGS)
59 58
60 pseudodb: pseudodb.o $(SHOBJS) $(DBOBJS) pseudo_ipc.o 59 pseudodb: pseudodb.o $(SHOBJS) $(DBOBJS) pseudo_ipc.o
@@ -77,10 +76,10 @@ Index: git/Makefile.in
77 pseudo_client.o pseudo_server.o pseudo_ipc.o: pseudo_ipc.h 76 pseudo_client.o pseudo_server.o pseudo_ipc.o: pseudo_ipc.h
78 77
79 pseudo_client.o: pseudo_client.h 78 pseudo_client.o: pseudo_client.h
80@@ -103,7 +106,7 @@ 79@@ -101,7 +104,7 @@
81 80
82 # no-strict-aliasing is needed for the function pointer trickery. 81 # no-strict-aliasing is needed for the function pointer trickery.
83 pseudo_wrappers.o: pseudo_wrappers.c 82 pseudo_wrappers.o: $(GUTS) pseudo_wrappers.c pseudo_wrapfuncs.c pseudo_wrapfuncs.h
84- $(CC) -fno-strict-aliasing $(CFLAGS) -D_GNU_SOURCE -c -o pseudo_wrappers.o pseudo_wrappers.c 83- $(CC) -fno-strict-aliasing $(CFLAGS) -D_GNU_SOURCE -c -o pseudo_wrappers.o pseudo_wrappers.c
85+ $(CC) -fno-strict-aliasing $(CFLAGS) $(EXTRA_CFLAGS) -D_GNU_SOURCE -c -o pseudo_wrappers.o pseudo_wrappers.c 84+ $(CC) -fno-strict-aliasing $(CFLAGS) $(EXTRA_CFLAGS) -D_GNU_SOURCE -c -o pseudo_wrappers.o pseudo_wrappers.c
86 85
diff --git a/meta/packages/pseudo/pseudo_git.bb b/meta/packages/pseudo/pseudo_git.bb
index 1ba43c07f7..92ea897d66 100644
--- a/meta/packages/pseudo/pseudo_git.bb
+++ b/meta/packages/pseudo/pseudo_git.bb
@@ -6,12 +6,14 @@ LICENSE = "LGPL2.1"
6DEPENDS = "sqlite3" 6DEPENDS = "sqlite3"
7 7
8PV = "0.0+git${SRCPV}" 8PV = "0.0+git${SRCPV}"
9PR = "r4" 9PR = "r5"
10 10
11SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \ 11SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
12 file://tweakflags.patch \ 12 file://tweakflags.patch \
13 file://path-munge.patch \ 13 file://path-munge.patch \
14 file://ld_sacredness.patch" 14 file://ld_sacredness.patch \
15 file://make_parallel.patch \
16 file://static_sqlite.patch"
15 17
16FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo" 18FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"
17PROVIDES += "virtual/fakeroot" 19PROVIDES += "virtual/fakeroot"