summaryrefslogtreecommitdiffstats
path: root/meta/packages/pkgconfig/pkgconfig_0.22.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-08-01 19:11:11 +0000
committerRichard Purdie <richard@openedhand.com>2007-08-01 19:11:11 +0000
commit75825af40256d3990bb18a7de9685f249d9f833f (patch)
tree429b2962859d5779fc2929df5006e0c87b925ae4 /meta/packages/pkgconfig/pkgconfig_0.22.bb
parent7944fb200e56ea888c48e971c5af7e074f59f71a (diff)
downloadpoky-75825af40256d3990bb18a7de9685f249d9f833f.tar.gz
pkgconfig: Fix compile issues for non-native version
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2301 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pkgconfig/pkgconfig_0.22.bb')
-rw-r--r--meta/packages/pkgconfig/pkgconfig_0.22.bb28
1 files changed, 2 insertions, 26 deletions
diff --git a/meta/packages/pkgconfig/pkgconfig_0.22.bb b/meta/packages/pkgconfig/pkgconfig_0.22.bb
index 28cf2c53f8..599e1c815e 100644
--- a/meta/packages/pkgconfig/pkgconfig_0.22.bb
+++ b/meta/packages/pkgconfig/pkgconfig_0.22.bb
@@ -1,27 +1,3 @@
1SECTION = "console/utils" 1require pkgconfig.inc
2DESCRIPTION = "pkg-config is a system for managing library \
3compile/link flags that works with automake and autoconf. \
4It replaces the ubiquitous *-config scripts you may have \
5seen with a single tool."
6HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
7LICENSE = "GPL"
8 2
9SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \ 3SRC_URI += "file://autofoo.patch;patch=1"
10 file://glibconfig-sysdefs.h"
11
12S = "${WORKDIR}/pkg-config-${PV}/"
13
14inherit autotools
15
16acpaths = "-I ."
17do_configure () {
18 install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.8/
19 gnu-configize
20 libtoolize --force
21 oe_runconf
22}
23
24do_stage_prepend() {
25 install -d -m 0755 ${STAGING_DATADIR}/pkgconfig
26
27}