diff options
author | Ross Burton <ross@openedhand.com> | 2007-09-23 15:32:17 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2007-09-23 15:32:17 +0000 |
commit | 2aaaeda2b034c267632938b7b09489ac672a3206 (patch) | |
tree | f3e5e4ddfd191deaa01aa27737704d32b27f5e43 /meta/packages/pimlico | |
parent | ed66764821441b3ab8fde48edf2ff4b221d9e5ed (diff) | |
download | poky-2aaaeda2b034c267632938b7b09489ac672a3206.tar.gz |
Update tasks to 0.12
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2773 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pimlico')
-rw-r--r-- | meta/packages/pimlico/files/tasks-owl.diff | 60 | ||||
-rw-r--r-- | meta/packages/pimlico/files/tasks-single.diff | 9 | ||||
-rw-r--r-- | meta/packages/pimlico/tasks-0.10/delete-crash.diff | 71 | ||||
-rw-r--r-- | meta/packages/pimlico/tasks_0.12.bb (renamed from meta/packages/pimlico/tasks_0.10.bb) | 4 | ||||
-rw-r--r-- | meta/packages/pimlico/tasks_svn.bb | 3 |
5 files changed, 25 insertions, 122 deletions
diff --git a/meta/packages/pimlico/files/tasks-owl.diff b/meta/packages/pimlico/files/tasks-owl.diff index ea867d890d..ce1ed9db7e 100644 --- a/meta/packages/pimlico/files/tasks-owl.diff +++ b/meta/packages/pimlico/files/tasks-owl.diff | |||
@@ -1,14 +1,24 @@ | |||
1 | Index: src/gtk/tasks-ui.xml | 1 | Index: src/gtk/tasks-ui.xml |
2 | =================================================================== | 2 | =================================================================== |
3 | --- src/gtk/tasks-ui.xml (revision 288) | 3 | --- src/gtk/tasks-ui.xml (revision 338) |
4 | +++ src/gtk/tasks-ui.xml (working copy) | 4 | +++ src/gtk/tasks-ui.xml (working copy) |
5 | @@ -10,10 +10,8 @@ | 5 | @@ -7,17 +7,14 @@ |
6 | <menuitem action="EditTask"/> | ||
7 | <menuitem action="CompleteTask"/> | ||
8 | <separator/> | ||
9 | + <menuitem action="Undo"/> | ||
10 | + <menuitem action="Redo"/> | ||
11 | + <separator/> | ||
6 | <menuitem action="DeleteTask"/> | 12 | <menuitem action="DeleteTask"/> |
7 | <menuitem action="PurgeTasks"/> | 13 | <menuitem action="PurgeTasks"/> |
8 | <separator/> | 14 | <separator/> |
9 | + <menuitem action="About"/> | 15 | + <menuitem action="About"/> |
10 | <menuitem action="Quit"/> | 16 | <menuitem action="Quit"/> |
11 | </menu> | 17 | </menu> |
18 | - <menu action="EditMenu"> | ||
19 | - <menuitem action="Undo"/> | ||
20 | - <menuitem action="Redo"/> | ||
21 | - </menu> | ||
12 | - <menu action="HelpMenu"> | 22 | - <menu action="HelpMenu"> |
13 | - <menuitem action="About"/> | 23 | - <menuitem action="About"/> |
14 | - </menu> | 24 | - </menu> |
@@ -16,7 +26,7 @@ Index: src/gtk/tasks-ui.xml | |||
16 | </ui> | 26 | </ui> |
17 | Index: src/gtk/main.c | 27 | Index: src/gtk/main.c |
18 | =================================================================== | 28 | =================================================================== |
19 | --- src/gtk/main.c (revision 288) | 29 | --- src/gtk/main.c (revision 338) |
20 | +++ src/gtk/main.c (working copy) | 30 | +++ src/gtk/main.c (working copy) |
21 | @@ -21,6 +21,7 @@ | 31 | @@ -21,6 +21,7 @@ |
22 | #include <libecal/e-cal.h> | 32 | #include <libecal/e-cal.h> |
@@ -25,50 +35,28 @@ Index: src/gtk/main.c | |||
25 | +#include <owlwindowmenu.h> | 35 | +#include <owlwindowmenu.h> |
26 | 36 | ||
27 | #include <libkoto/ical-util.h> | 37 | #include <libkoto/ical-util.h> |
28 | #include <libkoto/koto-category-group.h> | 38 | #include <libkoto/koto-actions.h> |
29 | @@ -462,17 +463,6 @@ | 39 | @@ -564,8 +565,8 @@ |
30 | NULL); | ||
31 | } | ||
32 | |||
33 | -/* | ||
34 | - * Callback from the UI manager with the GtkMenu widget. Pack and add this to | ||
35 | - * the container. | ||
36 | - */ | ||
37 | -static void | ||
38 | -ui_add_widget (GtkUIManager *ui, GtkWidget *widget, GtkContainer *container) | ||
39 | -{ | ||
40 | - gtk_box_pack_start (GTK_BOX (container), widget, FALSE, FALSE, 0); | ||
41 | - gtk_widget_show (widget); | ||
42 | -} | ||
43 | - | ||
44 | /* TODO: split into global actions and actions that require a task to be selected */ | ||
45 | static const GtkActionEntry actions[] = | ||
46 | { | ||
47 | @@ -563,11 +553,12 @@ | ||
48 | } | ||
49 | /* Bind the accelerators */ | ||
50 | gtk_window_add_accel_group (GTK_WINDOW (window), gtk_ui_manager_get_accel_group (ui_manager)); | 40 | gtk_window_add_accel_group (GTK_WINDOW (window), gtk_ui_manager_get_accel_group (ui_manager)); |
51 | - g_signal_connect (ui_manager, "add-widget", G_CALLBACK (ui_add_widget), top_box); | ||
52 | |||
53 | /* Do this so that the menu is packed now instead of in the idle loop */ | ||
54 | gtk_ui_manager_ensure_update (ui_manager); | 41 | gtk_ui_manager_ensure_update (ui_manager); |
55 | - | 42 | |
56 | + owl_set_window_menu_item (GTK_WINDOW (window), | 43 | - menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar"); |
57 | + GTK_MENU_ITEM (gtk_ui_manager_get_widget (ui_manager, "/MenuBar/TasksMenu"))); | 44 | - gtk_box_pack_start (GTK_BOX (top_box), menu, FALSE, FALSE, 0); |
58 | + | 45 | + menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar/TasksMenu"); |
46 | + owl_set_window_menu_item (GTK_WINDOW (window), GTK_MENU_ITEM (menu)); | ||
47 | |||
59 | box = gtk_vbox_new (FALSE, 4); | 48 | box = gtk_vbox_new (FALSE, 4); |
60 | gtk_container_set_border_width (GTK_CONTAINER (box), 4); | 49 | gtk_container_set_border_width (GTK_CONTAINER (box), 4); |
61 | gtk_container_add (GTK_CONTAINER (top_box), box); | ||
62 | Index: src/gtk/Makefile.am | 50 | Index: src/gtk/Makefile.am |
63 | =================================================================== | 51 | =================================================================== |
64 | --- src/gtk/Makefile.am (revision 288) | 52 | --- src/gtk/Makefile.am (revision 338) |
65 | +++ src/gtk/Makefile.am (working copy) | 53 | +++ src/gtk/Makefile.am (working copy) |
66 | @@ -4,7 +4,7 @@ | 54 | @@ -4,7 +4,7 @@ |
67 | bin_PROGRAMS = tasks | 55 | bin_PROGRAMS = tasks |
68 | tasks_CPPFLAGS = -I$(top_srcdir)/ | 56 | tasks_CPPFLAGS = -I$(top_srcdir)/ |
69 | tasks_CFLAGS = -Wall $(GTK_CFLAGS) $(ECAL_CFLAGS) $(SEXY_CFLAGS) | 57 | tasks_CFLAGS = $(WARN_CFLAGS) $(GTK_CFLAGS) $(ECAL_CFLAGS) $(SEXY_CFLAGS) |
70 | -tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) | 58 | -tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) |
71 | +tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) -lowl | 59 | +tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) -lowl |
72 | 60 | ||
73 | tasks_SOURCES = \ | 61 | tasks_SOURCES = \ |
74 | main.c \ | 62 | main.c \ |
diff --git a/meta/packages/pimlico/files/tasks-single.diff b/meta/packages/pimlico/files/tasks-single.diff deleted file mode 100644 index dd807ea256..0000000000 --- a/meta/packages/pimlico/files/tasks-single.diff +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | Index: tasks/data/tasks.desktop.in | ||
2 | =================================================================== | ||
3 | --- tasks/data/tasks.desktop.in (revision 115) | ||
4 | +++ tasks/data/tasks.desktop.in (working copy) | ||
5 | @@ -9,3 +9,4 @@ | ||
6 | Categories=GTK;Application;Office;ProjectManagement; | ||
7 | Terminal=false | ||
8 | StartupNotify=true | ||
9 | +SingleInstance=true | ||
diff --git a/meta/packages/pimlico/tasks-0.10/delete-crash.diff b/meta/packages/pimlico/tasks-0.10/delete-crash.diff deleted file mode 100644 index 0b2ba473d4..0000000000 --- a/meta/packages/pimlico/tasks-0.10/delete-crash.diff +++ /dev/null | |||
@@ -1,71 +0,0 @@ | |||
1 | Index: libkoto/koto-utils.c | ||
2 | =================================================================== | ||
3 | --- libkoto/koto-utils.c (revision 294) | ||
4 | +++ libkoto/koto-utils.c (revision 295) | ||
5 | @@ -25,6 +25,7 @@ | ||
6 | |||
7 | typedef struct { | ||
8 | GtkWindow *window; | ||
9 | + GtkTreeModel *model; | ||
10 | char *title; | ||
11 | } WindowData; | ||
12 | |||
13 | @@ -67,19 +68,21 @@ | ||
14 | /* | ||
15 | * Update the window title, generally as the number of tasks has changed. | ||
16 | */ | ||
17 | -static void | ||
18 | -update_title (WindowData *data, GtkTreeModel *model) | ||
19 | +static gboolean | ||
20 | +update_title (gpointer user_data) | ||
21 | { | ||
22 | + WindowData *data = user_data; | ||
23 | int count = 0; | ||
24 | char *title; | ||
25 | |||
26 | g_assert (data); | ||
27 | - g_assert (model); | ||
28 | |||
29 | - gtk_tree_model_foreach (model, count_pending, &count); | ||
30 | + gtk_tree_model_foreach (data->model, count_pending, &count); | ||
31 | title = g_strdup_printf (data->title, count); | ||
32 | gtk_window_set_title (data->window, title); | ||
33 | g_free (title); | ||
34 | + | ||
35 | + return FALSE; | ||
36 | } | ||
37 | |||
38 | /* | ||
39 | @@ -89,7 +92,7 @@ | ||
40 | static void | ||
41 | on_row_inserted (GtkTreeModel *model, GtkTreePath *path, GtkTreeIter *iter, WindowData *data) | ||
42 | { | ||
43 | - update_title (data, model); | ||
44 | + g_idle_add (update_title, data); | ||
45 | } | ||
46 | |||
47 | /* | ||
48 | @@ -99,7 +102,7 @@ | ||
49 | static void | ||
50 | on_row_deleted (GtkTreeModel *model, GtkTreePath *path, WindowData *data) | ||
51 | { | ||
52 | - update_title (data, model); | ||
53 | + g_idle_add (update_title, data); | ||
54 | } | ||
55 | |||
56 | /* | ||
57 | @@ -135,6 +138,7 @@ | ||
58 | |||
59 | data = g_slice_new (WindowData); | ||
60 | data->window = window; | ||
61 | + data->model = model; | ||
62 | data->title = g_strdup (title); | ||
63 | |||
64 | g_object_weak_ref (G_OBJECT (model), on_weak_notify, data); | ||
65 | @@ -145,5 +149,5 @@ | ||
66 | "signal::row-deleted", G_CALLBACK (on_row_deleted), data, | ||
67 | NULL); | ||
68 | |||
69 | - update_title (data, model); | ||
70 | + update_title (data); | ||
71 | } | ||
diff --git a/meta/packages/pimlico/tasks_0.10.bb b/meta/packages/pimlico/tasks_0.12.bb index 75e589e740..ff8da563e6 100644 --- a/meta/packages/pimlico/tasks_0.10.bb +++ b/meta/packages/pimlico/tasks_0.12.bb | |||
@@ -1,8 +1,4 @@ | |||
1 | require tasks.inc | 1 | require tasks.inc |
2 | 2 | ||
3 | PR="r2" | ||
4 | |||
5 | SRC_URI = "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz \ | 3 | SRC_URI = "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz \ |
6 | file://tasks-single.diff;patch=1 \ | ||
7 | file://delete-crash.diff;patch=1;pnum=0 \ | ||
8 | file://tasks-owl.diff;patch=1;pnum=0" | 4 | file://tasks-owl.diff;patch=1;pnum=0" |
diff --git a/meta/packages/pimlico/tasks_svn.bb b/meta/packages/pimlico/tasks_svn.bb index b3da6ebe20..be3a8d0978 100644 --- a/meta/packages/pimlico/tasks_svn.bb +++ b/meta/packages/pimlico/tasks_svn.bb | |||
@@ -2,9 +2,8 @@ require tasks.inc | |||
2 | 2 | ||
3 | DEFAULT_PREFERENCE = "-1" | 3 | DEFAULT_PREFERENCE = "-1" |
4 | 4 | ||
5 | PV = "0.10+svnr${SRCREV}" | 5 | PV = "0.12+svnr${SRCREV}" |
6 | S = "${WORKDIR}/trunk" | 6 | S = "${WORKDIR}/trunk" |
7 | 7 | ||
8 | SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \ | 8 | SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \ |
9 | file://tasks-single.diff;patch=1 \ | ||
10 | file://tasks-owl.diff;patch=1" | 9 | file://tasks-owl.diff;patch=1" |