diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-16 10:56:17 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-16 10:56:17 +0000 |
commit | 7acfa9467f7acb4d15663ed81b46cc88fd1bd6a8 (patch) | |
tree | df62c5b38a72b8f2b654e6d17ed1204763c26ce7 /meta/packages/perl | |
parent | 5c0111cb9db0162d111eed41540de6a702b68e58 (diff) | |
download | poky-7acfa9467f7acb4d15663ed81b46cc88fd1bd6a8.tar.gz |
perl: Standardise config.sh location
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/perl')
-rw-r--r-- | meta/packages/perl/perl-native_5.8.8.bb | 6 | ||||
-rw-r--r-- | meta/packages/perl/perl.inc | 4 | ||||
-rw-r--r-- | meta/packages/perl/perl_5.8.8.bb | 5 |
3 files changed, 7 insertions, 8 deletions
diff --git a/meta/packages/perl/perl-native_5.8.8.bb b/meta/packages/perl/perl-native_5.8.8.bb index e2bdaee30a..fb8be281bf 100644 --- a/meta/packages/perl/perl-native_5.8.8.bb +++ b/meta/packages/perl/perl-native_5.8.8.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/" | |||
3 | SECTION = "libs" | 3 | SECTION = "libs" |
4 | LICENSE = "Artistic|GPL" | 4 | LICENSE = "Artistic|GPL" |
5 | DEPENDS = "virtual/db-native gdbm-native" | 5 | DEPENDS = "virtual/db-native gdbm-native" |
6 | PR = "r13" | 6 | PR = "r14" |
7 | 7 | ||
8 | SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \ | 8 | SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \ |
9 | file://perl-5.8.8-gcc-4.2.patch;patch=1 \ | 9 | file://perl-5.8.8-gcc-4.2.patch;patch=1 \ |
@@ -61,8 +61,8 @@ do_stage_append() { | |||
61 | # We need a hostperl link for building perl | 61 | # We need a hostperl link for building perl |
62 | ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl | 62 | ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl |
63 | # Store native config in non-versioned directory | 63 | # Store native config in non-versioned directory |
64 | install -d ${STAGING_DIR}/${HOST_SYS}/perl | 64 | install -d ${STAGING_LIBDIR}/perl |
65 | install config.sh ${STAGING_DIR}/${HOST_SYS}/perl | 65 | install config.sh ${STAGING_LIBDIR}/perl |
66 | } | 66 | } |
67 | 67 | ||
68 | PARALLEL_MAKE = "" | 68 | PARALLEL_MAKE = "" |
diff --git a/meta/packages/perl/perl.inc b/meta/packages/perl/perl.inc index 9e20ae63e6..15ae55cf17 100644 --- a/meta/packages/perl/perl.inc +++ b/meta/packages/perl/perl.inc | |||
@@ -36,8 +36,8 @@ do_install() { | |||
36 | } | 36 | } |
37 | 37 | ||
38 | do_stage() { | 38 | do_stage() { |
39 | install -d ${STAGING_DIR}/${HOST_SYS}/perl/ | 39 | install -d ${STAGING_LIBDIR}/perl/ |
40 | install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/ | 40 | install config.sh ${STAGING_LIBDIR}/perl/ |
41 | } | 41 | } |
42 | 42 | ||
43 | PACKAGES_DYNAMIC = "perl-module-*" | 43 | PACKAGES_DYNAMIC = "perl-module-*" |
diff --git a/meta/packages/perl/perl_5.8.8.bb b/meta/packages/perl/perl_5.8.8.bb index 977852ac21..0696de577f 100644 --- a/meta/packages/perl/perl_5.8.8.bb +++ b/meta/packages/perl/perl_5.8.8.bb | |||
@@ -137,11 +137,10 @@ do_install() { | |||
137 | fi | 137 | fi |
138 | } | 138 | } |
139 | do_stage() { | 139 | do_stage() { |
140 | install -d ${STAGING_DIR}/${HOST_SYS}/perl \ | 140 | install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \ |
141 | ${STAGING_LIBDIR_NATIVE}/perl/${PV} \ | ||
142 | ${STAGING_LIBDIR}/perl/${PV}/CORE | 141 | ${STAGING_LIBDIR}/perl/${PV}/CORE |
143 | # target config, used by cpan.bbclass to extract version information | 142 | # target config, used by cpan.bbclass to extract version information |
144 | install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/ | 143 | install config.sh ${STAGING_LIBDIR}/perl/ |
145 | # target configuration, used by native perl when cross-compiling | 144 | # target configuration, used by native perl when cross-compiling |
146 | install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl | 145 | install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl |
147 | # perl shared library headers | 146 | # perl shared library headers |