diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-18 22:04:55 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-18 22:04:55 +0000 |
commit | 5b44fa1f2929b850cd9b36df6db10a14d2b99a39 (patch) | |
tree | 80a2d102c56820616c1ab4d6296eeed2ae887bd9 /meta/packages/perl | |
parent | ca5f36ee6ad756e1e540288a56a504c1d8ecc7a3 (diff) | |
download | poky-5b44fa1f2929b850cd9b36df6db10a14d2b99a39.tar.gz |
perl: Updates to ensure Config-heavy-target.pl is found
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/perl')
-rw-r--r-- | meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch | 13 | ||||
-rw-r--r-- | meta/packages/perl/perl_5.8.8.bb | 2 |
2 files changed, 13 insertions, 2 deletions
diff --git a/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch b/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch index 1aacd35189..ac519a0271 100644 --- a/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch +++ b/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch | |||
@@ -18,7 +18,7 @@ values would be valid for the host only. | |||
18 | 18 | ||
19 | return $self->fetch_string($key); | 19 | return $self->fetch_string($key); |
20 | } | 20 | } |
21 | @@ -530,7 +530,12 @@ | 21 | @@ -530,7 +530,21 @@ |
22 | sub DESTROY { } | 22 | sub DESTROY { } |
23 | 23 | ||
24 | sub AUTOLOAD { | 24 | sub AUTOLOAD { |
@@ -28,7 +28,16 @@ values would be valid for the host only. | |||
28 | + { | 28 | + { |
29 | + $cfgfile = 'Config_heavy-target.pl'; | 29 | + $cfgfile = 'Config_heavy-target.pl'; |
30 | + } | 30 | + } |
31 | + require $cfgfile; | 31 | + if (defined $ENV{PERL_ARCHLIB}) |
32 | + { | ||
33 | + push @INC, $ENV{PERL_ARCHLIB}; | ||
34 | + require $cfgfile; | ||
35 | + pop @INC; | ||
36 | + } | ||
37 | + else | ||
38 | + { | ||
39 | + require $cfgfile; | ||
40 | + } | ||
32 | goto \&launcher unless $Config::AUTOLOAD =~ /launcher$/; | 41 | goto \&launcher unless $Config::AUTOLOAD =~ /launcher$/; |
33 | die "&Config::AUTOLOAD failed on $Config::AUTOLOAD"; | 42 | die "&Config::AUTOLOAD failed on $Config::AUTOLOAD"; |
34 | } | 43 | } |
diff --git a/meta/packages/perl/perl_5.8.8.bb b/meta/packages/perl/perl_5.8.8.bb index fa1a8d34c9..bf68cfcc8e 100644 --- a/meta/packages/perl/perl_5.8.8.bb +++ b/meta/packages/perl/perl_5.8.8.bb | |||
@@ -129,6 +129,8 @@ do_install() { | |||
129 | 129 | ||
130 | install -d ${D}${datadir}/perl/${PV}/ExtUtils | 130 | install -d ${D}${datadir}/perl/${PV}/ExtUtils |
131 | install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/ | 131 | install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/ |
132 | |||
133 | ln -s Config_heavy.pl ${D}${libdir}/perl/${PV}/Config_heavy-target.pl | ||
132 | } | 134 | } |
133 | 135 | ||
134 | PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess" | 136 | PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess" |