diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-05-30 14:10:03 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-05-30 14:10:03 +0000 |
commit | 08aabf7128532549d7e99f21106f855adb8fb6a1 (patch) | |
tree | f8738d5862503b77880d5f8d19791d4f4be9a895 /meta/packages/perl | |
parent | 8bae652a580325b9eb1ac31bcd0bf171348b72ba (diff) | |
download | poky-08aabf7128532549d7e99f21106f855adb8fb6a1.tar.gz |
perl: rest of sync with OE for uclibc
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1828 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/perl')
-rw-r--r-- | meta/packages/perl/libxml-parser-perl_2.34.bb | 2 | ||||
-rw-r--r-- | meta/packages/perl/perl_5.8.8.bb | 25 |
2 files changed, 24 insertions, 3 deletions
diff --git a/meta/packages/perl/libxml-parser-perl_2.34.bb b/meta/packages/perl/libxml-parser-perl_2.34.bb index 0b0cd750b0..46ce6512ca 100644 --- a/meta/packages/perl/libxml-parser-perl_2.34.bb +++ b/meta/packages/perl/libxml-parser-perl_2.34.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | SECTION = "libs" | 1 | SECTION = "libs" |
2 | LICENSE = "Artistic" | 2 | LICENSE = "Artistic" |
3 | DEPENDS += "expat-native" | 3 | DEPENDS += "expat-native" |
4 | PR = "r9" | 4 | PR = "r10" |
5 | 5 | ||
6 | SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz" | 6 | SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz" |
7 | 7 | ||
diff --git a/meta/packages/perl/perl_5.8.8.bb b/meta/packages/perl/perl_5.8.8.bb index 42a376c323..d603c9d67d 100644 --- a/meta/packages/perl/perl_5.8.8.bb +++ b/meta/packages/perl/perl_5.8.8.bb | |||
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL" | |||
5 | PRIORITY = "optional" | 5 | PRIORITY = "optional" |
6 | # We need gnugrep (for -I) | 6 | # We need gnugrep (for -I) |
7 | DEPENDS = "virtual/db perl-native grep-native" | 7 | DEPENDS = "virtual/db perl-native grep-native" |
8 | PR = "r18" | 8 | PR = "r19" |
9 | 9 | ||
10 | # Major part of version | 10 | # Major part of version |
11 | PVM = "5.8" | 11 | PVM = "5.8" |
@@ -58,10 +58,15 @@ do_configure() { | |||
58 | # Fixups for uclibc | 58 | # Fixups for uclibc |
59 | if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibcgnueabi" ]; then | 59 | if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibcgnueabi" ]; then |
60 | sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \ | 60 | sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \ |
61 | -e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \ | ||
61 | -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \ | 62 | -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \ |
63 | -e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \ | ||
62 | -e "s,\(d_getnetbyaddr_r=\)'define',\1'undef',g" \ | 64 | -e "s,\(d_getnetbyaddr_r=\)'define',\1'undef',g" \ |
65 | -e "s,\(getnetbyaddr_r_proto=\)'\w+',\1'0',g" \ | ||
63 | -e "s,\(d_getnetent_r=\)'define',\1'undef',g" \ | 66 | -e "s,\(d_getnetent_r=\)'define',\1'undef',g" \ |
67 | -e "s,\(getnetent_r_proto=\)'\w+',\1'0',g" \ | ||
64 | -e "s,\(d_sockatmark=\)'define',\1'undef',g" \ | 68 | -e "s,\(d_sockatmark=\)'define',\1'undef',g" \ |
69 | -e "s,\(d_sockatmarkproto=\)'\w+',\1'0',g" \ | ||
65 | config.sh-${TARGET_ARCH}-${TARGET_OS} | 70 | config.sh-${TARGET_ARCH}-${TARGET_OS} |
66 | fi | 71 | fi |
67 | 72 | ||
@@ -121,9 +126,25 @@ do_install() { | |||
121 | fi | 126 | fi |
122 | } | 127 | } |
123 | do_stage() { | 128 | do_stage() { |
124 | install -d ${STAGING_DIR}/${HOST_SYS}/perl/ | 129 | install -d ${STAGING_DIR}/${HOST_SYS}/perl \ |
130 | ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV} \ | ||
131 | ${STAGING_LIBDIR}/perl/${PV}/CORE | ||
132 | # target config, used by cpan.bbclass to extract version information | ||
125 | install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/ | 133 | install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/ |
134 | # target configuration, used by native perl when cross-compiling | ||
126 | install lib/Config_heavy.pl ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/Config_heavy-target.pl | 135 | install lib/Config_heavy.pl ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/Config_heavy-target.pl |
136 | # perl shared library headers | ||
137 | for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \ | ||
138 | uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \ | ||
139 | perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \ | ||
140 | hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \ | ||
141 | cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \ | ||
142 | reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \ | ||
143 | nostdio.h perlapi.h perlvars.h reentr.inc thrdvar.h util.h \ | ||
144 | dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \ | ||
145 | thread.h warnings.h; do | ||
146 | install $i ${STAGING_LIBDIR}/perl/${PV}/CORE | ||
147 | done | ||
127 | } | 148 | } |
128 | 149 | ||
129 | PACKAGES = "perl-dbg perl perl-misc perl-lib perl-dev perl-pod perl-doc" | 150 | PACKAGES = "perl-dbg perl perl-misc perl-lib perl-dev perl-pod perl-doc" |