summaryrefslogtreecommitdiffstats
path: root/meta/packages/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-10-30 08:21:24 +0000
committerRichard Purdie <richard@openedhand.com>2007-10-30 08:21:24 +0000
commitbf8f4d45ee8cea9d44aa4b59065390a22ba91a2f (patch)
treeb5b0ab2d477cf75beab7d225e8c14f165a199a05 /meta/packages/perl/perl_5.8.8.bb
parent1ba6bdf2df5fdfea7c3c93cb2a1fc54c647b6877 (diff)
downloadpoky-bf8f4d45ee8cea9d44aa4b59065390a22ba91a2f.tar.gz
perl: Sync with OE, fix hardcoded staging references
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3034 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/perl/perl_5.8.8.bb')
-rw-r--r--meta/packages/perl/perl_5.8.8.bb31
1 files changed, 21 insertions, 10 deletions
diff --git a/meta/packages/perl/perl_5.8.8.bb b/meta/packages/perl/perl_5.8.8.bb
index d603c9d67d..977852ac21 100644
--- a/meta/packages/perl/perl_5.8.8.bb
+++ b/meta/packages/perl/perl_5.8.8.bb
@@ -5,18 +5,21 @@ LICENSE = "Artistic|GPL"
5PRIORITY = "optional" 5PRIORITY = "optional"
6# We need gnugrep (for -I) 6# We need gnugrep (for -I)
7DEPENDS = "virtual/db perl-native grep-native" 7DEPENDS = "virtual/db perl-native grep-native"
8PR = "r19" 8PR = "r20"
9 9
10# Major part of version 10# Major part of version
11PVM = "5.8" 11PVM = "5.8"
12 12
13SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \ 13SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
14 file://Makefile.patch;patch=1 \ 14 file://Makefile.patch;patch=1 \
15 file://Makefile.SH.patch \ 15 file://Makefile.SH.patch;patch=1 \
16 file://makedepend-dash.patch;patch=1 \
17 file://installperl.patch;patch=1 \
16 file://perl-dynloader.patch;patch=1 \ 18 file://perl-dynloader.patch;patch=1 \
17 file://perl-moreconfig.patch;patch=1 \ 19 file://perl-moreconfig.patch;patch=1 \
18 file://letgcc-find-errno.patch;patch=1 \ 20 file://letgcc-find-errno.patch;patch=1 \
19 file://generate-sh.patch;patch=1 \ 21 file://generate-sh.patch;patch=1 \
22 file://perl-5.8.8-gcc-4.2.patch;patch=1 \
20 file://09_fix_installperl.patch;patch=1 \ 23 file://09_fix_installperl.patch;patch=1 \
21 file://52_debian_extutils_hacks.patch;patch=1 \ 24 file://52_debian_extutils_hacks.patch;patch=1 \
22 file://53_debian_mod_paths.patch;patch=1 \ 25 file://53_debian_mod_paths.patch;patch=1 \
@@ -25,6 +28,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
25 file://60_debian_libnet_config_path.patch;patch=1 \ 28 file://60_debian_libnet_config_path.patch;patch=1 \
26 file://62_debian_cpan_definstalldirs.patch;patch=1 \ 29 file://62_debian_cpan_definstalldirs.patch;patch=1 \
27 file://64_debian_enc2xs_inc.patch;patch=1 \ 30 file://64_debian_enc2xs_inc.patch;patch=1 \
31 file://asm-pageh-fix.patch;patch=1 \
28 file://config.sh \ 32 file://config.sh \
29 file://config.sh-32 \ 33 file://config.sh-32 \
30 file://config.sh-32-le \ 34 file://config.sh-32-le \
@@ -37,15 +41,14 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
37HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}" 41HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}"
38 42
39# Where to find .so files - use the -native versions not those from the target build 43# Where to find .so files - use the -native versions not those from the target build
40export PERLHOSTLIB = "${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/" 44export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl/${PV}/"
41 45
42do_configure() { 46do_configure() {
43 # Make hostperl in build directory be the native perl 47 # Make hostperl in build directory be the native perl
44 cp -f ${HOSTPERL} hostperl 48 cp -f ${HOSTPERL} hostperl
45 49
46 # This is silly - should just patch Makefile.SH directly 50 # Do our work in the cross subdir
47 cd Cross 51 cd Cross
48 cp -f ${WORKDIR}/Makefile.SH.patch .
49 52
50 # Generate configuration 53 # Generate configuration
51 rm -f config.sh-${TARGET_ARCH}-${TARGET_OS} 54 rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
@@ -87,8 +90,6 @@ do_configure() {
87 rm -f config 90 rm -f config
88 echo "ARCH = ${TARGET_ARCH}" > config 91 echo "ARCH = ${TARGET_ARCH}" > config
89 echo "OS = ${TARGET_OS}" >> config 92 echo "OS = ${TARGET_OS}" >> config
90
91 oe_runmake patch
92} 93}
93do_compile() { 94do_compile() {
94 if test "${MACHINE}" != "native"; then 95 if test "${MACHINE}" != "native"; then
@@ -121,18 +122,28 @@ do_install() {
121 sed -i -e "s,${D},,g" \ 122 sed -i -e "s,${D},,g" \
122 -e "s,-isystem${STAGING_INCDIR} ,,g" \ 123 -e "s,-isystem${STAGING_INCDIR} ,,g" \
123 -e "s,${STAGING_LIBDIR},${libdir},g" \ 124 -e "s,${STAGING_LIBDIR},${libdir},g" \
125 -e "s,${STAGING_BINDIR},${bindir},g" \
124 -e "s,${STAGING_INCDIR},${includedir},g" \ 126 -e "s,${STAGING_INCDIR},${includedir},g" \
125 ${D}/${libdir}/perl/${PV}/Config_heavy.pl 127 -e "s,${CROSS_DIR}${base_bindir}/,,g" \
128 ${D}${bindir}/h2xs \
129 ${D}${bindir}/h2ph \
130 ${D}${datadir}/perl/${PV}/pod/*.pod \
131 ${D}${datadir}/perl/${PV}/cacheout.pl \
132 ${D}${datadir}/perl/${PV}/FileCache.pm \
133 ${D}${libdir}/perl/${PV}/Config.pm \
134 ${D}${libdir}/perl/${PV}/Config_heavy.pl \
135 ${D}${libdir}/perl/${PV}/CORE/perl.h \
136 ${D}${libdir}/perl/${PV}/CORE/pp.h
126 fi 137 fi
127} 138}
128do_stage() { 139do_stage() {
129 install -d ${STAGING_DIR}/${HOST_SYS}/perl \ 140 install -d ${STAGING_DIR}/${HOST_SYS}/perl \
130 ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV} \ 141 ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
131 ${STAGING_LIBDIR}/perl/${PV}/CORE 142 ${STAGING_LIBDIR}/perl/${PV}/CORE
132 # target config, used by cpan.bbclass to extract version information 143 # target config, used by cpan.bbclass to extract version information
133 install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/ 144 install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
134 # target configuration, used by native perl when cross-compiling 145 # target configuration, used by native perl when cross-compiling
135 install lib/Config_heavy.pl ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/Config_heavy-target.pl 146 install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
136 # perl shared library headers 147 # perl shared library headers
137 for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \ 148 for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
138 uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \ 149 uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \