summaryrefslogtreecommitdiffstats
path: root/meta/packages/perl/perl.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-27 21:04:11 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-27 21:04:11 +0000
commit80785a10721e523029c27f264fca5a892cf68e36 (patch)
treed33b51538db742a5d6f8df6b184b5531e8bf68ce /meta/packages/perl/perl.inc
parentbd4fd028a799e804d803eac14ccb9e164ecc4938 (diff)
downloadpoky-80785a10721e523029c27f264fca5a892cf68e36.tar.gz
perl: 5.8.7 -> 5.8.8 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1785 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/perl/perl.inc')
-rw-r--r--meta/packages/perl/perl.inc34
1 files changed, 7 insertions, 27 deletions
diff --git a/meta/packages/perl/perl.inc b/meta/packages/perl/perl.inc
index 4f42d78ded..9e20ae63e6 100644
--- a/meta/packages/perl/perl.inc
+++ b/meta/packages/perl/perl.inc
@@ -9,43 +9,23 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
9 file://Makefile.patch;patch=1 \ 9 file://Makefile.patch;patch=1 \
10 file://config.sh-arm-linux.patch;patch=1 \ 10 file://config.sh-arm-linux.patch;patch=1 \
11 file://libperl-5.8.3-create-libperl-soname.patch;patch=1;pnum=0 \ 11 file://libperl-5.8.3-create-libperl-soname.patch;patch=1;pnum=0 \
12 file://uclibc.patch;patch=1 \ 12 file://Makefile.SH.patch"
13 file://Makefile.SH.patch \
14 file://config.sh-mipsel-linux \
15 file://config.sh-i686-linux"
16 13
17HOSTPERL="${STAGING_BINDIR_NATIVE}/perl${PV}" 14HOSTPERL="${STAGING_BINDIR_NATIVE}/perl${PV}"
18 15
19do_configure() {
20 ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
21 cp ${HOSTPERL} hostperl
22 cd Cross
23 rm -f Makefile.SH.patch
24 cp ${WORKDIR}/Makefile.SH.patch .
25 cp ${WORKDIR}/config.sh-mipsel-linux .
26 cp ${WORKDIR}/config.sh-i686-linux .
27 cat config.sh-arm-linux | sed -e "s,arm-linux,armeb-linux,g" > config.sh-armeb-linux
28 for i in config.sh-*-linux; do
29 a="`echo $i|sed -e 's,^config.sh-,,; s,-linux$,,'`"
30 newfile="`echo $i|sed -e 's,-linux$,-linux-uclibc,g'`"
31 cat $i | sed -e "s,${a}-linux,${a}-linux-uclibc,g; \
32 s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
33 done
34 sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
35 rm -f config
36 echo "ARCH = ${TARGET_ARCH}" > config
37 echo "OS = ${TARGET_OS}" >> config
38 oe_runmake patch
39}
40
41do_compile() { 16do_compile() {
42 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL 17 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
43 cd Cross 18 cd Cross
44 # You must use gcc to link on sh 19 # You must use gcc to link on sh
45 OPTIONS="" 20 OPTIONS=""
46 if test ${TARGET_ARCH} = "sh3" -o ${TARGET_ARCH} = "sh4"; then 21 if test ${TARGET_ARCH} = "sh3" -o ${TARGET_ARCH} = "sh4"; then
47 OPTIONS="LD=${TARGET_ARCH}-${TARGET_OS}-gcc" 22 OPTIONS="LD=${TARGET_SYS}-gcc"
48 fi 23 fi
24 # You must use gcc to link on powerpc also
25 if test ${TARGET_ARCH} = "powerpc" ; then
26 OPTIONS="LD=${TARGET_SYS}-gcc"
27 fi
28
49 oe_runmake perl $OPTIONS 29 oe_runmake perl $OPTIONS
50} 30}
51 31