diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-18 20:05:55 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-18 20:05:55 +0000 |
commit | ca5f36ee6ad756e1e540288a56a504c1d8ecc7a3 (patch) | |
tree | 9ad90f44e75c449f54f30bb702aa797ee8083a78 /meta/packages/perl/perl-native_5.8.8.bb | |
parent | 06685d7558891dc50b439cf82c394cfadc3ee1d4 (diff) | |
download | poky-ca5f36ee6ad756e1e540288a56a504c1d8ecc7a3.tar.gz |
perl: Update from OE.dev and convert to use do_install for staging
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/perl/perl-native_5.8.8.bb')
-rw-r--r-- | meta/packages/perl/perl-native_5.8.8.bb | 110 |
1 files changed, 68 insertions, 42 deletions
diff --git a/meta/packages/perl/perl-native_5.8.8.bb b/meta/packages/perl/perl-native_5.8.8.bb index fb8be281bf..05b4c1e64e 100644 --- a/meta/packages/perl/perl-native_5.8.8.bb +++ b/meta/packages/perl/perl-native_5.8.8.bb | |||
@@ -20,49 +20,75 @@ S = "${WORKDIR}/perl-${PV}" | |||
20 | inherit native | 20 | inherit native |
21 | 21 | ||
22 | do_configure () { | 22 | do_configure () { |
23 | ./Configure \ | 23 | ./Configure \ |
24 | -Dcc="${CC}" \ | 24 | -Dcc="${CC}" \ |
25 | -Dcflags="${CFLAGS}" \ | 25 | -Dcflags="${CFLAGS}" \ |
26 | -Dldflags="${LDFLAGS}" \ | 26 | -Dldflags="${LDFLAGS}" \ |
27 | -Dcf_by="Open Embedded" \ | 27 | -Dcf_by="Open Embedded" \ |
28 | -Dprefix=${prefix} \ | 28 | -Dprefix=${prefix} \ |
29 | -Dvendorprefix=${prefix} \ | 29 | -Dvendorprefix=${prefix} \ |
30 | -Dvendorprefix=${prefix} \ | 30 | -Dvendorprefix=${prefix} \ |
31 | -Dsiteprefix=${prefix} \ | 31 | -Dsiteprefix=${prefix} \ |
32 | \ | 32 | \ |
33 | -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \ | 33 | -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \ |
34 | -Darchlib=${STAGING_LIBDIR}/perl/${PV} \ | 34 | -Darchlib=${STAGING_LIBDIR}/perl/${PV} \ |
35 | -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \ | 35 | -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \ |
36 | -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \ | 36 | -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \ |
37 | -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \ | 37 | -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \ |
38 | -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \ | 38 | -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \ |
39 | \ | 39 | \ |
40 | -Duseshrplib \ | 40 | -Duseshrplib \ |
41 | -Dusethreads \ | 41 | -Dusethreads \ |
42 | -Duseithreads \ | 42 | -Duseithreads \ |
43 | -Duselargefiles \ | 43 | -Duselargefiles \ |
44 | -Ud_dosuid \ | 44 | -Dnoextensions=ODBM_File \ |
45 | -Ui_db \ | 45 | -Ud_dosuid \ |
46 | -Ui_ndbm \ | 46 | -Ui_db \ |
47 | -Ui_gdbm \ | 47 | -Ui_ndbm \ |
48 | -Di_shadow \ | 48 | -Ui_gdbm \ |
49 | -Di_syslog \ | 49 | -Di_shadow \ |
50 | -Duseperlio \ | 50 | -Di_syslog \ |
51 | -Dman3ext=3pm \ | 51 | -Duseperlio \ |
52 | -Uafs \ | 52 | -Dman3ext=3pm \ |
53 | -Ud_csh \ | 53 | -Uafs \ |
54 | -Uusesfio \ | 54 | -Ud_csh \ |
55 | -Uusenm -des | 55 | -Uusesfio \ |
56 | sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!; | 56 | -Uusenm -des |
57 | s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new | ||
58 | mv config.sh.new config.sh | ||
59 | } | 57 | } |
60 | do_stage_append() { | 58 | |
61 | # We need a hostperl link for building perl | 59 | NATIVE_INSTALL_WORKS = "1" |
62 | ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl | 60 | do_install () { |
63 | # Store native config in non-versioned directory | 61 | oe_runmake 'DESTDIR=${D}' install |
64 | install -d ${STAGING_LIBDIR}/perl | 62 | |
65 | install config.sh ${STAGING_LIBDIR}/perl | 63 | # We need a hostperl link for building perl |
64 | ln -sf perl${PV} ${D}${bindir}/hostperl | ||
65 | |||
66 | install -d ${D}${libdir}/perl/${PV}/CORE \ | ||
67 | ${D}${datadir}/perl/${PV}/ExtUtils | ||
68 | |||
69 | # Save native config | ||
70 | install config.sh ${D}${libdir}/perl | ||
71 | install lib/Config.pm ${D}${libdir}/perl/${PV}/ | ||
72 | install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/ | ||
73 | |||
74 | # perl shared library headers | ||
75 | for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \ | ||
76 | uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \ | ||
77 | perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \ | ||
78 | hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \ | ||
79 | cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \ | ||
80 | reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \ | ||
81 | nostdio.h perlapi.h perlvars.h reentr.inc thrdvar.h util.h \ | ||
82 | dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \ | ||
83 | thread.h warnings.h; do | ||
84 | install $i ${D}${libdir}/perl/${PV}/CORE | ||
85 | done | ||
86 | } | ||
87 | do_install_append_nylon() { | ||
88 | # get rid of definitions not supported by the gcc version we use for nylon... | ||
89 | for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do | ||
90 | perl -pi -e 's/-Wdeclaration-after-statement //g' ${i} | ||
91 | done | ||
66 | } | 92 | } |
67 | 93 | ||
68 | PARALLEL_MAKE = "" | 94 | PARALLEL_MAKE = "" |