summaryrefslogtreecommitdiffstats
path: root/meta/packages/perl/perl-5.8.8/Makefile.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-10-30 08:21:24 +0000
committerRichard Purdie <richard@openedhand.com>2007-10-30 08:21:24 +0000
commitbf8f4d45ee8cea9d44aa4b59065390a22ba91a2f (patch)
treeb5b0ab2d477cf75beab7d225e8c14f165a199a05 /meta/packages/perl/perl-5.8.8/Makefile.patch
parent1ba6bdf2df5fdfea7c3c93cb2a1fc54c647b6877 (diff)
downloadpoky-bf8f4d45ee8cea9d44aa4b59065390a22ba91a2f.tar.gz
perl: Sync with OE, fix hardcoded staging references
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3034 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/perl/perl-5.8.8/Makefile.patch')
-rw-r--r--meta/packages/perl/perl-5.8.8/Makefile.patch42
1 files changed, 38 insertions, 4 deletions
diff --git a/meta/packages/perl/perl-5.8.8/Makefile.patch b/meta/packages/perl/perl-5.8.8/Makefile.patch
index c78a39b178..ed494b3287 100644
--- a/meta/packages/perl/perl-5.8.8/Makefile.patch
+++ b/meta/packages/perl/perl-5.8.8/Makefile.patch
@@ -1,6 +1,18 @@
1--- perl-5.8.8/Cross/Makefile 2007/04/06 00:47:46 1.1 1Index: perl-5.8.8/Cross/Makefile
2+++ perl-5.8.8/Cross/Makefile 2007/04/06 00:48:04 2===================================================================
3@@ -12,7 +12,7 @@ 3--- perl-5.8.8.orig/Cross/Makefile 2004-01-12 21:44:01.000000000 +0100
4+++ perl-5.8.8/Cross/Makefile 2007-08-15 00:15:18.000000000 +0200
5@@ -2,7 +2,8 @@
6 #
7 ## $Id: Makefile,v 1.7 2004/01/12 15:41:02 red Exp red $
8
9-export TOPDIR=${shell pwd}
10+override TOPDIR=${shell pwd}
11+export TOPDIR
12 include $(TOPDIR)/config
13 export CFLAGS
14 export SYS=$(ARCH)-$(OS)
15@@ -12,7 +13,7 @@
4 16
5 export CC = $(CROSS)gcc 17 export CC = $(CROSS)gcc
6 export CXX = $(CROSS)g++ 18 export CXX = $(CROSS)g++
@@ -9,7 +21,29 @@
9 export STRIP = $(CROSS)strip 21 export STRIP = $(CROSS)strip
10 export AR = $(CROSS)ar 22 export AR = $(CROSS)ar
11 export RANLIB = $(CROSS)ranlib 23 export RANLIB = $(CROSS)ranlib
12@@ -58,11 +58,11 @@ 24@@ -34,21 +35,6 @@
25 all:
26 @echo Please read the README file before doing anything else.
27
28-gen_patch:
29- diff -Bbur ../Makefile.SH Makefile.SH > Makefile.SH.patch
30- diff -Bbur ../installperl installperl > installperl.patch
31-
32-patch:
33- cd .. ; if [ ! -e ./CROSS_PATCHED ] ; then \
34- patch -p1 < Cross/Makefile.SH.patch; \
35- patch -p1 < Cross/installperl.patch ; mv installperl installperl-patched; \
36- sed -e 's/XXSTRIPXX/$(SYS)/' installperl-patched > installperl; \
37- touch CROSS_PATCHED ; fi
38-
39-dry_patch:
40- cd .. ; patch --dry-run -p1 < Cross/Makefile.SH.patch; \
41- patch --dry-run -p1 < Cross/installperl.patch; \
42-
43 perl:
44 @echo Perl cross-build directory is $(TOPDIR)
45 @echo Target arch is $(SYS)
46@@ -58,11 +44,11 @@
13 $(TOPDIR)/generate_config_sh config.sh-$(SYS) > $(TOPDIR)/../config.sh 47 $(TOPDIR)/generate_config_sh config.sh-$(SYS) > $(TOPDIR)/../config.sh
14 cd $(TOPDIR)/.. ; ./Configure -S ; make depend ; make ; make more 48 cd $(TOPDIR)/.. ; ./Configure -S ; make depend ; make ; make more
15 cd $(TOPDIR)/.. ; mkdir -p fake_config_library ; cp lib/Config.pm fake_config_library 49 cd $(TOPDIR)/.. ; mkdir -p fake_config_library ; cp lib/Config.pm fake_config_library