diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/pcmciautils | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pcmciautils')
4 files changed, 100 insertions, 0 deletions
diff --git a/meta/packages/pcmciautils/pcmciautils-013/makefile_fix.patch b/meta/packages/pcmciautils/pcmciautils-013/makefile_fix.patch new file mode 100644 index 0000000000..a45f9e20e3 --- /dev/null +++ b/meta/packages/pcmciautils/pcmciautils-013/makefile_fix.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | Hardcoded paths are bad... | ||
2 | |||
3 | Index: pcmciautils-013/Makefile | ||
4 | =================================================================== | ||
5 | --- pcmciautils-013.orig/Makefile 2006-03-26 11:56:41.000000000 +0100 | ||
6 | +++ pcmciautils-013/Makefile 2006-05-09 22:10:16.000000000 +0100 | ||
7 | @@ -69,11 +69,11 @@ | ||
8 | mandir = ${prefix}/usr/share/man | ||
9 | srcdir = . | ||
10 | |||
11 | -INSTALL = /usr/bin/install -c | ||
12 | +INSTALL = install -c | ||
13 | INSTALL_PROGRAM = ${INSTALL} | ||
14 | INSTALL_DATA = ${INSTALL} -m 644 | ||
15 | INSTALL_SCRIPT = ${INSTALL_PROGRAM} | ||
16 | -SYMLINK = /usr/bin/ln -sf | ||
17 | +SYMLINK = ln -sf | ||
18 | |||
19 | # place to put our hotplug scripts nodes | ||
20 | hotplugdir = ${etcdir}/hotplug | ||
diff --git a/meta/packages/pcmciautils/pcmciautils-013/version_workaround.patch b/meta/packages/pcmciautils/pcmciautils-013/version_workaround.patch new file mode 100644 index 0000000000..ff34e139b3 --- /dev/null +++ b/meta/packages/pcmciautils/pcmciautils-013/version_workaround.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly | ||
2 | under arm gcc 3.4.x so we work around it. | ||
3 | |||
4 | Index: pcmciautils-013/src/pccardctl.c | ||
5 | =================================================================== | ||
6 | --- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100 | ||
7 | +++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100 | ||
8 | @@ -350,7 +350,7 @@ | ||
9 | } | ||
10 | |||
11 | static void print_header(void) { | ||
12 | - printf("pcmciautils %s\n", PCMCIAUTILS_VERSION); | ||
13 | + printf("pcmciautils 013\n"); | ||
14 | printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n"); | ||
15 | printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n"); | ||
16 | } | ||
diff --git a/meta/packages/pcmciautils/pcmciautils_010.bb b/meta/packages/pcmciautils/pcmciautils_010.bb new file mode 100644 index 0000000000..8045a0e442 --- /dev/null +++ b/meta/packages/pcmciautils/pcmciautils_010.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem" | ||
2 | DEPENDS = "sysfsutils udev module-init-tools" | ||
3 | RDEPENDS = "udev module-init-tools" | ||
4 | HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html" | ||
5 | SECTION = "kernel/userland" | ||
6 | PRIORITY = "optional" | ||
7 | |||
8 | SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2" | ||
9 | S = "${WORKDIR}/pcmciautils-${PV}" | ||
10 | |||
11 | PR = "r3" | ||
12 | |||
13 | export HOSTCC = "${BUILD_CC}" | ||
14 | export etcdir = "${sysconfdir}" | ||
15 | export sbindir = "${base_sbindir}" | ||
16 | export pcmciaconfdir = "${sysconfdir}/pcmcia" | ||
17 | export udevrulesdir = "${sysconfdir}/udev/rules.d" | ||
18 | export UDEV = 1 | ||
19 | LD = "${CC}" | ||
20 | CFLAGS =+ "-I${S}/src" | ||
21 | CFLAGS =+ '-DPCMCIAUTILS_VERSION=010' | ||
22 | |||
23 | PARALLEL_MAKE = "" | ||
24 | EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'" | ||
25 | |||
26 | do_install () { | ||
27 | oe_runmake 'DESTDIR=${D}' install | ||
28 | } | ||
29 | |||
30 | CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts" | ||
31 | RCONFLICTS_${PN} += "pcmcia-cs" | ||
diff --git a/meta/packages/pcmciautils/pcmciautils_013.bb b/meta/packages/pcmciautils/pcmciautils_013.bb new file mode 100644 index 0000000000..3dde683012 --- /dev/null +++ b/meta/packages/pcmciautils/pcmciautils_013.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem" | ||
2 | DEPENDS = "sysfsutils udev module-init-tools" | ||
3 | RDEPENDS = "udev module-init-tools" | ||
4 | HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html" | ||
5 | SECTION = "kernel/userland" | ||
6 | PRIORITY = "optional" | ||
7 | |||
8 | SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2 \ | ||
9 | file://makefile_fix.patch;patch=1 \ | ||
10 | file://version_workaround.patch;patch=1" | ||
11 | S = "${WORKDIR}/pcmciautils-${PV}" | ||
12 | |||
13 | PR = "r0" | ||
14 | |||
15 | export HOSTCC = "${BUILD_CC}" | ||
16 | export etcdir = "${sysconfdir}" | ||
17 | export sbindir = "${base_sbindir}" | ||
18 | export pcmciaconfdir = "${sysconfdir}/pcmcia" | ||
19 | export udevrulesdir = "${sysconfdir}/udev/rules.d" | ||
20 | export UDEV = 1 | ||
21 | LD = "${CC}" | ||
22 | CFLAGS =+ "-I${S}/src" | ||
23 | CFLAGS =+ '-DPCMCIAUTILS_VERSION=013' | ||
24 | |||
25 | PARALLEL_MAKE = "" | ||
26 | EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'" | ||
27 | |||
28 | do_install () { | ||
29 | oe_runmake 'DESTDIR=${D}' install | ||
30 | } | ||
31 | |||
32 | CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts" | ||
33 | RCONFLICTS_${PN} += "pcmcia-cs" | ||