summaryrefslogtreecommitdiffstats
path: root/meta/packages/pcmciautils/pcmciautils-017
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-14 13:09:18 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-16 16:25:17 +0100
commitdd05d05044017fb46b70f46503c76212aa606a9e (patch)
tree99520f0e19e1d9580a91c6d3e4b6462866fb4810 /meta/packages/pcmciautils/pcmciautils-017
parente17f8f7e409f22767e620681e023a2c28039357d (diff)
downloadpoky-dd05d05044017fb46b70f46503c76212aa606a9e.tar.gz
pcmciautils: upgrade to version 017
from 014 changes: - put LEX=flex into EXTRA_OEMAKE, from openembedded project - add RDEPENDS only to ${PN}, from openembedded project - remove modalias_update patch, it's in upstream - rebase the other two patches - starting from 017 (or maybe 016), two helper binaries are put into /usr/lib/udev instead of /sbin, adapt this change by adding the new path into package Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/pcmciautils/pcmciautils-017')
-rw-r--r--meta/packages/pcmciautils/pcmciautils-017/makefile_fix.patch99
-rw-r--r--meta/packages/pcmciautils/pcmciautils-017/version_workaround.patch16
2 files changed, 115 insertions, 0 deletions
diff --git a/meta/packages/pcmciautils/pcmciautils-017/makefile_fix.patch b/meta/packages/pcmciautils/pcmciautils-017/makefile_fix.patch
new file mode 100644
index 0000000000..82dbfa8699
--- /dev/null
+++ b/meta/packages/pcmciautils/pcmciautils-017/makefile_fix.patch
@@ -0,0 +1,99 @@
1rebase the patch to 017, removing hardcoded path for true
2as well. Removing of -D in install invocation is a little
3questionable, is it some GNU extention?
4
507/14/2010 - qhe, original patch note follows
6
7Hardcoded paths are bad...
8
9diff --git a/Makefile b/Makefile
10index 26f3e4b..31f0cdf 100644
11--- a/Makefile
12+++ b/Makefile
13@@ -69,7 +69,7 @@ sbindir = ${exec_prefix}/sbin
14 mandir = ${prefix}/usr/share/man
15 udevdir = ${prefix}/lib/udev
16
17-INSTALL = /usr/bin/install -c
18+INSTALL = install -c
19 INSTALL_PROGRAM = ${INSTALL}
20 INSTALL_DATA = ${INSTALL} -m 644
21 INSTALL_SCRIPT = ${INSTALL_PROGRAM}
22@@ -171,7 +171,7 @@ endif
23 # if DEBUG is enabled, then we do not strip or optimize
24 ifeq ($(strip $(DEBUG)),true)
25 CFLAGS += -O1 -g -DDEBUG -D_GNU_SOURCE
26- STRIPCMD = /bin/true -Since_we_are_debugging
27+ STRIPCMD = true -Since_we_are_debugging
28 else
29 CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer -D_GNU_SOURCE
30 STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
31@@ -264,30 +264,32 @@ clean:
32
33 install-hotplug:
34 $(INSTALL) -d $(DESTDIR)$(hotplugdir)
35- $(INSTALL_PROGRAM) -D hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
36- $(INSTALL_PROGRAM) -D hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
37+ $(INSTALL_PROGRAM) hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
38+ $(INSTALL_PROGRAM) hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
39
40 uninstall-hotplug:
41 - rm -f $(DESTDIR)$(hotplugdir)/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.rc
42
43 install-socket-hotplug:
44- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
45- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
46+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
47+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
48
49 uninstall-socket-hotplug:
50 - rm -f $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
51
52 install-socket-tools:
53- $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_SOCKET_STARTUP)
54+ $(INSTALL) -d $(DESTDIR)$(udevhelperdir)
55+ $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_SOCKET_STARTUP)
56
57 uninstall-socket-tools:
58 - rm -f $(DESTDIR)$(udevhelperdir)/$(PCMCIA_SOCKET_STARTUP)
59
60 install-tools:
61 $(INSTALL) -d $(DESTDIR)$(sbindir)
62- $(INSTALL_PROGRAM) -D $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
63+ $(INSTALL) -d $(DESTDIR)$(udevhelperdir)
64+ $(INSTALL_PROGRAM) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
65 $(SYMLINK) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(LSPCMCIA)
66- $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_CHECK_BROKEN_CIS)
67+ $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_CHECK_BROKEN_CIS)
68
69 uninstall-tools:
70 - rm -f $(DESTDIR)$(sbindir)/$(PCCARDCTL)
71@@ -296,22 +298,24 @@ uninstall-tools:
72
73 install-config:
74 $(INSTALL) -d $(DESTDIR)$(pcmciaconfdir)
75- $(INSTALL_DATA) -D config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
76+ $(INSTALL_DATA) config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
77 if [ -f config/config.opts.$(ARCH) ]; then \
78- $(INSTALL_DATA) -D config/config.opts.$(ARCH) $(DESTDIR)$(pcmciaconfdir)/config.opts; \
79+ $(INSTALL_DATA) config/config.opts.$(ARCH) $(DESTDIR)$(pcmciaconfdir)/config.opts; \
80 fi
81
82 uninstall-config:
83 # - rm -f $(DESTDIR)$(pcmciaconfdir)/config.opts
84
85 install-udev:
86- $(INSTALL_DATA) -D $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
87+ $(INSTALL) -d $(DESTDIR)$(udevrulesdir)
88+ $(INSTALL_DATA) $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
89
90 uninstall-udev:
91 - rm -f $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
92
93 install-man:
94- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
95+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
96+ $(INSTALL_DATA) man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
97 $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
98
99 uninstall-man:
diff --git a/meta/packages/pcmciautils/pcmciautils-017/version_workaround.patch b/meta/packages/pcmciautils/pcmciautils-017/version_workaround.patch
new file mode 100644
index 0000000000..57efa68d31
--- /dev/null
+++ b/meta/packages/pcmciautils/pcmciautils-017/version_workaround.patch
@@ -0,0 +1,16 @@
1PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly
2under arm gcc 3.4.x so we work around it.
3
4Index: pcmciautils-013/src/pccardctl.c
5===================================================================
6--- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100
7+++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100
8@@ -350,7 +350,7 @@
9 }
10
11 static void print_header(void) {
12- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
13+ printf("pcmciautils 017\n");
14 printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
15 printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
16 }