diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb')
-rw-r--r-- | meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb | 102 |
1 files changed, 102 insertions, 0 deletions
diff --git a/meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb b/meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb new file mode 100644 index 0000000000..1db3006e14 --- /dev/null +++ b/meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb | |||
@@ -0,0 +1,102 @@ | |||
1 | DESCRIPTION = "Utilities and system configuration files for the Linux PCMCIA card services" | ||
2 | SECTION = "base" | ||
3 | PRIORITY = "required" | ||
4 | LICENSE = "GPL" | ||
5 | DEPENDS = "virtual/kernel" | ||
6 | PR = "r27" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \ | ||
9 | file://busybox.patch;patch=1 \ | ||
10 | file://network.patch;patch=1 \ | ||
11 | file://pcic-extra.patch;patch=1 \ | ||
12 | file://automount.patch;patch=1 \ | ||
13 | file://ratoc-cfu1u.patch;patch=1 \ | ||
14 | file://no-hostap-cards.patch;patch=1 \ | ||
15 | file://gcc4_fixes.patch;patch=1 \ | ||
16 | file://pcmcia \ | ||
17 | file://ide.opts \ | ||
18 | file://wireless.opts \ | ||
19 | file://network.conf \ | ||
20 | file://wnv.conf" | ||
21 | |||
22 | SRC_URI_append_spitz = " file://nocleanup.patch;patch=1" | ||
23 | S = "${WORKDIR}/pcmcia-cs-${PV}" | ||
24 | |||
25 | INITSCRIPT_NAME = "pcmcia" | ||
26 | INITSCRIPT_PARAMS = "defaults" | ||
27 | |||
28 | inherit update-rc.d module-base | ||
29 | |||
30 | export KERNEL_SOURCE = ${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')} | ||
31 | |||
32 | sbindir = "/sbin" | ||
33 | |||
34 | do_configure() { | ||
35 | touch .prereq.ok | ||
36 | touch config.out | ||
37 | cat >config.mk <<EOF | ||
38 | UCC=${CC} | ||
39 | UFLAGS=${CFLAGS} -I${S}/include | ||
40 | HAS_WORDEXP=y | ||
41 | SYSV_INIT=y | ||
42 | RC_DIR=/etc | ||
43 | CONFIG_PNP_BIOS=n | ||
44 | ARCH=${ARCH} | ||
45 | CONFIG_CARDBUS=n | ||
46 | CONFIG_PCMCIA=y | ||
47 | CONFIG_INET=y | ||
48 | CONFIG_SCSI=y | ||
49 | DO_IDE=y | ||
50 | EOF | ||
51 | cat >include/pcmcia/autoconf.h <<EOF | ||
52 | #define HAS_WORDEXP 1 | ||
53 | EOF | ||
54 | } | ||
55 | |||
56 | do_compile() { | ||
57 | oe_runmake all HAS_XPM= FLIBS="" XMANDIR="" | ||
58 | } | ||
59 | |||
60 | INSTALL_ETC = "ftl ide ieee1394 memory network parport scsi serial wireless" | ||
61 | INSTALL_ETC_DATA = "config config.opts ftl.opts ieee1394.opts memory.opts network.opts parport.opts scsi.opts serial.opts shared" | ||
62 | INSTALL_ETC_DATA_arm = "config ftl.opts ieee1394.opts memory.opts network.opts parport.opts scsi.opts serial.opts shared" | ||
63 | |||
64 | do_install() { | ||
65 | install -d ${D}${sbindir} | ||
66 | for f in cardmgr/cardctl cardmgr/cardmgr cardmgr/ide_info cardmgr/ifport cardmgr/ifuser cardmgr/pcinitrd flash/ftl_check flash/ftl_format | ||
67 | do | ||
68 | install -m 0755 $f ${D}${sbindir}/ | ||
69 | done | ||
70 | install -d ${D}${sysconfdir}/init.d \ | ||
71 | ${D}${sysconfdir}/pcmcia \ | ||
72 | ${D}${sysconfdir}/pcmcia/cis | ||
73 | |||
74 | install -m 0644 ${WORKDIR}/network.conf ${D}${sysconfdir}/pcmcia/ | ||
75 | install -m 0644 ${WORKDIR}/wnv.conf ${D}${sysconfdir}/pcmcia/ | ||
76 | |||
77 | for i in ${INSTALL_ETC}; do | ||
78 | install -m 0755 etc/${i} ${D}${sysconfdir}/pcmcia/ | ||
79 | done | ||
80 | for i in ${INSTALL_ETC_DATA}; do | ||
81 | install -m 0644 etc/${i} ${D}${sysconfdir}/pcmcia/ | ||
82 | done | ||
83 | |||
84 | # ensure that config.opts always exists, albeit empty | ||
85 | echo >> ${D}${sysconfdir}/pcmcia/config.opts | ||
86 | |||
87 | install -m 0644 ${WORKDIR}/ide.opts ${D}${sysconfdir}/pcmcia/ | ||
88 | install -m 0644 ${WORKDIR}/wireless.opts ${D}${sysconfdir}/pcmcia/ | ||
89 | for i in etc/cis/*; do | ||
90 | install -m 0644 $i ${D}${sysconfdir}/pcmcia/cis/ | ||
91 | done | ||
92 | install -m 0755 etc/rc.pcmcia ${D}${sysconfdir}/init.d/pcmcia | ||
93 | install -d ${D}${sysconfdir}/sysconfig | ||
94 | install -m 0755 ${WORKDIR}/pcmcia ${D}${sysconfdir}/sysconfig/pcmcia | ||
95 | } | ||
96 | |||
97 | PACKAGES =+ "${PN}-ftl ${PN}-pcinitrd" | ||
98 | |||
99 | FILES_${PN} = "${sbindir} ${sysconfdir}" | ||
100 | FILES_${PN}-ftl = "/sbin/ftl_format /sbin/ftl_check /etc/pcmcia/ftl*" | ||
101 | FILES_${PN}-pcinitrd = "/sbin/pcinitrd" | ||
102 | |||