diff options
author | Qing He <qing.he@intel.com> | 2010-07-30 16:22:49 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-10 15:31:19 +0100 |
commit | c33529794a541a617dc9c291b57acae55dd50af6 (patch) | |
tree | 5fb3a43f42b5112c66292b62a3aefee559328103 /meta/packages/pciutils | |
parent | 650319cd749f0d00c9e371cd7ea429b8e250357b (diff) | |
download | poky-c33529794a541a617dc9c291b57acae55dd50af6.tar.gz |
pciutils: upgrade to version 3.1.5
from 3.0.3
changes:
- rebased patch configure.patch and pcimodules-pciutils.diff
- fix a bug in parameter order in config that causes invalid
search path and library version
- remove unnecessary kernel version reference in configure
- use DESTDIR mechanism for build and installation
- pciutils should RDEPENDS on pciutils-ids
- enable shared library build and package a new package series,
libpci
- conceive a new patch to fix shared library build, default build
would embedd invalid library dependencies
- add another patch to fix build on arm
- fix a bug in previous do_install_depends that used invalid
installation mode
- symbolic link /usr/sbin/pciutils to /usr/bin, so non-root user
can use it as well
Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/pciutils')
-rw-r--r-- | meta/packages/pciutils/pciutils-3.1.5/configure.patch (renamed from meta/packages/pciutils/pciutils-3.0.3/configure.patch) | 36 | ||||
-rw-r--r-- | meta/packages/pciutils/pciutils-3.1.5/guess-fix.patch | 35 | ||||
-rw-r--r-- | meta/packages/pciutils/pciutils-3.1.5/lib-build-fix.patch | 92 | ||||
-rw-r--r-- | meta/packages/pciutils/pciutils-3.1.5/pcimodules-pciutils.diff (renamed from meta/packages/pciutils/pciutils-3.0.3/pcimodules-pciutils.diff) | 25 | ||||
-rw-r--r-- | meta/packages/pciutils/pciutils_3.0.3.bb | 38 | ||||
-rw-r--r-- | meta/packages/pciutils/pciutils_3.1.5.bb | 56 |
6 files changed, 215 insertions, 67 deletions
diff --git a/meta/packages/pciutils/pciutils-3.0.3/configure.patch b/meta/packages/pciutils/pciutils-3.1.5/configure.patch index 0bfcc0c609..1bfe724750 100644 --- a/meta/packages/pciutils/pciutils-3.0.3/configure.patch +++ b/meta/packages/pciutils/pciutils-3.1.5/configure.patch | |||
@@ -2,12 +2,14 @@ | |||
2 | # | 2 | # |
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | 3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher |
4 | # | 4 | # |
5 | --- | ||
5 | 6 | ||
6 | Index: pciutils-3.0.3/lib/configure | 7 | 7/30/2010 - rebased to 3.1.5 by Qing He <qing.he@intel.com> |
7 | =================================================================== | 8 | |
8 | --- pciutils-3.0.3.orig/lib/configure 2008-12-31 00:47:07.000000000 +0000 | 9 | diff -uNr pciutils-3.1.5.orig/lib/configure pciutils-3.1.5/lib/configure |
9 | +++ pciutils-3.0.3/lib/configure 2008-12-31 01:08:01.000000000 +0000 | 10 | --- pciutils-3.1.5.orig/lib/configure 2010-07-30 13:51:58.000000000 +0800 |
10 | @@ -11,6 +11,10 @@ | 11 | +++ pciutils-3.1.5/lib/configure 2010-07-30 13:53:25.000000000 +0800 |
12 | @@ -14,6 +14,10 @@ | ||
11 | fi | 13 | fi |
12 | } | 14 | } |
13 | 15 | ||
@@ -18,26 +20,27 @@ Index: pciutils-3.0.3/lib/configure | |||
18 | if [ -z "$VERSION" -o -z "$IDSDIR" ] ; then | 20 | if [ -z "$VERSION" -o -z "$IDSDIR" ] ; then |
19 | echo >&2 "Please run the configure script from the top-level Makefile" | 21 | echo >&2 "Please run the configure script from the top-level Makefile" |
20 | exit 1 | 22 | exit 1 |
21 | @@ -18,15 +22,15 @@ | 23 | @@ -21,8 +25,8 @@ |
22 | 24 | ||
23 | echo_n "Configuring libpci for your system..." | 25 | echo_n "Configuring libpci for your system..." |
24 | if [ -z "$HOST" ] ; then | 26 | if [ -z "$HOST" ] ; then |
25 | - sys=`uname -s` | 27 | - sys=`uname -s` |
26 | - rel=`uname -r` | 28 | - rel=`uname -r` |
27 | + sys=${3:-`uname -s`} | 29 | + sys=${3:-`uname -s`} |
28 | + rel=${4:-`uname -r`} | 30 | + rel= |
31 | realsys="$sys" | ||
29 | if [ "$sys" = "AIX" -a -x /usr/bin/oslevel -a -x /usr/sbin/lsattr ] | 32 | if [ "$sys" = "AIX" -a -x /usr/bin/oslevel -a -x /usr/sbin/lsattr ] |
30 | then | 33 | then |
31 | rel=`/usr/bin/oslevel` | 34 | @@ -30,7 +34,7 @@ |
32 | proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1` | 35 | proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1` |
33 | cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'` | 36 | cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'` |
34 | else | 37 | else |
35 | - cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'` | 38 | - cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'` |
36 | + cpu=${5:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`} | 39 | + cpu=${4:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`} |
37 | fi | 40 | fi |
38 | if [ "$sys" = "GNU/kFreeBSD" -o "$sys" = "DragonFly" ] | 41 | if [ "$sys" = "GNU/kFreeBSD" -o "$sys" = "DragonFly" ] |
39 | then | 42 | then |
40 | @@ -36,7 +40,7 @@ | 43 | @@ -40,7 +44,7 @@ |
41 | then | 44 | then |
42 | sys=cygwin | 45 | sys=cygwin |
43 | fi | 46 | fi |
@@ -46,7 +49,7 @@ Index: pciutils-3.0.3/lib/configure | |||
46 | fi | 49 | fi |
47 | [ -n "$RELEASE" ] && rel="${RELEASE}" | 50 | [ -n "$RELEASE" ] && rel="${RELEASE}" |
48 | # CAVEAT: tr on Solaris is a bit weird and the extra [] is otherwise harmless. | 51 | # CAVEAT: tr on Solaris is a bit weird and the extra [] is otherwise harmless. |
49 | @@ -45,6 +49,21 @@ | 52 | @@ -49,6 +53,21 @@ |
50 | sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'` | 53 | sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'` |
51 | echo " $host $rel $cpu $sys" | 54 | echo " $host $rel $cpu $sys" |
52 | 55 | ||
@@ -68,10 +71,9 @@ Index: pciutils-3.0.3/lib/configure | |||
68 | c=config.h | 71 | c=config.h |
69 | m=config.mk | 72 | m=config.mk |
70 | echo >$c '#define PCI_CONFIG_H' | 73 | echo >$c '#define PCI_CONFIG_H' |
71 | Index: pciutils-3.0.3/Makefile | 74 | diff -uNr pciutils-3.1.5.orig/Makefile pciutils-3.1.5/Makefile |
72 | =================================================================== | 75 | --- pciutils-3.1.5.orig/Makefile 2010-07-30 13:51:58.000000000 +0800 |
73 | --- pciutils-3.0.3.orig/Makefile 2008-12-31 01:07:52.000000000 +0000 | 76 | +++ pciutils-3.1.5/Makefile 2010-07-30 13:52:24.000000000 +0800 |
74 | +++ pciutils-3.0.3/Makefile 2008-12-31 01:10:50.000000000 +0000 | ||
75 | @@ -37,7 +37,6 @@ | 77 | @@ -37,7 +37,6 @@ |
76 | # Commands | 78 | # Commands |
77 | INSTALL=install | 79 | INSTALL=install |
@@ -80,7 +82,7 @@ Index: pciutils-3.0.3/Makefile | |||
80 | CC=$(CROSS_COMPILE)gcc | 82 | CC=$(CROSS_COMPILE)gcc |
81 | AR=$(CROSS_COMPILE)ar | 83 | AR=$(CROSS_COMPILE)ar |
82 | RANLIB=$(CROSS_COMPILE)ranlib | 84 | RANLIB=$(CROSS_COMPILE)ranlib |
83 | @@ -78,7 +77,7 @@ | 85 | @@ -86,7 +85,7 @@ |
84 | example.o: example.c $(PCIINC) | 86 | example.o: example.c $(PCIINC) |
85 | 87 | ||
86 | %: %.o | 88 | %: %.o |
@@ -89,7 +91,7 @@ Index: pciutils-3.0.3/Makefile | |||
89 | 91 | ||
90 | %.8 %.7: %.man | 92 | %.8 %.7: %.man |
91 | M=`echo $(DATE) | sed 's/-01-/-January-/;s/-02-/-February-/;s/-03-/-March-/;s/-04-/-April-/;s/-05-/-May-/;s/-06-/-June-/;s/-07-/-July-/;s/-08-/-August-/;s/-09-/-September-/;s/-10-/-October-/;s/-11-/-November-/;s/-12-/-December-/;s/\(.*\)-\(.*\)-\(.*\)/\3 \2 \1/'` ; sed <$< >$@ "s/@TODAY@/$$M/;s/@VERSION@/pciutils-$(VERSION)/;s#@IDSDIR@#$(IDSDIR)#" | 93 | M=`echo $(DATE) | sed 's/-01-/-January-/;s/-02-/-February-/;s/-03-/-March-/;s/-04-/-April-/;s/-05-/-May-/;s/-06-/-June-/;s/-07-/-July-/;s/-08-/-August-/;s/-09-/-September-/;s/-10-/-October-/;s/-11-/-November-/;s/-12-/-December-/;s/\(.*\)-\(.*\)-\(.*\)/\3 \2 \1/'` ; sed <$< >$@ "s/@TODAY@/$$M/;s/@VERSION@/pciutils-$(VERSION)/;s#@IDSDIR@#$(IDSDIR)#" |
92 | @@ -93,7 +92,7 @@ | 94 | @@ -101,7 +100,7 @@ |
93 | install: all | 95 | install: all |
94 | # -c is ignored on Linux, but required on FreeBSD | 96 | # -c is ignored on Linux, but required on FreeBSD |
95 | $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7 | 97 | $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7 |
diff --git a/meta/packages/pciutils/pciutils-3.1.5/guess-fix.patch b/meta/packages/pciutils/pciutils-3.1.5/guess-fix.patch new file mode 100644 index 0000000000..9072d2a68f --- /dev/null +++ b/meta/packages/pciutils/pciutils-3.1.5/guess-fix.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | the original guess algorithm is broken for many archs | ||
2 | for example, the following two would break: | ||
3 | arm-linux-gnueabi --> sys=gnueabi | ||
4 | x86_64-unknown-pc-linux-gnu --> sys = pc-linux-gnu | ||
5 | |||
6 | use a simpler scheme here and hope it works for all the cases | ||
7 | |||
8 | 7/30/2010 - created by Qing He <qing.he@intel.com> | ||
9 | |||
10 | diff --git a/lib/configure b/lib/configure | ||
11 | index 4318b05..84f6acb 100755 | ||
12 | --- a/lib/configure | ||
13 | +++ b/lib/configure | ||
14 | @@ -53,20 +53,7 @@ cpu=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\1/'` | ||
15 | sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'` | ||
16 | echo " $host $rel $cpu $sys" | ||
17 | |||
18 | -if [ "$host" = "linux--gnueabi" ] | ||
19 | -then | ||
20 | - sys=linux | ||
21 | -fi | ||
22 | - | ||
23 | -if [ "$host" = "linux--uclibc" ] | ||
24 | -then | ||
25 | - sys=linux | ||
26 | -fi | ||
27 | - | ||
28 | -if [ "$host" = "linux--uclibcgnueabi" ] | ||
29 | -then | ||
30 | - sys=linux | ||
31 | -fi | ||
32 | +{ echo "$host" | grep linux; } && sys=linux | ||
33 | |||
34 | c=config.h | ||
35 | m=config.mk | ||
diff --git a/meta/packages/pciutils/pciutils-3.1.5/lib-build-fix.patch b/meta/packages/pciutils/pciutils-3.1.5/lib-build-fix.patch new file mode 100644 index 0000000000..1e81f8401b --- /dev/null +++ b/meta/packages/pciutils/pciutils-3.1.5/lib-build-fix.patch | |||
@@ -0,0 +1,92 @@ | |||
1 | Link directly to lib/libpci.so.3.1.5 will hard code this versioned | ||
2 | string into lspci and other utilities, which is not desirable and | ||
3 | won't work. In the other hand, linking to a symbolic link lib/libpci.so | ||
4 | doesn't have this issue. | ||
5 | |||
6 | 7/30/2010 - created by Qing He <qing.he@intel.com> | ||
7 | |||
8 | diff --git a/Makefile b/Makefile | ||
9 | index 1b48e18..21af4b3 100644 | ||
10 | --- a/Makefile | ||
11 | +++ b/Makefile | ||
12 | @@ -51,9 +51,9 @@ PCIINC_INS=lib/config.h lib/header.h lib/pci.h lib/types.h | ||
13 | |||
14 | export | ||
15 | |||
16 | -all: lib/$(PCILIB) lspci setpci example lspci.8 setpci.8 pcilib.7 update-pciids update-pciids.8 $(PCI_IDS) pcimodules pcimodules.8 | ||
17 | +all: lib/$(PCILIB_DEV) lspci setpci example lspci.8 setpci.8 pcilib.7 update-pciids update-pciids.8 $(PCI_IDS) pcimodules pcimodules.8 | ||
18 | |||
19 | -lib/$(PCILIB): $(PCIINC) force | ||
20 | +lib/$(PCILIB) lib/$(PCILIB_DEV): $(PCIINC) force | ||
21 | $(MAKE) -C lib all | ||
22 | |||
23 | force: | ||
24 | @@ -61,9 +61,9 @@ force: | ||
25 | lib/config.h lib/config.mk: | ||
26 | cd lib && ./configure | ||
27 | |||
28 | -pcimodules: pcimodules.o common.o lib/$(PCILIB) | ||
29 | -lspci: lspci.o ls-vpd.o ls-caps.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o common.o lib/$(PCILIB) | ||
30 | -setpci: setpci.o common.o lib/$(PCILIB) | ||
31 | +pcimodules: pcimodules.o common.o lib/$(PCILIB_DEV) | ||
32 | +lspci: lspci.o ls-vpd.o ls-caps.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o common.o lib/$(PCILIB_DEV) | ||
33 | +setpci: setpci.o common.o lib/$(PCILIB_DEV) | ||
34 | |||
35 | pcimodules.o: pcimodules.c pciutils.h | ||
36 | LSPCIINC=lspci.h pciutils.h $(PCIINC) | ||
37 | @@ -83,7 +83,7 @@ update-pciids: update-pciids.sh | ||
38 | chmod +x $@ | ||
39 | |||
40 | # The example of use of libpci | ||
41 | -example: example.o lib/$(PCILIB) | ||
42 | +example: example.o lib/$(PCILIB_DEV) | ||
43 | example.o: example.c $(PCIINC) | ||
44 | |||
45 | %: %.o | ||
46 | diff --git a/lib/Makefile b/lib/Makefile | ||
47 | index 1eb06a5..a8dab56 100644 | ||
48 | --- a/lib/Makefile | ||
49 | +++ b/lib/Makefile | ||
50 | @@ -42,7 +42,7 @@ ifdef PCI_HAVE_PM_NBSD_LIBPCI | ||
51 | OBJS += nbsd-libpci | ||
52 | endif | ||
53 | |||
54 | -all: $(PCILIB) $(PCILIBPC) | ||
55 | +all: $(PCILIB_DEV) $(PCILIBPC) | ||
56 | |||
57 | ifeq ($(SHARED),no) | ||
58 | $(PCILIB): $(addsuffix .o,$(OBJS)) | ||
59 | @@ -53,6 +53,9 @@ else | ||
60 | CFLAGS += -fPIC -fvisibility=hidden | ||
61 | $(PCILIB): $(addsuffix .o,$(OBJS)) | ||
62 | $(CC) -shared $(LDFLAGS) $(SONAME) -Wl,--version-script=libpci.ver -o $@ $^ $(LIB_LDLIBS) | ||
63 | + | ||
64 | +$(PCILIB_DEV): $(PCILIB) | ||
65 | + ln -s $< $@ | ||
66 | endif | ||
67 | |||
68 | $(PCILIBPC): libpci.pc.in | ||
69 | diff --git a/lib/configure b/lib/configure | ||
70 | index eec225a..4318b05 100755 | ||
71 | --- a/lib/configure | ||
72 | +++ b/lib/configure | ||
73 | @@ -174,16 +193,18 @@ fi | ||
74 | echo "Checking whether to build a shared library... $SHARED (set manually)" | ||
75 | if [ "$SHARED" = no ] ; then | ||
76 | echo >>$m 'PCILIB=$(LIBNAME).a' | ||
77 | + echo >>$m 'PCILIB_DEV=$(LIBNAME).a' | ||
78 | echo >>$m 'LDLIBS=$(WITH_LIBS)' | ||
79 | echo >>$m 'LIB_LDLIBS=' | ||
80 | else | ||
81 | echo >>$m 'PCILIB=$(LIBNAME).so.$(VERSION)' | ||
82 | + echo >>$m 'PCILIB_DEV=$(LIBNAME).so' | ||
83 | # We link the dependencies _to_ the library, so we do not need explicit deps in .pc | ||
84 | echo >>$m 'LDLIBS=' | ||
85 | echo >>$m 'LIB_LDLIBS=$(WITH_LIBS)' | ||
86 | echo >>$c '#define PCI_SHARED_LIB' | ||
87 | if [ "$SHARED" = yes ] ; then | ||
88 | - echo >>$m 'SONAME=-Wl,-soname,$(LIBNAME).so$(ABI_VERSION)' | ||
89 | + echo >>$m 'SONAME=-Wl,-soname -Wl,$(LIBNAME).so$(ABI_VERSION)' | ||
90 | fi | ||
91 | fi | ||
92 | echo >>$m 'PCILIBPC=$(LIBNAME).pc' | ||
diff --git a/meta/packages/pciutils/pciutils-3.0.3/pcimodules-pciutils.diff b/meta/packages/pciutils/pciutils-3.1.5/pcimodules-pciutils.diff index fba30ac719..36ea3b76be 100644 --- a/meta/packages/pciutils/pciutils-3.0.3/pcimodules-pciutils.diff +++ b/meta/packages/pciutils/pciutils-3.1.5/pcimodules-pciutils.diff | |||
@@ -1,8 +1,9 @@ | |||
1 | Index: pciutils-3.0.3/Makefile | 1 | 7/30/2010 - rebased to 3.1.5 by Qing He <qing.he@intel.com> |
2 | =================================================================== | 2 | |
3 | --- pciutils-3.0.3.orig/Makefile 2008-11-09 20:28:18.000000000 +0000 | 3 | diff -uNr pciutils-3.1.5.orig/Makefile pciutils-3.1.5/Makefile |
4 | +++ pciutils-3.0.3/Makefile 2008-12-31 00:46:45.000000000 +0000 | 4 | --- pciutils-3.1.5.orig/Makefile 2010-07-30 14:02:15.000000000 +0800 |
5 | @@ -52,7 +52,7 @@ | 5 | +++ pciutils-3.1.5/Makefile 2010-07-30 14:02:55.000000000 +0800 |
6 | @@ -51,7 +51,7 @@ | ||
6 | 7 | ||
7 | export | 8 | export |
8 | 9 | ||
@@ -11,19 +12,19 @@ Index: pciutils-3.0.3/Makefile | |||
11 | 12 | ||
12 | lib/$(PCILIB): $(PCIINC) force | 13 | lib/$(PCILIB): $(PCIINC) force |
13 | $(MAKE) -C lib all | 14 | $(MAKE) -C lib all |
14 | @@ -62,9 +62,11 @@ | 15 | @@ -61,9 +61,11 @@ |
15 | lib/config.h lib/config.mk: | 16 | lib/config.h lib/config.mk: |
16 | cd lib && ./configure | 17 | cd lib && ./configure |
17 | 18 | ||
18 | +pcimodules: pcimodules.o common.o lib/$(PCILIB) | 19 | +pcimodules: pcimodules.o common.o lib/$(PCILIB) |
19 | lspci: lspci.o common.o lib/$(PCILIB) | 20 | lspci: lspci.o ls-vpd.o ls-caps.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o common.o lib/$(PCILIB) |
20 | setpci: setpci.o common.o lib/$(PCILIB) | 21 | setpci: setpci.o common.o lib/$(PCILIB) |
21 | 22 | ||
22 | +pcimodules.o: pcimodules.c pciutils.h | 23 | +pcimodules.o: pcimodules.c pciutils.h |
23 | lspci.o: lspci.c pciutils.h $(PCIINC) | 24 | LSPCIINC=lspci.h pciutils.h $(PCIINC) |
24 | setpci.o: setpci.c pciutils.h $(PCIINC) | 25 | lspci.o: lspci.c $(LSPCIINC) |
25 | common.o: common.c pciutils.h $(PCIINC) | 26 | ls-vpd.o: ls-vpd.c $(LSPCIINC) |
26 | @@ -93,10 +95,10 @@ | 27 | @@ -100,10 +102,10 @@ |
27 | install: all | 28 | install: all |
28 | # -c is ignored on Linux, but required on FreeBSD | 29 | # -c is ignored on Linux, but required on FreeBSD |
29 | $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7 | 30 | $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7 |
@@ -36,7 +37,7 @@ Index: pciutils-3.0.3/Makefile | |||
36 | $(INSTALL) -c -m 644 pcilib.7 $(DESTDIR)$(MANDIR)/man7 | 37 | $(INSTALL) -c -m 644 pcilib.7 $(DESTDIR)$(MANDIR)/man7 |
37 | ifeq ($(SHARED),yes) | 38 | ifeq ($(SHARED),yes) |
38 | $(DIRINSTALL) -m 755 $(DESTDIR)$(LIBDIR) | 39 | $(DIRINSTALL) -m 755 $(DESTDIR)$(LIBDIR) |
39 | @@ -114,9 +116,9 @@ | 40 | @@ -121,9 +123,9 @@ |
40 | endif | 41 | endif |
41 | 42 | ||
42 | uninstall: all | 43 | uninstall: all |
diff --git a/meta/packages/pciutils/pciutils_3.0.3.bb b/meta/packages/pciutils/pciutils_3.0.3.bb deleted file mode 100644 index a05a69b61a..0000000000 --- a/meta/packages/pciutils/pciutils_3.0.3.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | DESCRIPTION = 'The PCI Utilities package contains a library for portable access \ | ||
2 | to PCI bus configuration space and several utilities based on this library.' | ||
3 | DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils' | ||
4 | SECTION = "console/utils" | ||
5 | HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml" | ||
6 | LICENSE = "GPLv2" | ||
7 | DEPENDS = "zlib" | ||
8 | |||
9 | SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \ | ||
10 | file://configure.patch;patch=1 \ | ||
11 | file://pcimodules-pciutils.diff;patch=1" | ||
12 | |||
13 | PARALLEL_MAKE = "" | ||
14 | |||
15 | do_configure () { | ||
16 | (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH}) | ||
17 | } | ||
18 | |||
19 | export PREFIX = "${D}${prefix}" | ||
20 | export SBINDIR = "${D}${sbindir}" | ||
21 | export SHAREDIR = "${D}${datadir}" | ||
22 | export MANDIR = "${D}${mandir}" | ||
23 | |||
24 | LDFLAGS += "-lz" | ||
25 | |||
26 | # The configure script breaks if the HOST variable is set | ||
27 | HOST[unexport] = "1" | ||
28 | |||
29 | do_install () { | ||
30 | oe_runmake install | ||
31 | } | ||
32 | do_install_append () { | ||
33 | install -d ${D}/${prefix}/share | ||
34 | install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share | ||
35 | } | ||
36 | |||
37 | PACKAGES =+ "pciutils-ids" | ||
38 | FILES_pciutils-ids="${prefix}/share/pci.ids" | ||
diff --git a/meta/packages/pciutils/pciutils_3.1.5.bb b/meta/packages/pciutils/pciutils_3.1.5.bb new file mode 100644 index 0000000000..73fe1cca68 --- /dev/null +++ b/meta/packages/pciutils/pciutils_3.1.5.bb | |||
@@ -0,0 +1,56 @@ | |||
1 | DESCRIPTION = 'The PCI Utilities package contains a library for portable access \ | ||
2 | to PCI bus configuration space and several utilities based on this library.' | ||
3 | DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils' | ||
4 | HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml" | ||
5 | SECTION = "console/utils" | ||
6 | |||
7 | LICENSE = "GPLv2+" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
9 | DEPENDS = "zlib" | ||
10 | RDEPENDS_${PN} = "${PN}-ids" | ||
11 | PR = "r0" | ||
12 | |||
13 | SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \ | ||
14 | file://configure.patch \ | ||
15 | file://pcimodules-pciutils.diff \ | ||
16 | file://lib-build-fix.patch \ | ||
17 | file://guess-fix.patch" | ||
18 | |||
19 | PARALLEL_MAKE = "" | ||
20 | |||
21 | PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes" | ||
22 | |||
23 | # see configure.patch | ||
24 | do_configure () { | ||
25 | ( | ||
26 | cd lib && \ | ||
27 | ${PCI_CONF_FLAG} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH} | ||
28 | ) | ||
29 | } | ||
30 | |||
31 | export PREFIX = "${prefix}" | ||
32 | export SBINDIR = "${sbindir}" | ||
33 | export SHAREDIR = "${datadir}" | ||
34 | export MANDIR = "${mandir}" | ||
35 | |||
36 | EXTRA_OEMAKE += "${PCI_CONF_FLAG}" | ||
37 | |||
38 | # The configure script breaks if the HOST variable is set | ||
39 | HOST[unexport] = "1" | ||
40 | |||
41 | do_install () { | ||
42 | oe_runmake DESTDIR=${D} install install-lib | ||
43 | |||
44 | install -d ${D}${bindir} | ||
45 | ln -s ../sbin/lspci ${D}${bindir}/lspci | ||
46 | |||
47 | install -d ${D}${datadir} | ||
48 | install -m 644 ${S}/pci.ids ${D}${datadir} | ||
49 | } | ||
50 | |||
51 | PACKAGES =+ "pciutils-ids libpci libpci-dev libpci-dbg" | ||
52 | FILES_pciutils-ids = "${datadir}/pci.ids*" | ||
53 | FILES_libpci = "${libdir}/libpci.so.*" | ||
54 | FILES_libpci-dbg = "${libdir}/.debug" | ||
55 | FILES_libpci-dev = "${libdir}/libpci.a ${libdir}/libpci.la ${libdir}/libpci.so \ | ||
56 | ${includedir}/pci ${libdir}/pkgconfig" | ||