diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:11 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:57 +0100 |
commit | d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch) | |
tree | f36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/parted | |
parent | caab7fc509bf27706ff3248689f6afd04225cfda (diff) | |
download | poky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz |
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/parted')
-rw-r--r-- | meta/packages/parted/parted-1.9.0/no_check.patch | 18 | ||||
-rw-r--r-- | meta/packages/parted/parted-1.9.0/syscalls.patch | 53 | ||||
-rw-r--r-- | meta/packages/parted/parted_1.9.0.bb | 16 |
3 files changed, 0 insertions, 87 deletions
diff --git a/meta/packages/parted/parted-1.9.0/no_check.patch b/meta/packages/parted/parted-1.9.0/no_check.patch deleted file mode 100644 index 24a328ceea..0000000000 --- a/meta/packages/parted/parted-1.9.0/no_check.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | If check is detected, it makes the builds non-determinstic so just force | ||
2 | it to be disabled. | ||
3 | |||
4 | RP - 4/11/08 | ||
5 | |||
6 | Index: parted-1.9.0/configure.ac | ||
7 | =================================================================== | ||
8 | --- parted-1.9.0.orig/configure.ac 2009-07-23 18:52:08.000000000 +0100 | ||
9 | +++ parted-1.9.0/configure.ac 2010-02-02 14:13:56.013905093 +0000 | ||
10 | @@ -477,7 +477,7 @@ | ||
11 | AM_CONDITIONAL([BUILD_LINUX], [test "$OS" = linux]) | ||
12 | |||
13 | dnl check for "check", unit testing library/header | ||
14 | -PKG_CHECK_MODULES([CHECK], [check >= 0.9.3], have_check=yes, have_check=no) | ||
15 | +have_check=no | ||
16 | if test "$have_check" != "yes"; then | ||
17 | AC_MSG_RESULT([Unable to locate check version 0.9.3 or higher: not building]) | ||
18 | fi | ||
diff --git a/meta/packages/parted/parted-1.9.0/syscalls.patch b/meta/packages/parted/parted-1.9.0/syscalls.patch deleted file mode 100644 index 6be49968f3..0000000000 --- a/meta/packages/parted/parted-1.9.0/syscalls.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | --- | ||
2 | libparted/arch/linux.c | 13 +++++++++++++ | ||
3 | 1 file changed, 13 insertions(+) | ||
4 | |||
5 | Index: parted-1.9.0/libparted/arch/linux.c | ||
6 | =================================================================== | ||
7 | --- parted-1.9.0.orig/libparted/arch/linux.c 2009-07-23 18:52:08.000000000 +0100 | ||
8 | +++ parted-1.9.0/libparted/arch/linux.c 2010-02-02 14:14:16.523904768 +0000 | ||
9 | @@ -17,6 +17,8 @@ | ||
10 | |||
11 | #define PROC_DEVICES_BUFSIZ 16384 | ||
12 | |||
13 | +#include <linux/version.h> | ||
14 | + | ||
15 | #include <config.h> | ||
16 | #include <arch/linux.h> | ||
17 | |||
18 | @@ -1477,12 +1479,14 @@ | ||
19 | |||
20 | #if SIZEOF_OFF_T < 8 | ||
21 | |||
22 | +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,20) | ||
23 | static _syscall5(int,_llseek, | ||
24 | unsigned int, fd, | ||
25 | unsigned long, offset_high, | ||
26 | unsigned long, offset_low, | ||
27 | loff_t*, result, | ||
28 | unsigned int, origin) | ||
29 | +#endif | ||
30 | |||
31 | loff_t | ||
32 | llseek (unsigned int fd, loff_t offset, unsigned int whence) | ||
33 | @@ -1490,11 +1494,20 @@ | ||
34 | loff_t result; | ||
35 | int retval; | ||
36 | |||
37 | +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,20) | ||
38 | retval = _llseek(fd, | ||
39 | ((unsigned long long)offset) >> 32, | ||
40 | ((unsigned long long)offset) & 0xffffffff, | ||
41 | &result, | ||
42 | whence); | ||
43 | +#else | ||
44 | + retval = syscall(__NR__llseek, fd, | ||
45 | + ((unsigned long long)offset) >> 32, | ||
46 | + ((unsigned long long)offset) & 0xffffffff, | ||
47 | + &result, | ||
48 | + whence); | ||
49 | +#endif | ||
50 | + | ||
51 | return (retval==-1 ? (loff_t) retval : result); | ||
52 | } | ||
53 | |||
diff --git a/meta/packages/parted/parted_1.9.0.bb b/meta/packages/parted/parted_1.9.0.bb deleted file mode 100644 index f2a265187f..0000000000 --- a/meta/packages/parted/parted_1.9.0.bb +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | DESCRIPTION = "parted, the GNU partition resizing program" | ||
2 | HOMEPAGE = "http://www.gnu.org/software/parted/parted.html" | ||
3 | LICENSE = "GPLv2" | ||
4 | SECTION = "console/tools" | ||
5 | DEPENDS = "readline e2fsprogs" | ||
6 | PR = "r3" | ||
7 | |||
8 | SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \ | ||
9 | file://no_check.patch;patch=1 \ | ||
10 | file://syscalls.patch;patch=1 " | ||
11 | |||
12 | EXTRA_OECONF = "--disable-Werror --disable-device-mapper" | ||
13 | |||
14 | inherit autotools pkgconfig gettext | ||
15 | |||
16 | BBCLASSEXTEND = "native" | ||