summaryrefslogtreecommitdiffstats
path: root/meta/packages/oprofile
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-27 16:30:56 +0000
committerRoss Burton <ross@openedhand.com>2007-11-27 16:30:56 +0000
commitfc5d8af7a71876283b16f1a9a0fb701aa7c1db74 (patch)
tree942b2aa45bbbc1cd4804167dfd86ce7683b5a01d /meta/packages/oprofile
parent261c8d8c775f44b6935a5b36ee00a084910afae7 (diff)
downloadpoky-fc5d8af7a71876283b16f1a9a0fb701aa7c1db74.tar.gz
oprofile: fix arithmetic ops on dash
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3259 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oprofile')
-rw-r--r--meta/packages/oprofile/oprofile/fix-arith.patch52
-rw-r--r--meta/packages/oprofile/oprofile_0.9.3.bb3
2 files changed, 54 insertions, 1 deletions
diff --git a/meta/packages/oprofile/oprofile/fix-arith.patch b/meta/packages/oprofile/oprofile/fix-arith.patch
new file mode 100644
index 0000000000..5c55f4b349
--- /dev/null
+++ b/meta/packages/oprofile/oprofile/fix-arith.patch
@@ -0,0 +1,52 @@
1Index: utils/opcontrol
2===================================================================
3RCS file: /cvsroot/oprofile/oprofile/utils/opcontrol,v
4retrieving revision 1.148
5diff -u -r1.148 opcontrol
6--- utils/opcontrol 8 Nov 2007 09:24:30 -0000 1.148
7+++ utils/opcontrol 27 Nov 2007 17:02:20 -0000
8@@ -395,7 +395,7 @@
9 echo "SESSION_DIR=$SESSION_DIR" >>$SETUP_FILE
10
11 if test "$NR_CHOSEN" != "0"; then
12- for f in `seq 0 $((NR_CHOSEN - 1))`; do
13+ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
14 get_event $f
15 echo "CHOSEN_EVENTS_${f}=$GOTEVENT" >>$SETUP_FILE
16 done
17@@ -590,7 +590,7 @@
18 OPHELP_ARGS=
19
20 if test "$NR_CHOSEN" != 0; then
21- for f in `seq 0 $((NR_CHOSEN - 1))`; do
22+ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
23 get_event $f
24 if test "$GOTEVENT" != ""; then
25 OPHELP_ARGS="$OPHELP_ARGS $GOTEVENT"
26@@ -612,7 +612,7 @@
27 return
28 fi
29
30- for f in `seq 0 $((NR_CHOSEN - 1))`; do
31+ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
32 get_event $f
33 if test "$GOTEVENT" != ""; then
34 EVENT=`echo $GOTEVENT | awk -F: '{print $1}'`
35@@ -1226,7 +1226,7 @@
36 verify_counters
37
38 OPROFILED_EVENTS=
39- for f in `seq 0 $((NR_CHOSEN - 1))`; do
40+ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
41 get_event $f
42 if test "$GOTEVENT" != ""; then
43 EVENT=`echo $GOTEVENT | awk -F: '{print $1}'`
44@@ -1383,7 +1383,7 @@
45 fi
46
47 if test "$NR_CHOSEN" != "0"; then
48- for f in `seq 0 $((NR_CHOSEN - 1))`; do
49+ for f in `seq 0 $(($NR_CHOSEN - 1))`; do
50 get_event $f
51 echo "Event $f: $GOTEVENT"
52 done
diff --git a/meta/packages/oprofile/oprofile_0.9.3.bb b/meta/packages/oprofile/oprofile_0.9.3.bb
index c4ea585c85..c4194ab2e1 100644
--- a/meta/packages/oprofile/oprofile_0.9.3.bb
+++ b/meta/packages/oprofile/oprofile_0.9.3.bb
@@ -4,13 +4,14 @@ of profiling all running code at low overhead."
4LICENSE = "GPL" 4LICENSE = "GPL"
5DEPENDS = "popt binutils" 5DEPENDS = "popt binutils"
6RDEPENDS = "binutils-symlinks" 6RDEPENDS = "binutils-symlinks"
7PR = "r3" 7PR = "r4"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \ 9SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
10 file://armv6_fix.patch;patch=1 \ 10 file://armv6_fix.patch;patch=1 \
11 file://oparchive_fix.patch;patch=1 \ 11 file://oparchive_fix.patch;patch=1 \
12 file://root_option.patch;patch=1 \ 12 file://root_option.patch;patch=1 \
13 file://opstart.patch;patch=1 \ 13 file://opstart.patch;patch=1 \
14 file://fix-arith.patch;patch=1;pnum=0 \
14 file://acinclude.m4" 15 file://acinclude.m4"
15S = "${WORKDIR}/oprofile-${PV}" 16S = "${WORKDIR}/oprofile-${PV}"
16 17