summaryrefslogtreecommitdiffstats
path: root/meta/packages/oprofile
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-10-11 14:39:05 +0000
committerRichard Purdie <richard@openedhand.com>2006-10-11 14:39:05 +0000
commit272266f06ffbf67a73893ac5c46ee5e14688b16f (patch)
treed1dbc62492a2ff47897d046e8ffd0460fd8eab2c /meta/packages/oprofile
parent6dfc07b50aca754da52d9ce22d9f6caaf24bd61c (diff)
downloadpoky-272266f06ffbf67a73893ac5c46ee5e14688b16f.tar.gz
oprofile: Remove some bashisms and general breakage
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@792 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oprofile')
-rw-r--r--meta/packages/oprofile/oprofile/opcontrol_bashisms.patch24
-rw-r--r--meta/packages/oprofile/oprofile_cvs.bb2
2 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/oprofile/oprofile/opcontrol_bashisms.patch b/meta/packages/oprofile/oprofile/opcontrol_bashisms.patch
new file mode 100644
index 0000000000..58e2cb8097
--- /dev/null
+++ b/meta/packages/oprofile/oprofile/opcontrol_bashisms.patch
@@ -0,0 +1,24 @@
1 utils/opcontrol | 3 +--
2 1 file changed, 1 insertion(+), 2 deletions(-)
3
4Index: oprofile/utils/opcontrol
5===================================================================
6--- oprofile.orig/utils/opcontrol 2006-02-10 14:18:13.000000000 +0000
7+++ oprofile/utils/opcontrol 2006-10-11 15:52:16.000000000 +0100
8@@ -476,7 +476,7 @@ validate_separate_args()
9 SEPARATE_KERNEL=0
10 SEPARATE_THREAD=0
11 SEPARATE_CPU=0
12- while (($i < $#)); do
13+ while [ "$i" -lt "$#" ]; do
14 shift
15 case "$1" in
16 lib|library)
17@@ -1513,7 +1513,6 @@ check_version()
18 BINDIR="/usr/bin"
19 OPCONTROL=`$BINDIR/which $0`
20 OPDIR=`$BINDIR/dirname $OPCONTROL`
21-n
22 PATH=/usr/local/bin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin
23
24 check_version_help $@
diff --git a/meta/packages/oprofile/oprofile_cvs.bb b/meta/packages/oprofile/oprofile_cvs.bb
index 1a255d3577..087cc33967 100644
--- a/meta/packages/oprofile/oprofile_cvs.bb
+++ b/meta/packages/oprofile/oprofile_cvs.bb
@@ -1,4 +1,5 @@
1PV = "0.9.1+cvs${SRCDATE}" 1PV = "0.9.1+cvs${SRCDATE}"
2PR = "r1"
2SECTION = "devel" 3SECTION = "devel"
3DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \ 4DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
4of profiling all running code at low overhead." 5of profiling all running code at low overhead."
@@ -7,6 +8,7 @@ DEPENDS = "popt binutils"
7 8
8SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \ 9SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
9 file://no_arm_mapping_syms.patch;patch=1 \ 10 file://no_arm_mapping_syms.patch;patch=1 \
11 file://opcontrol_bashisms.patch;patch=1 \
10 file://acinclude.m4" 12 file://acinclude.m4"
11S = "${WORKDIR}/oprofile" 13S = "${WORKDIR}/oprofile"
12 14