diff options
author | Richard Purdie <rpurdie@rpsys.net> | 2008-10-23 12:05:39 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@rpsys.net> | 2008-10-23 12:05:39 +0100 |
commit | 0cc119f05f5daa378720f34db6b5e41546f4af06 (patch) | |
tree | 052132c139b6ac977db43d436a3d0f3fe9d14c3a /meta/packages/opkg | |
parent | 842606bc394025a1387982ee6e290186c9d92e2a (diff) | |
download | poky-0cc119f05f5daa378720f34db6b5e41546f4af06.tar.gz |
opkg: Really fix the prototype problem (and an invalid call)
Diffstat (limited to 'meta/packages/opkg')
-rw-r--r-- | meta/packages/opkg/files/fix_prototype.patch | 13 | ||||
-rw-r--r-- | meta/packages/opkg/opkg-native_svn.bb | 2 | ||||
-rw-r--r-- | meta/packages/opkg/opkg.inc | 4 |
3 files changed, 17 insertions, 2 deletions
diff --git a/meta/packages/opkg/files/fix_prototype.patch b/meta/packages/opkg/files/fix_prototype.patch index 8d4eb7b5ad..4be881aa7e 100644 --- a/meta/packages/opkg/files/fix_prototype.patch +++ b/meta/packages/opkg/files/fix_prototype.patch | |||
@@ -24,3 +24,16 @@ Index: opkg/libopkg/opkg_utils.h | |||
24 | 24 | ||
25 | int get_available_blocks(char * filesystem); | 25 | int get_available_blocks(char * filesystem); |
26 | char **read_raw_pkgs_from_file(const char *file_name); | 26 | char **read_raw_pkgs_from_file(const char *file_name); |
27 | Index: opkg/libopkg/opkg_cmd.c | ||
28 | =================================================================== | ||
29 | --- opkg.orig/libopkg/opkg_cmd.c 2008-10-23 12:02:29.000000000 +0100 | ||
30 | +++ opkg/libopkg/opkg_cmd.c 2008-10-23 12:02:53.000000000 +0100 | ||
31 | @@ -151,7 +151,7 @@ | ||
32 | error_list = error_list->next; | ||
33 | |||
34 | } | ||
35 | - free_error_list(&error_list); | ||
36 | + free_error_list(); | ||
37 | } | ||
38 | |||
39 | } | ||
diff --git a/meta/packages/opkg/opkg-native_svn.bb b/meta/packages/opkg/opkg-native_svn.bb index 888c4117c9..d9c86509c1 100644 --- a/meta/packages/opkg/opkg-native_svn.bb +++ b/meta/packages/opkg/opkg-native_svn.bb | |||
@@ -3,7 +3,7 @@ require opkg.inc | |||
3 | DEPENDS = "curl-native" | 3 | DEPENDS = "curl-native" |
4 | PROVIDES += "virtual/update-alternatives-native" | 4 | PROVIDES += "virtual/update-alternatives-native" |
5 | RPROVIDES_${PN} += "update-alternatives-native" | 5 | RPROVIDES_${PN} += "update-alternatives-native" |
6 | PR = "r2" | 6 | PR = "r4" |
7 | 7 | ||
8 | target_libdir := "${libdir}" | 8 | target_libdir := "${libdir}" |
9 | 9 | ||
diff --git a/meta/packages/opkg/opkg.inc b/meta/packages/opkg/opkg.inc index 6c6a7a7afb..d0167f6283 100644 --- a/meta/packages/opkg/opkg.inc +++ b/meta/packages/opkg/opkg.inc | |||
@@ -6,7 +6,9 @@ LICENSE = "GPL" | |||
6 | DEPENDS = "curl gpgme" | 6 | DEPENDS = "curl gpgme" |
7 | PV = "0.0+svnr${SRCREV}" | 7 | PV = "0.0+svnr${SRCREV}" |
8 | 8 | ||
9 | SRC_URI = "svn://svn.openmoko.org/trunk/src/target/;module=opkg;proto=http" | 9 | SRC_URI = "svn://svn.openmoko.org/trunk/src/target/;module=opkg;proto=http \ |
10 | file://fix_prototype.patch;patch=1" | ||
11 | |||
10 | S = "${WORKDIR}/opkg" | 12 | S = "${WORKDIR}/opkg" |
11 | 13 | ||
12 | inherit autotools pkgconfig | 14 | inherit autotools pkgconfig |