summaryrefslogtreecommitdiffstats
path: root/meta/packages/opkg/opkg.inc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-13 22:06:05 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-13 22:06:25 +0000
commita717961f6e0e016e447eeca5f5f5d3a81354c61c (patch)
treebbedfba6ebef809e6bc303954d3ec743374693d3 /meta/packages/opkg/opkg.inc
parent357282e2111fa6b84b34185d9916b0c17119480c (diff)
downloadpoky-a717961f6e0e016e447eeca5f5f5d3a81354c61c.tar.gz
opkg: Convert to use BBCLASSEXTEND
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/opkg/opkg.inc')
-rw-r--r--meta/packages/opkg/opkg.inc13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/packages/opkg/opkg.inc b/meta/packages/opkg/opkg.inc
index d82f6d53f2..1d1cb5c26f 100644
--- a/meta/packages/opkg/opkg.inc
+++ b/meta/packages/opkg/opkg.inc
@@ -4,6 +4,8 @@ DESCRIPTION_update-alternatives-cworth = "Update alternatives"
4SECTION = "base" 4SECTION = "base"
5LICENSE = "GPL" 5LICENSE = "GPL"
6DEPENDS = "curl gpgme" 6DEPENDS = "curl gpgme"
7DEPENDS_virtclass-native = "curl-native"
8DEPENDS_virtclass-nativesdk = "curl-nativesdk"
7PV = "0.0+svnr${SRCREV}" 9PV = "0.0+svnr${SRCREV}"
8PE = "1" 10PE = "1"
9 11
@@ -14,9 +16,20 @@ SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
14 16
15S = "${WORKDIR}/trunk" 17S = "${WORKDIR}/trunk"
16 18
19FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/opkg"
20
17# Werror gives all kinds bounds issuses with gcc 4.3.3 21# Werror gives all kinds bounds issuses with gcc 4.3.3
18do_configure_prepend() { 22do_configure_prepend() {
19 sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am 23 sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
20} 24}
21 25
22inherit autotools_stage pkgconfig 26inherit autotools_stage pkgconfig
27
28target_libdir := "${libdir}"
29EXTRA_OECONF_virtclass-native = "--with-opkglibdir=${target_libdir} --disable-gpg"
30EXTRA_OECONF_virtclass-nativesdk = "--with-opkglibdir=${target_libdir} --disable-gpg"
31
32#PROVIDES_append_virtclass-native = "virtual/update-alternatives-native"
33#RPROVIDES_${PN} += "update-alternatives-native"
34
35BBCLASSEXTEND = "native nativesdk"